]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
add java_min_classdataversion support
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4 #   returns -ENOSYS
5 # - add macros for some ppc, mipsel, alpha and sparc
6 #
7 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
8 #
9 # Conditional build:
10 %bcond_with     static          # build static rpm+rpmi
11 %bcond_without  apidocs         # don't generate documentation with doxygen
12 %bcond_without  python          # don't build python bindings
13 %bcond_without  selinux         # build without selinux support
14 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
15 %bcond_with     db61            # use DB 6.1 instead of 5.2
16 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
17 %bcond_with     sqlite          # build with SQLite support
18 %bcond_with     system_lua      # use system lua
19 %bcond_without  system_pcre     # use system pcre
20 %bcond_with     keyutils        # build with keyutils support
21 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
22 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
23 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
24 #
25
26 %if %{with sqlite}
27 # Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
28 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
29 %endif
30
31 # versions of required libraries
32 %if %{with db61}
33 %define         reqdb_pkg       db6.1
34 %define         reqdb_ver       6.1
35 %define         reqdb_pkgver    6.1.19
36 %else
37 %define         reqdb_pkg       db5.2
38 %define         reqdb_ver       5.2
39 %define         reqdb_pkgver    5.2.36.0-4
40 %endif
41 %define         reqpopt_ver     1.15
42 %define         beecrypt_ver    2:4.2.0
43 %define         sover           5.4
44
45 Summary:        RPM Package Manager
46 Summary(de.UTF-8):      RPM Packet-Manager
47 Summary(es.UTF-8):      Gestor de paquetes RPM
48 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
49 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
50 Summary(ru.UTF-8):      Менеджер пакетов от RPM
51 Summary(uk.UTF-8):      Менеджер пакетів від RPM
52 Name:           rpm
53 Version:        5.4.15
54 Release:        39
55 License:        LGPL v2.1
56 Group:          Base
57 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
58 Source0:        %{name}-%{version}.tar.gz
59 # Source0-md5:  4067f83ca8b5bf1a21e443c0cff3efa0
60 # See README.cpu-os-macros how to update cpu-os-macros.a
61 Source100:      cpu-os-macros.a
62 Source101:      README.cpu-os-macros
63 Source1:        %{name}.groups
64 Source2:        macros.pld.in
65 Source3:        %{name}-install-tree
66 Source4:        %{name}-find-spec-bcond
67 Source5:        %{name}-hrmib-cache
68 Source6:        %{name}-groups-po.awk
69 Source7:        %{name}-compress-doc
70 Source8:        %{name}-php-provides
71 Source9:        %{name}-php-requires
72 Source10:       %{name}.sysinfo
73 Source11:       perl.prov
74 Source12:       %{name}-user_group.sh
75 Source13:       %{name}.sysconfig
76 Source14:       %{name}-java-requires
77 # http://svn.pld-linux.org/banner.sh/
78 Source15:       banner.sh
79 Source16:       ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
80 # Source16-md5: 23914bb49fafe7153cee87126d966461
81 Source17:       %{name}-mimetypedeps
82 Source18:       macros.local
83 Source19:       %{name}.noautocompressdoc
84 Source20:       %{name}.noautoprov
85 Source21:       %{name}.noautoprovfiles
86 Source22:       %{name}.noautoreq
87 Source24:       %{name}.noautoreqfiles
88 Source25:       %{name}-php-requires.php
89 Source26:       %{name}db_checkversion.c
90 Source27:       macros.lang
91 Source28:       %{name}db_reset.c
92 Source29:       dbupgrade.sh
93 Source30:       rubygems.rb
94 Source31:       gem_helper.rb
95 Patch0:         %{name}-branch.patch
96 Patch1:         %{name}-man_pl.patch
97 Patch2:         %{name}-popt-aliases.patch
98 Patch3:         %{name}-nosetproctitle.patch
99 Patch4:         %{name}-perl-macros.patch
100 Patch5:         %{name}-perl-req-perlfile.patch
101 Patch6:         %{name}-scripts-closefds.patch
102 Patch7:         %{name}-php-macros.patch
103 Patch8:         %{name}-gettext-in-header.patch
104 Patch9:         %{name}-lua.patch
105 Patch10:        %{name}-php-deps.patch
106 Patch11:        %{name}-notsc.patch
107 Patch12:        %{name}-hack-norpmlibdep.patch
108 Patch13:        %{name}-dont-copy-descriptive-tags.patch
109 Patch14:        %{name}-perl_req-INC_dirs.patch
110 Patch15:        %{name}-debuginfo.patch
111 Patch16:        vendor-pld.patch
112 Patch17:        %{name}-old-fileconflicts-behaviour.patch
113 Patch18:        %{name}-javadeps.patch
114 Patch19:        %{name}-truncate-cvslog.patch
115 Patch20:        %{name}-libtool-deps.patch
116 Patch21:        %{name}-mimetype.patch
117 Patch22:        %{name}-sparc64.patch
118 Patch23:        %{name}-gendiff.patch
119 Patch24:        openmp.patch
120 Patch25:        %{name}-URPM-build-fix.patch
121 Patch27:        %{name}-helperEVR-noassert.patch
122 Patch28:        %{name}-unglobal.patch
123 Patch29:        %{name}-builddir-readlink.patch
124 Patch30:        %{name}-changelog_order_check_nonfatal.patch
125 Patch31:        %{name}-cleanbody.patch
126 Patch32:        %{name}-dirdeps-macro.patch
127 Patch33:        %{name}-installbeforeerase.patch
128 Patch34:        %{name}-libmagic-locale.patch
129 Patch35:        %{name}-namespace-compare.patch
130 Patch36:        %{name}-popt-coreutils.patch
131 Patch37:        %{name}-postun-nofail.patch
132 Patch38:        %{name}-silence-RPM_CHAR_TYPE.patch
133 Patch39:        %{name}-fix-missing-types-in-headers.patch
134 Patch40:        %{name}-fix--p-interpreter-and-empty-script.patch
135 Patch41:        %{name}-db_buffer_small.patch
136 Patch42:        %{name}-pattern_Release.patch
137 Patch43:        %{name}-fix-___build_pre-macro.patch
138 Patch44:        %{name}-missing-patch-file-fails-build.patch
139 Patch45:        %{name}-remove-misleading-missing-patch-message.patch
140 Patch46:        %{name}-file-magic-can-be-mixed-case.patch
141 Patch47:        %{name}-query-always-noisy.patch
142 Patch48:        %{name}-verify-ghosts-broken-logic.patch
143 Patch49:        %{name}-python-enable-compat-RPMSENSE.patch
144 Patch50:        %{name}-dont-treat-gstreamer-modules-as-font.patch
145 Patch51:        %{name}-gst-inspect-typo.patch
146 Patch52:        %{name}-null-term-ascii-digest.patch
147 Patch53:        %{name}-lua-enable-extra-libs.patch
148 Patch54:        %{name}-fix-filedigests-verify.patch
149 Patch55:        %{name}-disable-hmac-verify.patch
150 Patch56:        %{name}-macros.patch
151 Patch57:        %{name}-db5.2.patch
152 Patch58:        %{name}-preserve-iterator.patch
153 Patch60:        %{name}-python-sitescriptdir.patch
154 Patch61:        %{name}-clean-docdir.patch
155 Patch62:        %{name}-DB_CONFIG.patch
156 Patch63:        %{name}-pythoneggs.patch
157 Patch64:        %{name}-fix-compress-doc.patch
158 Patch65:        %{name}-parseSpec-skip-empty-tags.patch
159 Patch66:        %{name}-payload-use-hashed-inode.patch
160 Patch67:        %{name}-repackage-dont-force-max-compression.patch
161 Patch70:        python-%{name}sense-missingok.patch
162 Patch71:        %{name}-changelog-encoding.patch
163 Patch72:        %{name}-preserve-tag-type.patch
164 Patch74:        %{name}-fix-internal-lua-build.patch
165 Patch75:        %{name}-double_check_file_deps.patch
166 Patch77:        %{name}-lua-expat.patch
167 Patch78:        %{name}-double_check_unpackaged_subdirs.patch
168 Patch79:        %{name}-rpmspec.patch
169 Patch80:        %{name}-revert-gpg-argv-parsing.patch
170 Patch81:        %{name}-perl-magic.patch
171 Patch82:        %{name}-5.4.15-use-DSA-sig.patch
172 Patch83:        %{name}-ignore-missing-macro-files.patch
173 Patch84:        x32.patch
174 Patch85:        rpm-CVE-2013-6435.patch
175 Patch86:        rpm-CVE-2014-8118.patch
176 Patch87:        %{name}-file-output-for-ELF.patch
177 Patch88:        %{name}-rpmtdnext.patch
178 Patch89:        disable-header-verification.patch
179 Patch90:        %{name}-cppcompat.patch
180 Patch91:        py-disable-fetch.patch
181 Patch92:        fast_python_deps.patch
182 Patch93:        python2_explicit.patch
183 Patch94:        do_not_write_before_macro_buffer.patch
184 Patch95:        rpm-python-spec-header.patch
185 Patch96:        skip-ldconfig-optimization.patch
186
187 # Patches imported from Mandriva
188
189 # status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
190 # would basically just mean backporting it..
191 Patch1000:      %{name}-5.4.4-add-_specfile-macro.patch
192 # status: needs to be cleaned up and properly reviewed together with rest
193 # of the patches related to dependency generation
194 Patch1001:      %{name}-5.4.9-avoid-dependencies-on-self.patch
195 # status: probably ready to merge
196 Patch1002:      %{name}-5.4.4-pkgconfigdeps-check-path.patch
197 # status: probably okay to merge, but discuss on rpm-devel first
198 Patch1003:      %{name}-5.4.4-glob-wildcards-for-loading-macro-files.patch
199 # status: needs to be discussed
200 Patch1004:      %{name}-5.4.4-allow-installation-of-repackaged-rpms.patch
201 # status: ready to merge
202 Patch1005:      %{name}-5.4.8-dont-show-suggests-with-requires.patch
203 # status: ready for merge
204 Patch1006:      %{name}-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
205 # status: probably okay to merge, but discuss on rpm-devel first
206 Patch1007:      %{name}-5.4.10-duplicate_files_terminate_build.patch
207 # status: same as above
208 Patch1008:      %{name}-5.4.10-unpackaged_subdirs_terminate_build.patch
209 # mdvbz#64898
210 # status: uncertain, might be okay to merge, discuss on rpm-devel first
211 Patch1009:      %{name}-5.4.4-rpmbuild-withoutclean.patch
212 # no sense in having an additional dependency on 'pkgconfig' on all packages that
213 # have a pkgconfig file, it's not needed for them to be made useful and anything
214 # actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
215 # status: might be okay to merge, but discuss on rpm-devel first
216 Patch1010:      %{name}-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
217 # status: ready for merge
218 Patch1011:      %{name}-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
219 # $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
220 # %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
221 # status: needs to be discussed and investigated a bit better..
222 Patch1012:      %{name}-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
223 # status: probably okay to merge, but discuss on rpm-devel first
224 Patch1013:      %{name}-5.4.10-files-listed-twice-terminates-build.patch
225 # status: probably okay to merge
226 Patch1014:      %{name}-5.4.9-ruby1.9-fixes.patch
227 # status: keep locally
228 Patch1015:      %{name}-5.4.9-keep-loading-script-macros.patch
229 # status: same as for other dep gen patches
230 Patch1016:      %{name}-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
231 # status: idem
232 Patch1017:      %{name}-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
233 # status: probably okay to merge
234 Patch1019:      %{name}-5.4.5-python-export-spec-macros.patch
235 # status: idem
236 Patch1020:      %{name}-5.4.9-font-provides.patch
237 # stauus: idem
238 Patch1021:      %{name}-5.4.7-kmod-dependencies.patch
239 # status: probably okay to merge, discuss on rpm-devel first
240 Patch1022:      %{name}-5.4.5-skip-dependencies-for-character-devices.patch
241 # status: probably okay to merge
242 Patch1024:      %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
243 # status: probably okay to merge
244 Patch1026:      %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
245 # status: ready
246 Patch1027:      %{name}-5.4.7-fix-generation-of-ruby-abi-provides.patch
247 # crash reproducable with 'rpm -qa --triggers'
248 # status: ready
249 Patch1028:      %{name}-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
250 # status: same as for other dep gen patches
251 Patch1029:      %{name}-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
252 # status: ready
253 Patch1030:      %{name}-5.4.7-fix-minor-memleaks.patch
254 # status: ready
255 Patch1031:      %{name}-5.4.9-mire-fix-strings-lacking-null-terminator.patch
256 # status: ready
257 Patch1032:      %{name}-5.4.9-rpmpython-fix-input.patch
258 # status: ready
259 Patch1033:      %{name}-5.4.7-no-seqid_init-on-rdonly-database.patch
260 # status: probably ready for merging
261 Patch1034:      %{name}-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
262 # status: probably ready to merge, discuss on rpm-devel first
263 Patch1035:      %{name}-5.4.9-fix-verify-segfault.patch
264 # Due to rpmdav/neon being written in a different fashion than other rpmio clients,
265 # the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
266 # with the result being that when unable to download files, neon will save error
267 # page as the target file.
268 # status: should go upstream, but uncertain about "correct" fix, ie. this is
269 # more of a workaround, while rewriting rpmdav code to behave consistently
270 # would be "the right thing to do". Yet I'm not fully able to grasp all of the
271 # code and don't want to spend more time just to get the API..
272 Patch1037:      %{name}-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
273 # As the transaction flags for ignoring arch & os are no longer used, there's
274 # currently no way to ignore arch & os of packages anymore. This patch adds
275 # support for doing this again by defining rpm variables and overriding
276 # --ignorearch & --ignoreos to set these.
277 # status: needs to be discussed upstream before thinking about merging
278 Patch1038:      %{name}-5.4.10-support-ignore-arch-and-os-again.patch
279 # status: ready for merge
280 Patch1039:      %{name}-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
281 # we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
282 Patch1040:      %{name}-5.4.9-support-signatures-and-digest-disablers.patch
283 # lack insight on actual functionality, which anyways seems broken, so let's
284 # disable it to avoid errors from berkeley db..
285 # status: keep locally
286 Patch1041:      %{name}-5.4.9-disable-l10ndir.patch
287 # status: ready for merge
288 Patch1042:      %{name}-5.4.9-fix-rpm_qa-pattern.patch
289 # warning: introduces memory leak
290 Patch1043:      %{name}-5.4.12-copy-Value-string.patch
291 Patch1044:      %{name}-5.4.12-fix-rpmlua-print.patch
292 Patch1045:      %{name}-5.4.12-fix-rpmpython-module-import-init.patch
293 Patch1046:      %{name}-5.4.12-truncate-output-buffer-after-use.patch
294 Patch1047:      %{name}-5.4.13-perl-bindings-do-not-use-xmalloc.patch
295 # proyvind:
296 # there's a rpmdbchk tool I wrote a while back, which might help you. although
297 # the incidents it's able to deal with is rather limited ATM... it might help
298 # you out, if not and you'll be able to solve yer problem, you could take a
299 # stab at adding support for fixing your specific problem to the util ;)
300 # https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-rpmdbchk.patch
301 Patch1048:      %{name}-5.4.14-rpmdbchk.patch
302 # https://abf.io/openmandriva/rpm/raw/master/rpm-5.4.14-no-assert-abort-with-broken-headers.patch
303 Patch1049:      %{name}-5.4.14-no-assert-abort-with-broken-headers.patch
304
305 Patch1050:      python-libx32.patch
306
307 URL:            http://rpm5.org/
308 BuildRequires:  %{reqdb_pkg}-devel >= %{reqdb_pkgver}
309 %if %{with sqlite}
310 BuildRequires:  sqlite3-devel
311 %else
312 BuildRequires:  %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
313 %endif
314 BuildRequires:  autoconf >= 2.63
315 BuildRequires:  automake >= 1.4
316 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
317 BuildRequires:  bzip2-devel >= 1.0.2-17
318 BuildRequires:  elfutils-devel >= 0.108
319 BuildRequires:  gettext-tools >= 0.19.2
320 %{?with_keyutils:BuildRequires: keyutils-devel}
321 BuildRequires:  libmagic-devel
322 %if %{with selinux}
323 BuildRequires:  libselinux-devel >= 2.1.0
324 BuildRequires:  libsemanage-devel >= 2.1.0
325 BuildRequires:  libsepol-devel >= 2.1.0
326 %endif
327 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
328 BuildRequires:  libstdc++-devel
329 BuildRequires:  libtool >= 1:1.4.2-9
330 %if %{with neon}
331 BuildRequires:  libxml2-devel
332 BuildRequires:  neon-devel >= 0.25.5
333 %endif
334 %{?with_system_lua:BuildRequires:       lua52-devel >= 5.2.2}
335 BuildRequires:  ossp-uuid-devel
336 BuildRequires:  patch >= 2.2
337 BuildRequires:  popt-devel >= %{reqpopt_ver}
338 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
339 BuildRequires:  python-modules >= 1:2.3
340 %{?with_python:BuildRequires:   rpm-pythonprov}
341 BuildRequires:  tcl
342 BuildRequires:  xz-devel
343 BuildRequires:  zlib-devel
344 %if %{with apidocs}
345 BuildRequires:  doxygen
346 BuildRequires:  ghostscript
347 BuildRequires:  graphviz
348 BuildRequires:  tetex-pdftex
349 %endif
350 %if %{with static}
351 # Require static library only for static build
352 BuildRequires:  %{reqdb_pkg}-static >= %{reqdb_pkgver}
353 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
354 BuildRequires:  bzip2-static >= 1.0.2-17
355 BuildRequires:  elfutils-static
356 BuildRequires:  glibc-static >= 2.2.94
357 BuildRequires:  libmagic-static
358 %if %{with selinux}
359 BuildRequires:  libselinux-static >= 2.1.0
360 BuildRequires:  libsemanage-static >= 2.1.0
361 BuildRequires:  libsepol-static >= 2.1.0
362 %endif
363 BuildRequires:  popt-static >= %{reqpopt_ver}
364 BuildRequires:  zlib-static
365 %endif
366 Requires(posttrans):    coreutils
367 Requires:       %{name}-base = %{version}-%{release}
368 Requires:       %{name}-lib = %{version}-%{release}
369 Requires:       beecrypt >= %{beecrypt_ver}
370 Requires:       popt >= %{reqpopt_ver}
371 Provides:       rpm-db-ver = %{reqdb_ver}
372 Obsoletes:      rpm-getdeps
373 %{!?with_static:Obsoletes:      rpm-utils-static}
374 Conflicts:      glibc < 2.2.92
375 # db4.6 poldek needed
376 Conflicts:      poldek < 0.21-0.20070703.00.3
377 # segfaults with lzma 0.42.2
378 Conflicts:      lzma-libs < 4.999.3
379 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
380 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
381
382 %define         _binary_payload         w9.gzdio
383
384 # don't require very fresh rpm.macros to build
385 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
386 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
387 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
388 %define         ppc     ppc ppc7400 ppc7450
389 %define         x8664   amd64 ia32e x86_64
390
391 # stabilize new build environment
392 %ifnarch x32
393 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
394 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
395 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
396 %else
397 # x32 is a very special case
398 %define         __newcc %{?force_cc}%{!?force_cc:x86_64-pld-linux-gnux32-gcc}
399 %define         __newcxx %{?force_cxx}%{!?force_cxx:x86_64-pld-linux-gnux32-g++}
400 %define         __newcpp %{?force_cpp}%{!?force_cpp:x86_64-pld-linux-gnux32-gcc -E}
401 %endif
402
403 %define         _rpmlibdir /usr/lib/rpm
404 %define         _noautocompressdoc      RPM-GPG-KEY
405
406 %description
407 RPM is a powerful package manager, which can be used to build,
408 install, query, verify, update, and uninstall individual software
409 packages. A package consists of an archive of files, and package
410 information, including name, version, and description.
411
412 %description -l de.UTF-8
413 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
414 Installation, Anfrage, Verifizierung, Aktualisierung und
415 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
416 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
417 Beschreibung.
418
419 %description -l es.UTF-8
420 RPM es un poderoso administrador de paquetes, que puede ser usado para
421 construir, instalar, pesquisar, verificar, actualizar y desinstalar
422 paquetes individuales de software. Un paquete consiste en un
423 almacenaje de archivos, y información sobre el paquete, incluyendo
424 nombre, versión y descripción.
425
426 %description -l pl.UTF-8
427 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
428 przebudowanie, instalację czy weryfikację dowolnego pakietu.
429 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
430 plików wchodzących w skład pakietu, zależności od innych pakietów, są
431 przechowywane w bazie danych i można je uzyskać za pomocą opcji
432 odpytywania programu rpm.
433
434 %description -l pt_BR.UTF-8
435 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
436 construir, instalar, pesquisar, verificar, atualizar e desinstalar
437 pacotes individuais de software. Um pacote consiste de um conjunto de
438 arquivos e informações adicionais, incluindo nome, versão e descrição
439 do pacote, permissões dos arquivos, etc.
440
441 %description -l ru.UTF-8
442 RPM - это мощный менеджер пакетов, который может быть использован для
443 создания, инсталляции, запросов (query), проверки, обновления и
444 удаления программных пакетов. Пакет состоит из файлового архива и
445 служебной информации, включающей название, версию, описание и другие
446 данные о пакете.
447
448 %description -l uk.UTF-8
449 RPM - це потужний менеджер пакетів, що може бути використаний для
450 створення, інсталяції, запитів (query), перевірки, поновлення та
451 видалення програмних пакетів. Пакет складається з файлового архіву та
452 службової інформації, що містить назву, версію, опис та іншу
453 інформацію про пакет.
454
455 %package base
456 Summary:        RPM base package - scripts used by rpm packages themselves
457 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
458 Group:          Base
459 Requires:       filesystem
460 Obsoletes:      rpm-scripts
461 Obsoletes:      vserver-rpm
462
463 %description base
464 The RPM base package contains scripts used by rpm packages themselves.
465 These include:
466 - scripts for adding/removing groups and users needed for rpm
467   packages,
468 - banner.sh to display %%banner messages from rpm scriptlets.
469
470 %description base -l pl.UTF-8
471 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
472 Zawiera on:
473 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
474 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
475
476 %package lib
477 Summary:        RPMs library
478 Summary(pl.UTF-8):      Biblioteki RPM-a
479 Group:          Libraries
480 Requires:       %{reqdb_pkg} >= %{reqdb_pkgver}
481 %if %{with sqlite}
482 Requires:       sqlite3 >= %{sqlite_build_version}
483 %else
484 Requires:       %{reqdb_pkg}-sql >= %{reqdb_pkgver}
485 %endif
486 Requires:       beecrypt >= %{beecrypt_ver}
487 Requires:       libmagic >= 1.15-2
488 %{?with_selinux:Requires:       libselinux >= 2.1.0}
489 Requires:       popt >= %{reqpopt_ver}
490 Obsoletes:      rpm-libs
491 # avoid SEGV caused by mixed db versions
492 Conflicts:      poldek < 0.18.1-16
493
494 %description lib
495 RPMs library.
496
497 %description lib -l pl.UTF-8
498 Biblioteki RPM-a.
499
500 %package devel
501 Summary:        Header files for rpm libraries
502 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
503 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
504 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
505 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
506 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
507 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
508 Group:          Development/Libraries
509 Requires:       %{name}-lib = %{version}-%{release}
510 Requires:       %{reqdb_pkg}-devel >= %{reqdb_pkgver}
511 Requires:       beecrypt-devel >= %{beecrypt_ver}
512 Requires:       bzip2-devel
513 Requires:       elfutils-devel
514 %{?with_keyutils:Requires:      keyutils-devel}
515 Requires:       libmagic-devel
516 %if %{with selinux}
517 Requires:       libselinux-devel
518 Requires:       libsemanage-devel
519 Requires:       libsepol-devel
520 %endif
521 Requires:       popt-devel >= %{reqpopt_ver}
522 Requires:       zlib-devel
523
524 %description devel
525 The RPM packaging system includes C libraries that make it easy to
526 manipulate RPM packages and databases. They are intended to ease the
527 creation of graphical package managers and other tools that need
528 intimate knowledge of RPM packages. This package contains header files
529 for these libraries.
530
531 %description devel -l de.UTF-8
532 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
533 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
534 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
535 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
536
537 %description devel -l es.UTF-8
538 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
539 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
540 facilitar la creación de administradores gráficos de paquetes y otras
541 herramientas que necesiten un conocimiento profundo de paquetes RPM.
542
543 %description devel -l pl.UTF-8
544 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
545 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
546 graficznych programów zarządzających pakietami oraz innych narzędzi,
547 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
548 zawiera pliki nagłówkowe wspomnianych bibliotek.
549
550 %description devel -l pt_BR.UTF-8
551 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
552 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
553 facilitar a criação de gerenciadores gráficos de pacotes e outras
554 ferramentas que precisem de conhecimento profundo de pacotes RPM.
555
556 %description devel -l ru.UTF-8
557 Система управления пакетами RPM содержит библиотеку C, которая
558 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
559 Эта библиотека предназначена для облегчения создания графических
560 пакетных менеджеров и других утилит, которым необходимо работать с
561 пакетами RPM.
562
563 %description devel -l uk.UTF-8
564 Система керування пакетами RPM містить бібліотеку C, котра спрощує
565 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
566 призначена для полегшення створення графічних пакетних менеджерів та
567 інших утиліт, що працюють з пакетами RPM.
568
569 %package static
570 Summary:        RPM static libraries
571 Summary(de.UTF-8):      RPMs statische Libraries
572 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
573 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
574 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
575 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
576 Group:          Development/Libraries
577 Requires:       %{name}-devel = %{version}-%{release}
578 Requires:       %{reqdb_pkg}-static >= %{reqdb_pkgver}
579 Requires:       beecrypt-static >= %{beecrypt_ver}
580 Requires:       bzip2-static
581 Requires:       elfutils-static
582 %{?with_keyutils:Requires:      keyutils-static}
583 Requires:       libmagic-static
584 %if %{with selinux}
585 Requires:       libselinux-static
586 Requires:       libsemanage-static
587 Requires:       libsepol-static
588 %endif
589 Requires:       popt-static >= %{reqpopt_ver}
590 Requires:       zlib-static
591
592 %description static
593 RPM static libraries.
594
595 %description static -l de.UTF-8
596 RPMs statische Libraries.
597
598 %description static -l pl.UTF-8
599 Biblioteki statyczne RPM-a.
600
601 %description static -l pt_BR.UTF-8
602 Bibliotecas estáticas para desenvolvimento.
603
604 %description static -l ru.UTF-8
605 Система управления пакетами RPM содержит библиотеку C, которая
606 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
607 Это статическая библиотека RPM.
608
609 %description static -l uk.UTF-8
610 Система керування пакетами RPM містить бібліотеку C, котра спрощує
611 роботу з пакетами RPM та відповідними базами даних. Це статична
612 бібліотека RPM.
613
614 %package utils
615 Summary:        Additional utilities for managing RPM packages and database
616 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
617 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
618 Group:          Applications/File
619 Requires:       %{name} = %{version}-%{release}
620 Requires:       popt >= %{reqpopt_ver}
621 %if %{with suggest_tags}
622 Suggests:       bzip2
623 Suggests:       gzip
624 %endif
625 Conflicts:      filesystem-debuginfo < 3.0-16
626
627 %description utils
628 Additional utilities for managing RPM packages and database.
629
630 %description utils -l de.UTF-8
631 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
632
633 %description utils -l pl.UTF-8
634 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
635
636 %package utils-perl
637 Summary:        Additional utilities for managing RPM packages and database
638 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
639 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
640 Group:          Applications/File
641 Requires:       %{name}-utils = %{version}-%{release}
642 Requires:       popt >= %{reqpopt_ver}
643
644 %description utils-perl
645 Additional utilities for managing RPM packages and database.
646
647 %description utils-perl -l de.UTF-8
648 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
649
650 %description utils-perl -l pl.UTF-8
651 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
652
653 %package utils-static
654 Summary:        Static rpm utilities
655 Summary(pl.UTF-8):      Statyczne narzędzia rpm
656 Group:          Applications/System
657 Requires:       %{name} = %{version}-%{release}
658
659 %description utils-static
660 Static rpm utilities for repairing system in case something with
661 shared libraries used by rpm become broken. Currently it contains rpmi
662 binary, which can be used to install/upgrade/remove packages without
663 using shared libraries (well, in fact with exception of NSS modules).
664
665 %description utils-static -l pl.UTF-8
666 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
667 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
668 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
669 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
670 (z wyjątkiem modułów NSS).
671
672 %package build
673 Summary:        Scripts for building binary RPM packages
674 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
675 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
676 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
677 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
678 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
679 Group:          Applications/File
680 Requires(pretrans):     coreutils
681 Requires(pretrans):     findutils
682 Requires:       %{name}-build-macros >= 1.712
683 Requires:       %{name}-utils = %{version}-%{release}
684 Requires:       /bin/id
685 Requires:       awk
686 Requires:       bzip2
687 Requires:       chrpath >= 0.10-4
688 Requires:       cpio
689 Requires:       diffutils
690 Requires:       elfutils
691 Requires:       file >= 4.17
692 Requires:       fileutils
693 Requires:       findutils
694 %ifarch athlon
695 Requires:       gcc >= 3.0.3
696 %else
697 Requires:       gcc
698 %endif
699 Requires:       glibc-devel
700 Requires:       grep
701 Requires:       gzip
702 Requires:       make
703 Requires:       patch
704 Requires:       sed >= 4.0
705 Requires:       sh-utils
706 Requires:       tar >= 1:1.22
707 Requires:       textutils
708 Requires:       which
709 Requires:       xz
710 Provides:       rpmbuild(monoautodeps)
711 Provides:       rpmbuild(noauto) = 3
712 %ifarch %{x8664}
713 Conflicts:      automake < 1:1.7.9-2
714 Conflicts:      libtool < 2:1.5-13
715 %endif
716
717 %description build
718 Scripts for building binary RPM packages.
719
720 %description build -l de.UTF-8
721 Scripts fürs Bauen binärer RPM-Pakete.
722
723 %description build -l pl.UTF-8
724 Skrypty pomocnicze do budowania binarnych RPM-ów.
725
726 %description build -l pt_BR.UTF-8
727 Este pacote contém scripts e programas executáveis que são usados para
728 construir pacotes usando o RPM.
729
730 %description build -l ru.UTF-8
731 Различные вспомогательные скрипты и исполняемые программы, которые
732 используются для сборки RPM'ов.
733
734 %description build -l uk.UTF-8
735 Різноманітні допоміжні скрипти та утиліти, які використовуються для
736 побудови RPM'ів.
737
738 %package javaprov
739 Summary:        Additional utilities for checking Java provides/requires in RPM packages
740 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
741 Group:          Applications/File
742 Requires:       %{name} = %{version}-%{release}
743 Requires:       file
744 Requires:       findutils >= 1:4.2.26
745 Requires:       mktemp
746 Requires:       unzip
747
748 %description javaprov
749 Additional utilities for checking Java provides/requires in RPM
750 packages.
751
752 %description javaprov -l pl.UTF-8
753 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
754 RPM.
755
756 %package perlprov
757 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
758 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
759 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
760 Group:          Applications/File
761 Requires:       %{name} = %{version}-%{release}
762 Requires:       perl-Encode
763 Requires:       perl-devel
764 Requires:       perl-modules
765
766 %description perlprov
767 Additional utilities for checking Perl provides/requires in RPM
768 packages.
769
770 %description perlprov -l de.UTF-8
771 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
772
773 %description perlprov -l pl.UTF-8
774 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
775 pakietach RPM.
776
777 %package pythonprov
778 Summary:        Python macros, which simplifies creation of RPM packages with Python software
779 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
780 Group:          Applications/File
781 Requires:       %{name} = %{version}-%{release}
782 Requires:       python
783 Requires:       python-setuptools
784 Requires:       python-modules
785
786 %description pythonprov
787 Python macros, which simplifies creation of RPM packages with Python
788 software.
789
790 %description pythonprov -l pl.UTF-8
791 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
792 Pythonie.
793
794 %package php-pearprov
795 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
796 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
797 Group:          Applications/File
798 Requires:       %{name} = %{version}-%{release}
799 Requires:       sed >= 4.0
800 Suggests:       php-pear-PHP_CompatInfo
801
802 %description php-pearprov
803 Additional utilities for checking PHP PEAR provides/requires in RPM
804 packages.
805
806 %description php-pearprov -l pl.UTF-8
807 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
808 pakietach RPM.
809
810 %package rubyprov
811 Summary:        Ruby tools, which simplify creation of RPM packages with Ruby software
812 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
813 Group:          Applications/File
814 Requires:       %{name} = %{version}-%{release}
815 Requires:       ruby
816 Requires:       ruby-modules
817 Requires:       ruby-rubygems
818
819 %description rubyprov
820 Ruby tools, which simplifies creation of RPM packages with Ruby
821 software.
822
823 %description rubyprov -l pl.UTF-8
824 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
825 Ruby.
826
827 %package -n python-rpm
828 Summary:        Python interface to RPM library
829 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
830 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
831 Group:          Development/Languages/Python
832 Requires:       %{name} = %{version}-%{release}
833 Requires:       python
834 Obsoletes:      rpm-python
835
836 %description -n python-rpm
837 The rpm-python package contains a module which permits applications
838 written in the Python programming language to use the interface
839 supplied by RPM (RPM Package Manager) libraries.
840
841 This package should be installed if you want to develop Python
842 programs that will manipulate RPM packages and databases.
843
844 %description -n python-rpm -l pl.UTF-8
845 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
846 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
847
848 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
849 Pythonie programy manipulujące pakietami i bazami danych rpm.
850
851 %description -n python-rpm -l pt_BR.UTF-8
852 O pacote rpm-python contém um módulo que permite que aplicações
853 escritas em Python utilizem a interface fornecida pelas bibliotecas
854 RPM (RPM Package Manager).
855
856 Esse pacote deve ser instalado se você quiser desenvolver programas em
857 Python para manipular pacotes e bancos de dados RPM.
858
859 %package apidocs
860 Summary:        RPM API documentation and guides
861 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
862 Group:          Documentation
863 %if "%{_rpmversion}" >= "5"
864 BuildArch:      noarch
865 %endif
866
867 %description apidocs
868 Documentation for RPM API and guides in HTML format generated from rpm
869 sources by doxygen.
870
871 %description apidocs -l pl.UTF-8
872 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
873 źrodeł RPM-a przez doxygen.
874
875 %prep
876 %setup -q -n %{name}-%{version}%{?subver}
877 install -d platform
878 cd platform
879 ar x %{SOURCE100}
880 cd -
881
882 #patch0 -p1
883 %patch1 -p1
884 %patch2 -p1
885 %patch3 -p1
886 %patch4 -p1
887 %patch5 -p1
888 %patch6 -p1
889 %patch7 -p1
890 %patch8 -p1
891 %{?with_system_lua:%patch9 -p1}
892 %patch10 -p1
893 %ifnarch i386 i486
894 # enable TSC for capable archs
895 %patch11 -p1
896 %endif
897 %patch12 -p1
898 %patch13 -p1
899 %patch14 -p0
900 %patch15 -p1
901 %patch16 -p1
902 %patch17 -p1
903 %patch18 -p1
904 %patch19 -p1
905 %patch20 -p1
906 %patch21 -p1
907 %ifarch sparc64
908 %patch22 -p1
909 %endif
910 %patch23 -p1
911 %patch24 -p1
912 %patch25 -p1
913 %patch27 -p1
914 %patch28 -p1
915 %patch29 -p1
916 %patch30 -p1
917 %patch31 -p1
918 %patch32 -p1
919 %patch33 -p1
920 %patch34 -p1
921 %patch35 -p1
922 %patch36 -p1
923 %patch37 -p1
924 %patch38 -p1
925 %patch39 -p1
926 %patch40 -p1
927 %{?with_db61:%patch41 -p1}
928 %patch42 -p1
929 %patch43 -p1
930 %patch44 -p1
931 %patch45 -p1
932 %patch46 -p1
933 %patch47 -p1
934 %patch48 -p1
935 %patch49 -p1
936 %patch50 -p1
937 %patch51 -p1
938 %patch52 -p0
939 %patch53 -p1
940 %patch54 -p1
941 %patch55 -p1
942 %patch56 -p1
943 %{!?with_db61:%patch57 -p1}
944 %patch58 -p1
945 %patch60 -p1
946 %patch61 -p1
947 %patch62 -p1
948 %patch63 -p1
949 %patch64 -p1
950 %patch65 -p1
951 %patch66 -p1
952 %patch67 -p1
953 %patch70 -p1
954 %patch71 -p1
955 %patch72 -p1
956 %patch74 -p1
957 %patch75 -p1
958 %patch77 -p0
959 %patch78 -p1
960 %patch79 -p1
961 %patch80 -p1
962 %patch81 -p0
963 %patch82 -p1
964 %patch84 -p1
965 %patch85 -p1
966 %patch86 -p1
967 %patch87 -p1
968 %patch88 -p1
969 %patch89 -p1
970 %patch90 -p1
971 %patch91 -p1
972
973 %patch1000 -p1
974 %patch1001 -p1
975 %patch1002 -p1
976 %patch1003 -p1
977 %patch1004 -p1
978 %patch1005 -p1
979 %patch1006 -p1
980 %patch1007 -p1
981 %patch1008 -p1
982 %patch1009 -p1
983 %patch1010 -p1
984 %patch1011 -p1
985 %patch1012 -p1
986 %patch1013 -p1
987 %patch1014 -p1
988 %patch1015 -p1
989 %patch1016 -p1
990 %patch1017 -p1
991 %patch1019 -p1
992 %patch1020 -p1
993 %patch1021 -p1
994 %patch1022 -p1
995 %patch1024 -p1
996 %patch1026 -p1
997 %patch1027 -p1
998 %patch1028 -p1
999 %patch1029 -p1
1000 %patch1030 -p1
1001 %patch1031 -p1
1002 %patch1032 -p1
1003 %patch1033 -p1
1004 %patch1034 -p1
1005 %patch1035 -p1
1006 %patch1037 -p1
1007 %patch1038 -p1
1008 %patch1039 -p1
1009 %patch1040 -p1
1010 # don't delete, may be usefull if jbj descides to enable this again
1011 #%patch1041 -p1
1012 %patch1042 -p1
1013 %patch1043 -p1
1014 %patch1044 -p1
1015 %patch1045 -p1
1016 %patch1046 -p1
1017 %patch1047 -p1
1018 %patch1048 -p1
1019 %patch1049 -p1
1020
1021 %patch83 -p1
1022 %patch92 -p1
1023 %patch93 -p1
1024 %patch94 -p1
1025 %patch95 -p1
1026 %patch96 -p1
1027
1028 %patch1050 -p1
1029
1030 install %{SOURCE2} macros/pld.in
1031 install %{SOURCE8} scripts/php.prov.in
1032 install %{SOURCE9} scripts/php.req.in
1033 install %{SOURCE11} scripts/perl.prov.in
1034 cp -p %{SOURCE30} scripts/rubygems.rb
1035 cp -p %{SOURCE31} scripts/gem_helper.rb
1036
1037 rm scripts/find-php*
1038
1039 %{__mv} -f scripts/perl.req{,.in}
1040
1041 # generate Group translations to *.po
1042 awk -f %{SOURCE6} %{SOURCE1}
1043
1044 install %{SOURCE26} tools/rpmdb_checkversion.c
1045 install %{SOURCE28} tools/rpmdb_reset.c
1046
1047 for extlib in beecrypt neon %{?with_system_pcre:pcre} popt; do
1048         [ -d $extlib ] && %{__rm} -r $extlib
1049 done
1050
1051 %build
1052 %{__libtoolize}
1053 #%{__autopoint}
1054 %{__aclocal}
1055 %{__autoheader}
1056 %{__autoconf}
1057 %{__automake}
1058
1059 # rpm checks for CPU type at runtime, but it looks better
1060 sed -i \
1061         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
1062         -e 's|@host_cpu@|%{_target_cpu}|' \
1063         -e 's|@host_os@|%{_target_os}|' \
1064         macros/macros.in
1065
1066 %{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
1067 # pass CC and CXX too in case of building with some older configure macro
1068 %configure \
1069         CC="%{__newcc}" \
1070         CXX="%{__newcxx}" \
1071         CPP="%{__newcpp}" \
1072         WITH_PERL_VERSION=no \
1073         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
1074         --disable-silent-rules \
1075         --enable-shared \
1076         --enable-static \
1077         %{!?with_apidocs:--without-apidocs} \
1078         --with-beecrypt=external \
1079         --with-bugreport="http://bugs.pld-linux.org/" \
1080         --with-bzip2=external \
1081         --with-db=external \
1082         --with-dbapi=db \
1083         --with-file=external \
1084         --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
1085         --with-libelf \
1086         --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
1087         --with-lzma=external \
1088         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
1089         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
1090         --without-path-versioned \
1091         --with-pcre=%{!?with_system_pcre:internal}%{?with_system_pcre:external} \
1092         --with-popt=external \
1093         %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
1094         %{!?with_python:--without-python} \
1095         --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
1096         --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
1097         --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
1098         --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
1099         --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
1100         --with-vendor=pld \
1101         --with-xz=external \
1102         --with-zlib=external
1103
1104 %{__make} -j1 \
1105         CC="%{__cc}" \
1106         CXX="%{__cxx}" \
1107         CPP="%{__cpp}"
1108
1109 %{?with_apidocs:%{__make} apidocs}
1110
1111 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
1112         -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
1113 %{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
1114         -o tools/rpmdb_reset -ldb-%{reqdb_ver}
1115
1116 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
1117         echo "Error linking rpmdb tools!"
1118         exit 1
1119 fi
1120 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
1121         echo "Error linking rpmdb tools!"
1122         exit 1
1123 fi
1124
1125 %install
1126 rm -rf $RPM_BUILD_ROOT
1127 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
1128         $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
1129
1130 install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1131
1132 %{__make} -j1 install \
1133         pkgconfigdir=%{_pkgconfigdir} \
1134         DESTDIR=$RPM_BUILD_ROOT
1135
1136 # install platform macros
1137 for f in platform/*macros; do
1138         bn=${f#*/}
1139         fn=${bn%.macros}/macros
1140         install -m644 $f -D %{buildroot}%{_rpmlibdir}/$fn
1141 done
1142
1143 # cleanup
1144 %ifnarch %{ix86} %{x8664} x32
1145 rm $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
1146 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
1147 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
1148 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
1149 rm $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
1150 rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
1151 rm $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
1152 %endif
1153
1154 %ifnarch %{x8664} x32
1155 rm $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
1156 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
1157 rm $RPM_BUILD_ROOT%{_rpmlibdir}/x32-linux/macros
1158 rm $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
1159 %endif
1160
1161 %ifnarch %{ppc}
1162 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
1163 %endif
1164
1165 rm $RPM_BUILD_ROOT%{_rpmlibdir}/alpha*-linux/macros
1166 rm $RPM_BUILD_ROOT%{_rpmlibdir}/arm*-linux/macros
1167 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ia64-linux/macros
1168 rm $RPM_BUILD_ROOT%{_rpmlibdir}/k6-linux/macros
1169 rm $RPM_BUILD_ROOT%{_rpmlibdir}/mips*-linux/macros
1170 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc*series-linux/macros
1171 rm $RPM_BUILD_ROOT%{_rpmlibdir}/ppc64*-linux/macros
1172 rm $RPM_BUILD_ROOT%{_rpmlibdir}/s390*-linux/macros
1173 rm $RPM_BUILD_ROOT%{_rpmlibdir}/sparc*-linux/macros
1174
1175 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1176 # first platform file entry can't contain regexps
1177 %ifarch x32
1178 %{_target_cpu}-%{_target_vendor}-linux-gnux32
1179 %else
1180 %{_target_cpu}-%{_target_vendor}-linux
1181 %endif
1182
1183 %ifarch x86_64
1184 x86_64-[^-]*-[Ll]inux(-gnu)?
1185 amd64-[^-]*-[Ll]inux(-gnu)?
1186 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
1187 %endif
1188 %ifarch amd64
1189 amd64-[^-]*-[Ll]inux(-gnu)?
1190 x86_64-[^-]*-[Ll]inux(-gnu)?
1191 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
1192 %endif
1193 %ifarch ia32e
1194 ia32e-[^-]*-[Ll]inux(-gnu)?
1195 x86_64-[^-]*-[Ll]inux(-gnu)?
1196 %endif
1197 %ifarch x32
1198 x32-[^-]*-[Ll]inux(-gnu(x32)?)?
1199 x86_64-[^-]*-[Ll]inux(-gnu)?
1200 amd64-[^-]*-[Ll]inux(-gnu)?
1201 %endif
1202
1203 %ifarch athlon %{x8664} x32
1204 athlon-[^-]*-[Ll]inux(-gnu)?
1205 %endif
1206 %ifarch pentium4 athlon %{x8664} x32
1207 pentium4-[^-]*-[Ll]inux(-gnu)?
1208 %endif
1209 %ifarch pentium3 pentium4 athlon %{x8664} x32
1210 pentium3-[^-]*-[Ll]inux(-gnu)?
1211 %endif
1212 %ifarch i686 pentium3 pentium4 athlon %{x8664} x32
1213 i686-[^-]*-[Ll]inux(-gnu)?
1214 %endif
1215 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664} x32
1216 i586-[^-]*-[Ll]inux(-gnu)?
1217 %endif
1218 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32
1219 i486-[^-]*-[Ll]inux(-gnu)?
1220 %endif
1221 %ifarch %{ix86} %{x8664} x32
1222 i386-[^-]*-[Ll]inux(-gnu)?
1223 %endif
1224
1225 %ifarch alpha
1226 alpha-[^-]*-[Ll]inux(-gnu)?
1227 %endif
1228
1229 %ifarch ia64
1230 ia64-[^-]*-[Ll]inux(-gnu)?
1231 %endif
1232
1233 %ifarch ppc64
1234 powerpc64-[^-]*-[Ll]inux(-gnu)?
1235 ppc64-[^-]*-[Ll]inux(-gnu)?
1236 %endif
1237 %ifarch %{ppc} ppc64
1238 powerpc-[^-]*-[Ll]inux(-gnu)?
1239 ppc-[^-]*-[Ll]inux(-gnu)?
1240 %endif
1241
1242 %ifarch s390x
1243 s390x-[^-]*-[Ll]inux(-gnu)?
1244 %endif
1245 %ifarch s390 s390x
1246 s390-[^-]*-[Ll]inux(-gnu)?
1247 %endif
1248
1249 %ifarch sparc64
1250 sparc64-[^-]*-[Ll]inux(-gnu)?
1251 sparcv8-[^-]*-[Ll]inux(-gnu)?
1252 sparcv9-[^-]*-[Ll]inux(-gnu)?
1253 %endif
1254 %ifarch sparcv9
1255 sparcv8-[^-]*-[Ll]inux(-gnu)?
1256 sparcv9-[^-]*-[Ll]inux(-gnu)?
1257 %endif
1258 %ifarch sparc sparcv9 sparc64
1259 sparc-[^-]*-[Ll]inux(-gnu)?
1260 %endif
1261
1262 noarch-[^-]*-.*
1263 EOF
1264
1265 # Squash Extra Blank Lines
1266 %{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
1267
1268 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1269 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1270 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
1271 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
1272 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
1273 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
1274 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
1275 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
1276
1277 # not installed since 4.4.8 (-tools-perl subpackage)
1278 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1279
1280 install %{SOURCE1} doc/manual/groups
1281 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
1282 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1283 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
1284 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1285 install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
1286 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
1287 cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1288 install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
1289 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
1290 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
1291
1292 install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
1293
1294 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1295
1296 install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
1297 install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
1298 install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1299 install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1300 install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1301 install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1302 install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
1303
1304 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1305 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
1306 install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
1307 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1308 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1309 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
1310
1311 install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1312 install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1313 install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
1314
1315 # create macro loading wrappers for backward compatibility
1316 for m in gstreamer java mono perl php python; do
1317         echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
1318 done
1319
1320 # moved to rpm-build-macros 1.699
1321 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/macros.d/kernel
1322
1323 # for rpm -e|-U --repackage
1324 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1325 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
1326
1327 # move rpm to /bin
1328 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1329 # move essential libs to /lib (libs that /bin/rpm links to)
1330 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
1331         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1332         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
1333 done
1334
1335 # Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1336 mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1337
1338 %if %{with python}
1339 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1340 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
1341
1342 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
1343 %endif
1344
1345 # wrong location, not used anyway
1346 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
1347 # utils dropped in 5.4 -- their manuals
1348 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
1349 # script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1350 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
1351
1352 %find_lang %{name}
1353
1354 %{__rm} -rf manual
1355 cp -a doc/manual manual
1356 %{__rm} -f manual/Makefile*
1357
1358 %clean
1359 rm -rf $RPM_BUILD_ROOT
1360
1361 %pretrans
1362 # this needs to be a dir
1363 if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
1364         umask 022
1365         mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1366         mkdir %{_sysconfdir}/rpm/sysinfo
1367 fi
1368
1369 %posttrans
1370 if [ -e /var/lib/rpm/Packages ] && \
1371                 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
1372         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
1373                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
1374                 echo
1375                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
1376                 echo
1377         fi
1378         echo
1379         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1380         echo 'you should ignore it and restart poldek'
1381         echo
1382         %{_rpmlibdir}/bin/dbupgrade.sh
1383 fi
1384
1385 %triggerpostun -- %{name} < 4.4.9-44
1386 %{_rpmlibdir}/hrmib-cache
1387
1388 %post   lib -p /sbin/ldconfig
1389 %postun lib -p /sbin/ldconfig
1390
1391 %pretrans build
1392 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
1393
1394 %files -f %{name}.lang
1395 %defattr(644,root,root,755)
1396 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
1397
1398 %dir /etc/pki/rpm-gpg
1399 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1400
1401 %attr(755,root,root) /bin/rpm
1402
1403 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1404 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
1405 %dir %{_sysconfdir}/rpm/sysinfo
1406 # these are ok to be replaced
1407 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
1408 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1409
1410 %{_mandir}/man8/rpm.8*
1411 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1412 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1413 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1414 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1415 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1416
1417 %dir /var/lib/rpm
1418 %dir /var/lib/rpm/log
1419 %dir /var/lib/rpm/tmp
1420 %config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
1421 %dir %attr(700,root,root) /var/spool/repackage
1422 %dir /var/lock/rpm
1423 /var/lock/rpm/transaction
1424
1425 # exported package NVRA (stamped with install tid)
1426 # net-snmp hrSWInstalledName queries, bash-completions
1427 %dir /var/cache/hrmib
1428
1429 %{_rpmlibdir}/qf
1430 %{_rpmlibdir}/rpmpopt*
1431 %{_rpmlibdir}/macros
1432 %dir %{_rpmlibdir}/macros.d
1433 %{_rpmlibdir}/macros.d/pld
1434 %{_rpmlibdir}/cpuinfo.yaml
1435 %{_rpmlibdir}/noarch-*
1436 %ifarch %{ix86} %{x8664} x32
1437 %{_rpmlibdir}/i?86*
1438 %{_rpmlibdir}/pentium*
1439 %{_rpmlibdir}/athlon*
1440 %endif
1441 %ifarch alpha
1442 %{_rpmlibdir}/alpha*
1443 %endif
1444 %ifarch ia64
1445 %{_rpmlibdir}/ia64*
1446 %endif
1447 %ifarch mips mipsel mips64 mips64el
1448 %{_rpmlibdir}/mips*
1449 %endif
1450 %ifarch %{ppc}
1451 %{_rpmlibdir}/ppc*
1452 %endif
1453 %ifarch sparc sparc64
1454 %{_rpmlibdir}/sparc*
1455 %endif
1456 %ifarch %{x8664} x32
1457 %{_rpmlibdir}/amd64*
1458 %{_rpmlibdir}/ia32e*
1459 %{_rpmlibdir}/x86_64*
1460 %{_rpmlibdir}/x32*
1461 %endif
1462
1463 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1464
1465 %dir %{_rpmlibdir}/bin
1466 %attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
1467 %attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
1468 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
1469 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
1470 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
1471
1472 %files base
1473 %defattr(644,root,root,755)
1474 %dir %{_sysconfdir}/rpm
1475 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1476 %dir %{_rpmlibdir}
1477 %attr(755,root,root) %{_bindir}/banner.sh
1478 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1479 %dir /var/lib/banner
1480
1481 %files lib
1482 %defattr(644,root,root,755)
1483 %attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1484 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1485 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1486 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
1487 %attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
1488 %attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
1489
1490 %files devel
1491 %defattr(644,root,root,755)
1492 %attr(755,root,root) %{_libdir}/librpm.so
1493 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1494 %attr(755,root,root) %{_libdir}/librpmbuild.so
1495 %attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
1496 %attr(755,root,root) %{_libdir}/librpmconstant.so
1497 %attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
1498 %attr(755,root,root) %{_libdir}/librpmdb.so
1499 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1500 %attr(755,root,root) %{_libdir}/librpmio.so
1501 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1502 %attr(755,root,root) %{_libdir}/librpmmisc.so
1503 %attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
1504 %{_libdir}/librpm*.la
1505 %{_includedir}/rpm
1506 %{_pkgconfigdir}/*.pc
1507
1508 %files static
1509 %defattr(644,root,root,755)
1510 %{_libdir}/librpm*.a
1511
1512 %files utils
1513 %defattr(644,root,root,755)
1514 %attr(755,root,root) %{_bindir}/rpm2cpio
1515 %attr(755,root,root) %{_bindir}/rpmconstant
1516 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1517 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1518 %attr(755,root,root) %{_rpmlibdir}/tgpg
1519 %attr(755,root,root) %{_rpmlibdir}/bin/chroot
1520 %attr(755,root,root) %{_rpmlibdir}/bin/cp
1521 %attr(755,root,root) %{_rpmlibdir}/bin/debugedit
1522 %attr(755,root,root) %{_rpmlibdir}/bin/find
1523 %attr(755,root,root) %{_rpmlibdir}/bin/mgo
1524 %attr(755,root,root) %{_rpmlibdir}/bin/mtree
1525 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1526 %attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1527 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1528 %attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1529 %if %{with selinux}
1530 %attr(755,root,root) %{_rpmlibdir}/bin/semodule
1531 %attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1532 %endif
1533 %if %{without system_lua}
1534 %attr(755,root,root) %{_rpmlibdir}/bin/lua
1535 %attr(755,root,root) %{_rpmlibdir}/bin/luac
1536 %attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1537 %attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1538 %endif
1539 %{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
1540 %attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
1541 %{_mandir}/man8/rpm2cpio.8*
1542 %{_mandir}/man8/rpmconstant.8*
1543 %{_mandir}/man8/rpmdeps.8*
1544 %{_mandir}/man8/rpmmtree.8*
1545 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1546 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1547 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1548 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1549
1550 %files utils-perl
1551 %defattr(644,root,root,755)
1552 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1553
1554 %if %{with static}
1555 %files utils-static
1556 %defattr(644,root,root,755)
1557 %attr(755,root,root) %{_bindir}/rpm[ieu]
1558 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1559 %endif
1560
1561 %files build
1562 %defattr(644,root,root,755)
1563 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1564 %attr(755,root,root) %{_rpmlibdir}/brp-*
1565 %attr(755,root,root) %{_rpmlibdir}/check-files
1566 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1567 %attr(755,root,root) %{_rpmlibdir}/cross-build
1568 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1569 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1570 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1571 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1572 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1573 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1574 %attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
1575 # needs hacked pkg-config to return anything
1576 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1577 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1578 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
1579 %{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
1580 %attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1581 %attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
1582 %attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1583 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
1584 %attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1585 %attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1586 %attr(755,root,root) %{_rpmlibdir}/bin/wget
1587 %attr(755,root,root) %{_rpmlibdir}/vcheck
1588 # not used yet ... these six depend on perl
1589 %attr(755,root,root) %{_rpmlibdir}/http.req
1590 # we always used scripts provided by mono-devel, maybe move them here
1591 #%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1592 #%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
1593
1594 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
1595 # must be here for "Requires: rpm-*prov" to work
1596 %{_rpmlibdir}/macros.d/cmake
1597 %{_rpmlibdir}/macros.d/gstreamer
1598 %{_rpmlibdir}/macros.d/java
1599 %{_rpmlibdir}/macros.d/libtool
1600 %{_rpmlibdir}/macros.d/mono
1601 %{_rpmlibdir}/macros.d/perl
1602 %{_rpmlibdir}/macros.d/php
1603 %{_rpmlibdir}/macros.d/pkgconfig
1604 %{_rpmlibdir}/macros.d/python
1605 %{_rpmlibdir}/macros.d/ruby
1606 %{_rpmlibdir}/macros.d/selinux
1607 %{_rpmlibdir}/macros.d/tcl
1608 %{_rpmlibdir}/macros.rpmbuild
1609 # compat wrappers
1610 %{_rpmlibdir}/macros.gstreamer
1611 %{_rpmlibdir}/macros.java
1612 %{_rpmlibdir}/macros.mono
1613 %{_rpmlibdir}/macros.perl
1614 %{_rpmlibdir}/macros.php
1615 %{_rpmlibdir}/macros.python
1616
1617 %attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1618 %attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1619
1620 %attr(755,root,root) %{_bindir}/gendiff
1621 %attr(755,root,root) %{_bindir}/rpmbuild
1622
1623 %dir %{_rpmlibdir}/helpers
1624 %attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
1625
1626 %{_mandir}/man1/gendiff.1*
1627 %{_mandir}/man8/rpmbuild.8*
1628 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1629 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1630 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1631
1632 %files javaprov
1633 %defattr(644,root,root,755)
1634 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1635 # needs jar (any jdk), jcf-dump (gcc-java) to work
1636 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1637
1638 %files rubyprov
1639 %defattr(644,root,root,755)
1640 %attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1641 %attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1642
1643 %files perlprov
1644 %defattr(644,root,root,755)
1645 %attr(755,root,root) %{_rpmlibdir}/perl.*
1646 %attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1647 %attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1648
1649 %files pythonprov
1650 %defattr(644,root,root,755)
1651 %attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
1652 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1653
1654 %files php-pearprov
1655 %defattr(644,root,root,755)
1656 %attr(755,root,root) %{_rpmlibdir}/php.prov
1657 %attr(755,root,root) %{_rpmlibdir}/php.req
1658 %attr(755,root,root) %{_rpmlibdir}/php.req.php
1659
1660 %if %{with python}
1661 %files -n python-rpm
1662 %defattr(644,root,root,755)
1663 %dir %{py_sitedir}/rpm
1664 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1665 %{py_sitedir}/rpm/*.py[co]
1666 %endif
1667
1668 %if %{with apidocs}
1669 %files apidocs
1670 %defattr(644,root,root,755)
1671 %doc apidocs
1672 %endif
This page took 0.229437 seconds and 3 git commands to generate.