]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- support for make-request.sh style of passing cvstag
authorAdam Gołębiowski <adamg@pld-linux.org>
Tue, 17 Jan 2006 13:22:42 +0000 (13:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    builder.sh -> 1.380

builder.sh

index 3a04df722677055307eded64f5695a9634ffa139..4f2c07a214d53eac6ae5d7e3de99f00aed7abd37 100644 (file)
@@ -187,7 +187,7 @@ Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
 [-Ts|--tag-stable] [-Tn|--tag-nest] [-Tv|--tag-version]
 [{-Tp|--tag-prefix} <prefix>] [{-tt|--test-tag}]
 [-nu|--no-urls] [-v|--verbose] [--opts <rpm opts>] [--show-bconds]
-[--with/--without <feature>] [--define <macro> <value>] <package>[.spec]
+[--with/--without <feature>] [--define <macro> <value>] <package>[.spec][:cvstag]
 
 -5, --update-md5    - update md5 comments in spec, implies -nd -ncs
 -a5, --add-md5      - add md5 comments to URL sources, implies -nc -nd -ncs
@@ -1702,6 +1702,11 @@ do
                        RPMOPTS="${RPMOPTS} -debug"; shift ;;
                * )
                        SPECFILE="${1}"
+                       # check if specname was passed as specname:cvstag
+                       if [ "${SPECFILE##*:}" != "${SPECFILE}" ]; then
+                               CVSTAG="${SPECFILE##*:}";
+                               SPECFILE="${SPECFILE%%:*}";
+                       fi
                        export PROMPT_COMMAND=`echo -ne "\033]0;${SPECFILE}\007"`
                        shift ;;
        esac
This page took 0.129333 seconds and 4 git commands to generate.