]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- updated
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 8 Nov 2006 19:16:46 +0000 (19:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    pearize.sh -> 1.41

pearize.sh

index ec2b196613dce840e19fc7932a3e6dc2379c9c7b..a70888fe2ae899235e1104336e4a1b53e7f037d9 100644 (file)
@@ -35,6 +35,10 @@ getsource() {
 }
 
 tarball=$(getsource $spec 0)
+if [ -z "$tarball" ]; then
+       echo >&2 "Spec is missing Source0!"
+       exit 1
+fi
 
 if [ ! -f $tarball ]; then
        ./builder -g "$spec"
@@ -49,7 +53,7 @@ Optional: @optional@
 License: @release_license@
 State: @release_state@
 EOF
-pear make-rpm-spec --spec-template=$stmp --rpm-pkgname=pearize $tarball
+pear make-rpm-spec --spec-template=$stmp --output=pearize.spec $tarball
 template=pearize.spec
 rm -f $stmp
 
This page took 0.0318929999999999 seconds and 4 git commands to generate.