]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- added $MAILER instead of /usr/sbin/sendmail with commented out
authortwittner <twittner@pld-linux.org>
Tue, 25 Dec 2007 16:35:57 +0000 (16:35 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
suggestion how to use this script with msmtp

Changed files:
    fetchsrc_request -> 1.18

fetchsrc_request

index 6084983bab4467e3108bae83a8fb369938b0d57e..41833996d56d40ed8bafa8700fac099fdf9a7e53 100644 (file)
@@ -1,11 +1,16 @@
 #!/bin/sh
 # $Id$
 #
+# Sending by
+MAILER='/usr/sbin/sendmail'
+# MAILER='/usr/bin/msmtp'
 # Sending via
 VIA="SENDMAIL"
 #VIA="localhost"
 VIA_ARGS=""
 #VIA_ARGS="some additional flags"
+# e.g. for msmtp:
+# VIA_ARGS='-a gmail'
 #
 # DISTFILES EMAIL
 DMAIL="distfiles@pld-linux.org"
@@ -45,8 +50,8 @@ if [[ "$SPEC" != *.spec ]]; then
 fi
 
 if [ "$VIA" = "SENDMAIL" ]; then
-       echo >&2 "Requesting $SPEC:$BRANCH via sendmail${VIA_ARGS:+ ($VIA_ARGS)}"
-       cat <<EOF | /usr/sbin/sendmail -t $VIA_ARGS
+       echo >&2 "Requesting $SPEC:$BRANCH via $MAILER ${VIA_ARGS:+ ($VIA_ARGS)}"
+       cat <<EOF | "$MAILER" -t -i $VIA_ARGS
 To: $DMAIL
 From: $LOGIN <$LOGIN@$HOST>
 Subject: fetchsrc_request notify
This page took 0.033035 seconds and 4 git commands to generate.