]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
update-geoip: allow use .spec files in args
authorElan Ruusamäe <glen@delfi.ee>
Thu, 22 May 2014 07:16:33 +0000 (10:16 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 22 May 2014 07:16:33 +0000 (10:16 +0300)
update-geoip.sh

index 20d27eb179084bcafeef58b413ca8c9058187397..21e425a9e3e6a9336594f04c24353b314c193f13 100755 (executable)
@@ -115,6 +115,7 @@ cd "$dir"
 
 pkgs='GeoIP-db-City GeoIP-db-Country GeoIP-db-IPASNum xtables-geoip'
 for pkg in ${*:-$pkgs}; do
+       pkg=${pkg%.spec}
        $status && continue
 
        get_package $pkg
@@ -132,6 +133,7 @@ done
 
 # report each package git status
 for pkg in ${*:-$pkgs}; do
+       pkg=${pkg%.spec}
        cd $pkg
        git status --porcelain
        cd ..
This page took 0.034868 seconds and 4 git commands to generate.