]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- always have SPECFILE ending with .spec extension, or 'builder -g mailcap' will...
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 25 Nov 2009 20:34:38 +0000 (20:34 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    builder.sh -> 1.599

builder.sh

index a466ef6be379136ccc4ad8a620e37ab23652bee8..2dcfbe2a13442694529066c5513b3009148d7603 100644 (file)
@@ -2212,14 +2212,15 @@ while [ $# -gt 0 ]; do
                        Exit_error err_invalid_cmdline "$1"
                        ;;
                *)
-                       SPECFILE="${1}"
+                       SPECFILE=$1; shift
                        # check if specname was passed as specname:cvstag
                        if [ "${SPECFILE##*:}" != "${SPECFILE}" ]; then
                                CVSTAG="${SPECFILE##*:}"
                                SPECFILE="${SPECFILE%%:*}"
                        fi
+                       # always have SPECFILE ending with .spec extension
+                       SPECFILE=${SPECFILE%%.spec}.spec
                        ASSUMED_NAME=$(basename ${SPECFILE%%.spec})
-                       shift
        esac
 done
 
This page took 0.027159 seconds and 4 git commands to generate.