]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- autoadd .spec ext to spec
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 28 Oct 2010 21:10:09 +0000 (21:10 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    repackage.sh -> 1.32

repackage.sh

index 460f68a322f0e5fc36512224aa089accc2d74b08..2a4d834519d934727c72576c99171132ec3e4b04 100644 (file)
@@ -95,6 +95,10 @@ if [ $# = 0 ]; then
                echo >&2 "Usage: ${0##*/} PACKAGE.spec"
                exit 1
        fi
+else
+       # $1 must be spec, ensure it has .spec ext
+       spec=$1; shift
+       set -- ${spec#.spec}.spec "$@"
 fi
 
 tmp=$(specdump "$@" | awk '$2 == "_target_cpu" {print $3}')
This page took 0.143825 seconds and 4 git commands to generate.