]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- ignore Sticky tag, etc lines for autotag()
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 23 Jan 2008 18:20:21 +0000 (18:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-build.sh -> 1.41

rpm-build.sh

index 208281beb387a5019d3230df68b1ea09a0c90719..3632efb40a1748b0915713961f1e586550a0df3e 100644 (file)
@@ -64,7 +64,7 @@ autotag() {
        local out
        for a in "$@"; do
                s=${a%.spec}.spec
        local out
        for a in "$@"; do
                s=${a%.spec}.spec
-               out=$(cvs status -v $s | awk "/auto-$dist-/{if (!a++) print \$1}")
+               out=$(cvs status -v $s | awk "!/Sticky/&&/auto-$dist-/{if (!a++) print \$1}")
                echo "$s:$out"
        done
 }
                echo "$s:$out"
        done
 }
This page took 0.036967 seconds and 4 git commands to generate.