]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- glob *.spec
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 12 Feb 2010 11:44:06 +0000 (11:44 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    md5 -> 1.3

md5

diff --git a/md5 b/md5
index 829e14d20bbe970926c240a1e5c4e2cddf299508..03b99931ce79d32aeb426c7f8547d5b53a9c7672 100644 (file)
--- a/md5
+++ b/md5
@@ -7,4 +7,14 @@ else
        builder=builder
 fi
 
+if [ $# = 0 ]; then
+       # if no spec name passed, glob *.spec
+       set -- *.spec
+       if [ ! -f "$1" -o $# -gt 1 ]; then
+               echo >&2 "ERROR: Too many or too few .spec files found"
+               echo >&2 "Usage: ${0##*/} PACKAGE.spec"
+               exit 1
+       fi
+fi
+
 $builder -ncs -5 "$@"
This page took 0.065387 seconds and 4 git commands to generate.