]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
comment some code logic
authorElan Ruusamäe <glen@delfi.ee>
Tue, 7 Aug 2012 05:08:15 +0000 (08:08 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 7 Aug 2012 05:08:15 +0000 (08:08 +0300)
relup.sh

index 6680d95611565a2f1c0c0b12d682f1942c634a3d..5c308ba3e32ce483e9b2de78001fc93a3631da5f 100755 (executable)
--- a/relup.sh
+++ b/relup.sh
@@ -93,6 +93,11 @@ done
 
 tmpd=$(mktemp -d "${TMPDIR:-/tmp}/relXXXXXX")
 topdir=$(rpm -E '%{_topdir}')
+
+# round 1: get packages and update .spec files
+# batches changes for each release
+# TODO: drop this, in git need to commit and push each package separately, no
+# way to group changes as in CVS
 cd "$topdir"
 for pkg in "$@"; do
        name=${pkg%.spec} name=${name##*/}
@@ -119,6 +124,7 @@ for pkg in "$@"; do
        echo "$spec" >> "$tmpd/$rel"
 done
 
+# round 2: commit the changes
 n="$(echo -e '\nn')"
 n="${n%%n}"
 for rel in $(ls "$tmpd" 2>/dev/null); do
This page took 0.053555 seconds and 4 git commands to generate.