]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- added obsoletes for qemu-kvm packages
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 # - qemu-system-ppc -hda ac-ppc.img says:
4 #   qemu: could not open disk image ac-ppc.img: error "Success"
5 #   qemu-0.12.2-2.x86_64.rpm - broken
6 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
7 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
8 #   qemu-0.11.1-*.x86_64.rpm - OK
9 #
10 # Conditional build:
11 %bcond_without  sdl             # SDL UI and audio support
12 %bcond_without  glx             # OpenGL/GLX support
13 %bcond_without  ceph            # Ceph/RBD support
14 %bcond_without  glusterfs       # GlusterFS backend
15 %bcond_without  rdma            # RDMA-based migration support
16 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
17 %bcond_without  spice           # SPICE support
18 %bcond_with     esd             # EsounD audio support
19 %bcond_without  oss             # OSS audio support
20 %bcond_without  pulseaudio      # PulseAudio audio support
21 %bcond_without  xen             # Xen backend driver support
22
23 Summary:        QEMU CPU Emulator
24 Summary(pl.UTF-8):      QEMU - emulator procesora
25 Name:           qemu
26 Version:        1.6.1
27 Release:        3
28 License:        GPL v2+
29 Group:          Applications/Emulators
30 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
31 # Source0-md5:  3a897d722457c5a895cd6ac79a28fda0
32 Patch0:         %{name}-cflags.patch
33 Patch1:         vgabios-widescreens.patch
34 Patch2:         %{name}-whitelist.patch
35 Patch3:         %{name}-system-libcacard.patch
36 # Proof of concept, for reference, do not remove
37 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
38 URL:            http://www.qemu-project.org/
39 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
40 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
41 BuildRequires:  alsa-lib-devel
42 BuildRequires:  bcc
43 BuildRequires:  bluez-libs-devel
44 BuildRequires:  brlapi-devel
45 %{?with_ceph:BuildRequires:     ceph-devel}
46 BuildRequires:  curl-devel
47 BuildRequires:  cyrus-sasl-devel >= 2
48 %{?with_esd:BuildRequires:      esound-devel}
49 BuildRequires:  glib2-devel >= 1:2.12
50 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
51 BuildRequires:  gnutls-devel
52 BuildRequires:  libaio-devel
53 BuildRequires:  libcacard-devel
54 BuildRequires:  libcap-devel
55 BuildRequires:  libcap-ng-devel
56 BuildRequires:  libfdt-devel
57 %{?with_rdma:BuildRequires:     libibverbs-devel}
58 BuildRequires:  libiscsi-devel
59 BuildRequires:  libjpeg-devel
60 BuildRequires:  libpng-devel
61 %{?with_rdma:BuildRequires:     librdmacm-devel}
62 BuildRequires:  libseccomp-devel
63 BuildRequires:  libssh2-devel >= 1.2.8
64 # for usb passthrough, when available
65 #BuildRequires: libusb-devel >= 1.0.13
66 BuildRequires:  libuuid-devel
67 BuildRequires:  ncurses-devel
68 BuildRequires:  nss-devel >= 3.12.8
69 BuildRequires:  perl-Encode
70 BuildRequires:  perl-tools-pod
71 BuildRequires:  pkgconfig
72 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
73 BuildRequires:  rpmbuild(macros) >= 1.202
74 BuildRequires:  sed >= 4.0
75 %if %{with spice}
76 BuildRequires:  spice-protocol >= 0.12.0
77 BuildRequires:  spice-server-devel >= 0.12.0
78 %endif
79 BuildRequires:  texi2html
80 BuildRequires:  texinfo
81 BuildRequires:  usbredir-devel >= 0.6
82 BuildRequires:  vde2-devel
83 BuildRequires:  which
84 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
85 BuildRequires:  xfsprogs-devel
86 BuildRequires:  xorg-lib-libX11-devel
87 BuildRequires:  zlib-devel
88 %if %{with gtk2}
89 BuildRequires:  gtk+2-devel >= 2:2.18.0
90 BuildRequires:  vte0-devel >= 0.24.0
91 %else
92 BuildRequires:  gtk+3-devel >= 3.0.0
93 BuildRequires:  vte-devel >= 0.32.0
94 %endif
95 Requires:       %{name}-img = %{version}-%{release}
96 Requires:       %{name}-system-alpha = %{version}-%{release}
97 Requires:       %{name}-system-arm = %{version}-%{release}
98 Requires:       %{name}-system-cris = %{version}-%{release}
99 Requires:       %{name}-system-lm32 = %{version}-%{release}
100 Requires:       %{name}-system-m68k = %{version}-%{release}
101 Requires:       %{name}-system-microblaze = %{version}-%{release}
102 Requires:       %{name}-system-mips = %{version}-%{release}
103 Requires:       %{name}-system-moxie = %{version}-%{release}
104 Requires:       %{name}-system-or32 = %{version}-%{release}
105 Requires:       %{name}-system-ppc = %{version}-%{release}
106 Requires:       %{name}-system-s390x = %{version}-%{release}
107 Requires:       %{name}-system-sh4 = %{version}-%{release}
108 Requires:       %{name}-system-sparc = %{version}-%{release}
109 Requires:       %{name}-system-unicore32 = %{version}-%{release}
110 Requires:       %{name}-system-x86 = %{version}-%{release}
111 Requires:       %{name}-system-xtensa = %{version}-%{release}
112 Requires:       %{name}-user = %{version}-%{release}
113 Obsoletes:      qemu-kvm
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %define systempkg_req \
117 Requires:       SDL >= 1.2.1 \
118 Requires:       usbredir >= 0.6 \
119 %if %{with gtk2} \
120 Requires:       gtk+2 >= 2:2.18.0 \
121 Requires:       vte0 >= 0.24.0 \
122 %else \
123 Requires:       gtk+3 >= 3.0.0 \
124 Requires:       vte >= 0.32.0 \
125 %endif
126
127 # some PPC/SPARC boot image in ELF format
128 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
129
130 %description
131 QEMU is a FAST! processor emulator. By using dynamic translation it
132 achieves a reasonnable speed while being easy to port on new host
133 CPUs. QEMU has two operating modes:
134
135 - User mode emulation. In this mode, QEMU can launch Linux processes
136   compiled for one CPU on another CPU. Linux system calls are converted
137   because of endianness and 32/64 bit mismatches. Wine (Windows
138   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
139
140 - Full system emulation. In this mode, QEMU emulates a full system,
141   including a processor and various peripherials. It can also be used to
142   provide virtual hosting of several virtual PC on a single server.
143
144 %description -l pl.UTF-8
145 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
146 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
147 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
148
149 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
150   procesy linuksowe skompilowane dla jednego procesora na innym
151   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
152   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
153   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
154   cele QEMU.
155
156 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
157   włączając w to procesor i różne urządzenia peryferyjne. Może być także
158   używane do wirtualnego hostowania kilku wirtualnych pecetów na
159   pojedynczym serwerze.
160
161 %package common
162 Summary:        QEMU common files needed by all QEMU targets
163 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
164 Group:          Development/Tools
165 Requires(postun):       /usr/sbin/groupdel
166 Requires(postun):       /usr/sbin/userdel
167 Requires(pre):  /bin/id
168 Requires(pre):  /usr/bin/getgid
169 Requires(pre):  /usr/sbin/groupadd
170 Requires(pre):  /usr/sbin/useradd
171 Requires:       glib2 >= 1:2.12
172 Requires:       libssh2 >= 1.2.8
173 Provides:       group(qemu)
174 Provides:       user(qemu)
175 Obsoletes:      qemu-kvm-common
176 Conflicts:      qemu < 1.0-2
177
178 %description common
179 QEMU is a generic and open source processor emulator which achieves a
180 good emulation speed by using dynamic translation.
181
182 This package provides the common files needed by all QEMU targets.
183
184 %description common -l pl.UTF-8
185 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
186 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
187
188 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
189 środowiska QEMU.
190
191 %package img
192 Summary:        QEMU command line tool for manipulating disk images
193 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
194 Group:          Development/Tools
195 Conflicts:      qemu < 1.0-2
196 Obsoletes:      qemu-kvm-img
197
198 %description img
199 This package provides a command line tool for manipulating disk
200 images.
201
202 %description img -l pl.UTF-8
203 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
204 na obrazach dysków.
205
206 %package user
207 Summary:        QEMU user mode emulation of qemu targets
208 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
209 Group:          Development/Tools
210 Requires:       %{name}-common = %{version}-%{release}
211 Obsoletes:      qemu-kvm-user
212
213 %description user
214 QEMU is a generic and open source processor emulator which achieves a
215 good emulation speed by using dynamic translation.
216
217 This package provides the user mode emulation of QEMU targets.
218
219 %description user -l pl.UTF-8
220 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
221 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
222
223 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
224
225 %package system-alpha
226 Summary:        QEMU system emulator for Alpha
227 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
228 Group:          Development/Tools
229 Requires:       %{name}-common = %{version}-%{release}
230 %systempkg_req
231 Obsoletes:      qemu-kvm-system-alpha
232
233 %description system-alpha
234 QEMU is a generic and open source processor emulator which achieves a
235 good emulation speed by using dynamic translation.
236
237 This package provides the system emulator with Alpha CPU.
238
239 %description system-alpha -l pl.UTF-8
240 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
241 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
242
243 Ten pakiet zawiera emulator systemu z procesorem Alpha.
244
245 %package system-arm
246 Summary:        QEMU system emulator for ARM
247 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
248 Group:          Development/Tools
249 Requires:       %{name}-common = %{version}-%{release}
250 %systempkg_req
251 Obsoletes:      qemu-kvm-system-arm
252
253 %description system-arm
254 QEMU is a generic and open source processor emulator which achieves a
255 good emulation speed by using dynamic translation.
256
257 This package provides the system emulator for ARM.
258
259 %description system-arm -l pl.UTF-8
260 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
261 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
262
263 Ten pakiet zawiera emulator systemu z procesorem ARM.
264
265 %package system-cris
266 Summary:        QEMU system emulator for CRIS
267 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
268 Group:          Development/Tools
269 Requires:       %{name}-common = %{version}-%{release}
270 %systempkg_req
271 Obsoletes:      qemu-kvm-system-cris
272
273 %description system-cris
274 QEMU is a generic and open source processor emulator which achieves a
275 good emulation speed by using dynamic translation.
276
277 This package provides the system emulator with CRIS CPU.
278
279 %description system-cris -l pl.UTF-8
280 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
281 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
282
283 Ten pakiet zawiera emulator systemu z procesorem CRIS.
284
285 %package system-lm32
286 Summary:        QEMU system emulator for LM32
287 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
288 Group:          Development/Tools
289 Requires:       %{name}-common = %{version}-%{release}
290 %systempkg_req
291 Obsoletes:      qemu-kvm-system-lm32
292
293 %description system-lm32
294 QEMU is a generic and open source processor emulator which achieves a
295 good emulation speed by using dynamic translation.
296
297 This package provides the system emulator with LM32 CPU.
298
299 %description system-lm32 -l pl.UTF-8
300 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
301 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
302
303 Ten pakiet zawiera emulator systemu z procesorem LM32.
304
305 %package system-m68k
306 Summary:        QEMU system emulator for m68k
307 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
308 Group:          Development/Tools
309 Requires:       %{name}-common = %{version}-%{release}
310 %systempkg_req
311 Obsoletes:      qemu-kvm-system-m68k
312
313 %description system-m68k
314 QEMU is a generic and open source processor emulator which achieves a
315 good emulation speed by using dynamic translation.
316
317 This package provides the system emulator with m68k CPU.
318
319 %description system-m68k -l pl.UTF-8
320 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
321 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
322
323 Ten pakiet zawiera emulator systemu z procesorem m68k.
324
325 %package system-microblaze
326 Summary:        QEMU system emulator for MicroBlaze
327 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
328 Group:          Development/Tools
329 Requires:       %{name}-common = %{version}-%{release}
330 %systempkg_req
331 Obsoletes:      qemu-kvm-system-microblaze
332
333 %description system-microblaze
334 QEMU is a generic and open source processor emulator which achieves a
335 good emulation speed by using dynamic translation.
336
337 This package provides the system emulator with MicroBlaze CPU.
338
339 %description system-microblaze -l pl.UTF-8
340 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
341 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
342
343 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
344
345 %package system-mips
346 Summary:        QEMU system emulator for MIPS
347 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
348 Group:          Development/Tools
349 Requires:       %{name}-common = %{version}-%{release}
350 %systempkg_req
351 Obsoletes:      qemu-kvm-system-mips
352
353 %description system-mips
354 QEMU is a generic and open source processor emulator which achieves a
355 good emulation speed by using dynamic translation.
356
357 This package provides the system emulator with MIPS CPU.
358
359 %description system-mips -l pl.UTF-8
360 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
361 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
362
363 Ten pakiet zawiera emulator systemu z procesorem MIPS.
364
365 %package system-moxie
366 Summary:        QEMU system emulator for Moxie
367 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
368 Group:          Development/Tools
369 Requires:       %{name}-common = %{version}-%{release}
370 %systempkg_req
371
372 %description system-moxie
373 QEMU is a generic and open source processor emulator which achieves a
374 good emulation speed by using dynamic translation.
375
376 This package provides the system emulator with Moxie CPU.
377
378 %description system-moxie -l pl.UTF-8
379 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
380 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
381
382 Ten pakiet zawiera emulator systemu z procesorem Moxie.
383
384 %package system-or32
385 Summary:        QEMU system emulator for OpenRISC
386 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
387 Group:          Development/Tools
388 Requires:       %{name}-common = %{version}-%{release}
389 %systempkg_req
390 Obsoletes:      qemu-kvm-system-or32
391
392 %description system-or32
393 QEMU is a generic and open source processor emulator which achieves a
394 good emulation speed by using dynamic translation.
395
396 This package provides the system emulator with OpenRISC CPU.
397
398 %description system-or32 -l pl.UTF-8
399 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
400 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
401
402 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
403
404 %package system-ppc
405 Summary:        QEMU system emulator for PowerPC
406 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
407 Group:          Development/Tools
408 Requires:       %{name}-common = %{version}-%{release}
409 %systempkg_req
410 Obsoletes:      qemu-kvm-system-ppc
411
412 %description system-ppc
413 QEMU is a generic and open source processor emulator which achieves a
414 good emulation speed by using dynamic translation.
415
416 This package provides the system emulator with PowerPC CPU.
417
418 %description system-ppc -l pl.UTF-8
419 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
420 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
421
422 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
423
424 %package system-s390x
425 Summary:        QEMU system emulator for S390
426 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
427 Group:          Development/Tools
428 Requires:       %{name}-common = %{version}-%{release}
429 %systempkg_req
430 Obsoletes:      qemu-kvm-system-s390x
431
432 %description system-s390x
433 QEMU is a generic and open source processor emulator which achieves a
434 good emulation speed by using dynamic translation.
435
436 This package provides the system emulator with S390 CPU.
437
438 %description system-s390x -l pl.UTF-8
439 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
440 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
441
442 Ten pakiet zawiera emulator systemu z procesorem S390.
443
444 %package system-sh4
445 Summary:        QEMU system emulator for SH4
446 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
447 Group:          Development/Tools
448 Requires:       %{name}-common = %{version}-%{release}
449 %systempkg_req
450 Obsoletes:      qemu-kvm-system-sh4
451
452 %description system-sh4
453 QEMU is a generic and open source processor emulator which achieves a
454 good emulation speed by using dynamic translation.
455
456 This package provides the system emulator with SH4 CPU.
457
458 %description system-sh4 -l pl.UTF-8
459 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
460 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
461
462 Ten pakiet zawiera emulator systemu z procesorem SH4.
463
464 %package system-sparc
465 Summary:        QEMU system emulator for SPARC
466 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
467 Group:          Development/Tools
468 Requires:       %{name}-common = %{version}-%{release}
469 %systempkg_req
470 Obsoletes:      qemu-kvm-system-sparc
471
472 %description system-sparc
473 QEMU is a generic and open source processor emulator which achieves a
474 good emulation speed by using dynamic translation.
475
476 This package provides the system emulator with SPARC/SPARC64 CPU.
477
478 %description system-sparc -l pl.UTF-8
479 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
480 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
481
482 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
483
484 %package system-unicore32
485 Summary:        QEMU system emulator for UniCore32
486 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
487 Group:          Development/Tools
488 Requires:       %{name}-common = %{version}-%{release}
489 %systempkg_req
490 Obsoletes:      qemu-kvm-system-unicore32
491
492 %description system-unicore32
493 QEMU is a generic and open source processor emulator which achieves a
494 good emulation speed by using dynamic translation.
495
496 This package provides the system emulator with UniCore32 CPU.
497
498 %description system-unicore32 -l pl.UTF-8
499 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
500 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
501
502 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
503
504 %package system-x86
505 Summary:        QEMU system emulator for x86
506 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
507 Group:          Development/Tools
508 Requires:       %{name}-common = %{version}-%{release}
509 %systempkg_req
510 Obsoletes:      qemu-kvm-system-x86
511
512 %description system-x86
513 QEMU is a generic and open source processor emulator which achieves a
514 good emulation speed by using dynamic translation.
515
516 %description system-x86 -l pl.UTF-8
517 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
518 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
519
520 %package system-xtensa
521 Summary:        QEMU system emulator for Xtensa
522 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
523 Group:          Development/Tools
524 Requires:       %{name}-common = %{version}-%{release}
525 %systempkg_req
526 Obsoletes:      qemu-kvm-system-xtensa
527
528 %description system-xtensa
529 QEMU is a generic and open source processor emulator which achieves a
530 good emulation speed by using dynamic translation.
531
532 This package provides the system emulator with Xtensa CPU.
533
534 %description system-xtensa -l pl.UTF-8
535 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
536 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
537
538 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
539
540 %prep
541 %setup -q
542 %patch0 -p1
543 %patch1 -p1
544 %patch2 -p0
545 %patch3 -p1
546
547 %{__mv} libcacard libcacard-use-system-lib
548
549 # workaround for conflict with alsa/error.h
550 ln -s ../error.h qapi/error.h
551
552 %build
553 ./configure \
554         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
555         --extra-ldflags="%{rpmldflags}" \
556         --prefix=%{_prefix} \
557         --sysconfdir=%{_sysconfdir} \
558         --cc="%{__cc}" \
559         --host-cc="%{__cc}" \
560         --disable-strip \
561         --enable-attr \
562         --enable-bluez \
563         --enable-brlapi \
564         --enable-cap-ng \
565         --enable-curl \
566         --enable-curses \
567         --enable-docs \
568         --enable-fdt \
569         %{__enable_disable glusterfs} \
570         --enable-libiscsi \
571         --enable-mixemu \
572         %{__enable_disable glx} \
573         %{__enable_disable ceph rbd} \
574         %{__enable_disable rdma} \
575         %{__enable_disable sdl} \
576         --enable-seccomp \
577         %{__enable_disable spice} \
578         --enable-smartcard-nss \
579         --enable-tpm \
580         --enable-usb-redir \
581         --enable-uuid \
582         --enable-vde \
583         --enable-virtfs \
584         --enable-vnc-jpeg \
585         --enable-vnc-png \
586         --enable-vnc-sasl \
587         --enable-vnc-tls \
588         %{__enable_disable xen} \
589         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
590         --interp-prefix=%{_libdir}/qemu/lib-%%M \
591         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
592
593 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
594 # --libexecdir in configure is nop
595 %{__make} \
596         V=1 \
597         CONFIG_QEMU_HELPERDIR="%{_libdir}"
598
599 # rebuild patched vesa tables with additional widescreen modes.
600 %{__make} -C roms/vgabios stdvga-bios
601
602 %install
603 rm -rf $RPM_BUILD_ROOT
604
605 %{__make} install \
606         DESTDIR=$RPM_BUILD_ROOT \
607         libexecdir=%{_libdir}
608
609 install -d $RPM_BUILD_ROOT%{_sysconfdir}
610 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
611 #!/bin/sh
612
613 EOF
614
615 # already packaged
616 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
617 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
618
619 # install patched vesa tables with additional widescreen modes.
620 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
621
622 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
623 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
624 %find_lang %{name}
625
626 %clean
627 rm -rf $RPM_BUILD_ROOT
628
629 %pre common
630 %groupadd -g 276 qemu
631 %useradd -u 276 -g qemu -c "QEMU User" qemu
632
633 %postun common
634 if [ "$1" = "0" ]; then
635         %userremove qemu
636         %groupremove qemu
637 fi
638
639 %files
640 %defattr(644,root,root,755)
641
642 %files common -f %{name}.lang
643 %defattr(644,root,root,755)
644 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
645 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
647 %dir %{_sysconfdir}/qemu
648 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
649 %attr(755,root,root) %{_bindir}/qemu-nbd
650 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
651 %{_mandir}/man1/qemu.1*
652 %{_mandir}/man1/virtfs-proxy-helper.1*
653 %{_mandir}/man8/qemu-nbd.8*
654
655 %dir %{_datadir}/qemu
656 %{_datadir}/%{name}/keymaps
657 %{_datadir}/%{name}/qemu-icon.bmp
658 # various bios images
659 %{_datadir}/%{name}/*.aml
660 %{_datadir}/%{name}/*.bin
661 %{_datadir}/%{name}/*.rom
662 %{_datadir}/%{name}/*.dtb
663 %{_datadir}/%{name}/qemu_logo_no_text.svg
664 %{_datadir}/%{name}/openbios-ppc
665 %{_datadir}/%{name}/openbios-sparc*
666 %{_datadir}/%{name}/palcode-clipper
667 %{_datadir}/%{name}/s390-ccw.img
668
669 %files img
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_bindir}/qemu-img
672 %{_mandir}/man1/qemu-img.1*
673
674 %files user
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_bindir}/qemu-alpha
677 %attr(755,root,root) %{_bindir}/qemu-arm
678 %attr(755,root,root) %{_bindir}/qemu-armeb
679 %attr(755,root,root) %{_bindir}/qemu-cris
680 %attr(755,root,root) %{_bindir}/qemu-ga
681 %attr(755,root,root) %{_bindir}/qemu-i386
682 %attr(755,root,root) %{_bindir}/qemu-io
683 %attr(755,root,root) %{_bindir}/qemu-m68k
684 %attr(755,root,root) %{_bindir}/qemu-microblaze
685 %attr(755,root,root) %{_bindir}/qemu-microblazeel
686 %attr(755,root,root) %{_bindir}/qemu-mips
687 %attr(755,root,root) %{_bindir}/qemu-mipsel
688 %attr(755,root,root) %{_bindir}/qemu-mips64
689 %attr(755,root,root) %{_bindir}/qemu-mips64el
690 %attr(755,root,root) %{_bindir}/qemu-mipsn32
691 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
692 %attr(755,root,root) %{_bindir}/qemu-or32
693 %attr(755,root,root) %{_bindir}/qemu-ppc
694 %attr(755,root,root) %{_bindir}/qemu-ppc64
695 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
696 %attr(755,root,root) %{_bindir}/qemu-s390x
697 %attr(755,root,root) %{_bindir}/qemu-sh4
698 %attr(755,root,root) %{_bindir}/qemu-sh4eb
699 %attr(755,root,root) %{_bindir}/qemu-sparc
700 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
701 %attr(755,root,root) %{_bindir}/qemu-sparc64
702 %attr(755,root,root) %{_bindir}/qemu-unicore32
703 %attr(755,root,root) %{_bindir}/qemu-x86_64
704
705 %files system-alpha
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_bindir}/qemu-system-alpha
708
709 %files system-arm
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_bindir}/qemu-system-arm
712
713 %files system-cris
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_bindir}/qemu-system-cris
716
717 %files system-lm32
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_bindir}/qemu-system-lm32
720
721 %files system-m68k
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_bindir}/qemu-system-m68k
724
725 %files system-microblaze
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
728 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
729
730 %files system-mips
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_bindir}/qemu-system-mips
733 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
734 %attr(755,root,root) %{_bindir}/qemu-system-mips64
735 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
736
737 %files system-moxie
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_bindir}/qemu-system-moxie
740
741 %files system-or32
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_bindir}/qemu-system-or32
744
745 %files system-ppc
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_bindir}/qemu-system-ppc
748 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
749 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
750
751 %files system-s390x
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_bindir}/qemu-system-s390x
754
755 %files system-sh4
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_bindir}/qemu-system-sh4
758 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
759
760 %files system-sparc
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_bindir}/qemu-system-sparc
763 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
764
765 %files system-unicore32
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
768
769 %files system-x86
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_bindir}/qemu-system-i386
772 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
773
774 %files system-xtensa
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
777 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.096096 seconds and 4 git commands to generate.