]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- enabled GlusterFS backend and RDMA migration support
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1# TODO:
2# - merge missing bits from qemu-kvm
3# - qemu-system-ppc -hda ac-ppc.img says:
4# qemu: could not open disk image ac-ppc.img: error "Success"
5# qemu-0.12.2-2.x86_64.rpm - broken
6# qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
7# qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
8# qemu-0.11.1-*.x86_64.rpm - OK
9#
10# Conditional build:
11%bcond_without sdl # SDL UI and audio support
12%bcond_without glx # OpenGL/GLX support
13%bcond_without ceph # Ceph/RBD support
14%bcond_without glusterfs # GlusterFS backend
15%bcond_without rdma # RDMA-based migration support
16%bcond_with gtk2 # GTK+ 2.x instead of 3.x
17%bcond_without spice # SPICE support
18%bcond_with esd # EsounD audio support
19%bcond_without oss # OSS audio support
20%bcond_without pulseaudio # PulseAudio audio support
21%bcond_without xen # Xen backend driver support
22
23Summary: QEMU CPU Emulator
24Summary(pl.UTF-8): QEMU - emulator procesora
25Name: qemu
26Version: 1.6.0
27Release: 1
28License: GPL v2+
29Group: Applications/Emulators
30Source0: http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
31# Source0-md5: f3f39308472d629aca57a255a0c91ba9
32Patch0: %{name}-cflags.patch
33Patch1: vgabios-widescreens.patch
34Patch2: %{name}-whitelist.patch
35Patch3: %{name}-system-libcacard.patch
36# Proof of concept, for reference, do not remove
37Patch4: %{name}-kde_virtual_workspaces_hack.patch
38URL: http://www.qemu-project.org/
39%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
40%{?with_sdl:BuildRequires: SDL-devel >= 1.2.1}
41BuildRequires: alsa-lib-devel
42BuildRequires: bcc
43BuildRequires: bluez-libs-devel
44BuildRequires: brlapi-devel
45%{?with_ceph:BuildRequires: ceph-devel}
46BuildRequires: curl-devel
47BuildRequires: cyrus-sasl-devel >= 2
48%{?with_esd:BuildRequires: esound-devel}
49BuildRequires: glib2-devel >= 1:2.12
50%{?with_glusterfs:BuildRequires: glusterfs-devel >= 3.4}
51BuildRequires: gnutls-devel
52BuildRequires: libaio-devel
53BuildRequires: libcacard-devel
54BuildRequires: libcap-devel
55BuildRequires: libcap-ng-devel
56BuildRequires: libfdt-devel
57%{?with_rdma:BuildRequires: libibverbs-devel}
58BuildRequires: libiscsi-devel
59BuildRequires: libjpeg-devel
60BuildRequires: libpng-devel
61%{?with_rdma:BuildRequires: librdmacm-devel}
62BuildRequires: libseccomp-devel
63BuildRequires: libssh2-devel >= 1.2.8
64# for usb passthrough, when available
65#BuildRequires: libusb-devel >= 1.0.13
66BuildRequires: libuuid-devel
67BuildRequires: ncurses-devel
68BuildRequires: nss-devel >= 3.12.8
69BuildRequires: perl-Encode
70BuildRequires: perl-tools-pod
71BuildRequires: pkgconfig
72%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
73BuildRequires: rpmbuild(macros) >= 1.202
74BuildRequires: sed >= 4.0
75%if %{with spice}
76BuildRequires: spice-protocol >= 0.12.0
77BuildRequires: spice-server-devel >= 0.12.0
78%endif
79BuildRequires: texi2html
80BuildRequires: texinfo
81BuildRequires: usbredir-devel >= 0.6
82BuildRequires: vde2-devel
83BuildRequires: which
84%{?with_xen:BuildRequires: xen-devel >= 3.4}
85BuildRequires: xfsprogs-devel
86BuildRequires: xorg-lib-libX11-devel
87BuildRequires: zlib-devel
88%if %{with gtk2}
89BuildRequires: gtk+2-devel >= 2:2.18.0
90BuildRequires: vte0-devel >= 0.24.0
91%else
92BuildRequires: gtk+3-devel >= 3.0.0
93BuildRequires: vte-devel >= 0.32.0
94%endif
95Requires: %{name}-img = %{version}-%{release}
96Requires: %{name}-system-alpha = %{version}-%{release}
97Requires: %{name}-system-arm = %{version}-%{release}
98Requires: %{name}-system-cris = %{version}-%{release}
99Requires: %{name}-system-lm32 = %{version}-%{release}
100Requires: %{name}-system-m68k = %{version}-%{release}
101Requires: %{name}-system-microblaze = %{version}-%{release}
102Requires: %{name}-system-mips = %{version}-%{release}
103Requires: %{name}-system-moxie = %{version}-%{release}
104Requires: %{name}-system-or32 = %{version}-%{release}
105Requires: %{name}-system-ppc = %{version}-%{release}
106Requires: %{name}-system-s390x = %{version}-%{release}
107Requires: %{name}-system-sh4 = %{version}-%{release}
108Requires: %{name}-system-sparc = %{version}-%{release}
109Requires: %{name}-system-unicore32 = %{version}-%{release}
110Requires: %{name}-system-x86 = %{version}-%{release}
111Requires: %{name}-system-xtensa = %{version}-%{release}
112Requires: %{name}-user = %{version}-%{release}
113BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115%define systempkg_req \
116Requires: SDL >= 1.2.1 \
117Requires: usbredir >= 0.6 \
118%if %{with gtk2} \
119Requires: gtk+2 >= 2:2.18.0 \
120Requires: vte0 >= 0.24.0 \
121%else \
122Requires: gtk+3 >= 3.0.0 \
123Requires: vte >= 0.32.0 \
124%endif
125
126# some PPC/SPARC boot image in ELF format
127%define _noautostrip .*%{_datadir}/qemu/.*-.*
128
129%description
130QEMU is a FAST! processor emulator. By using dynamic translation it
131achieves a reasonnable speed while being easy to port on new host
132CPUs. QEMU has two operating modes:
133
134- User mode emulation. In this mode, QEMU can launch Linux processes
135 compiled for one CPU on another CPU. Linux system calls are converted
136 because of endianness and 32/64 bit mismatches. Wine (Windows
137 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
138
139- Full system emulation. In this mode, QEMU emulates a full system,
140 including a processor and various peripherials. It can also be used to
141 provide virtual hosting of several virtual PC on a single server.
142
143%description -l pl.UTF-8
144QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
145tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
146aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
147
148- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
149 procesy linuksowe skompilowane dla jednego procesora na innym
150 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
151 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
152 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
153 cele QEMU.
154
155- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
156 włączając w to procesor i różne urządzenia peryferyjne. Może być także
157 używane do wirtualnego hostowania kilku wirtualnych pecetów na
158 pojedynczym serwerze.
159
160%package common
161Summary: QEMU common files needed by all QEMU targets
162Summary(pl.UTF-8): Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
163Group: Development/Tools
164Requires(postun): /usr/sbin/groupdel
165Requires(postun): /usr/sbin/userdel
166Requires(pre): /bin/id
167Requires(pre): /usr/bin/getgid
168Requires(pre): /usr/sbin/groupadd
169Requires(pre): /usr/sbin/useradd
170Requires: glib2 >= 1:2.12
171Requires: libssh2 >= 1.2.8
172Provides: group(qemu)
173Provides: user(qemu)
174Conflicts: qemu < 1.0-2
175
176%description common
177QEMU is a generic and open source processor emulator which achieves a
178good emulation speed by using dynamic translation.
179
180This package provides the common files needed by all QEMU targets.
181
182%description common -l pl.UTF-8
183QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
184dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
185
186Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
187środowiska QEMU.
188
189%package img
190Summary: QEMU command line tool for manipulating disk images
191Summary(pl.UTF-8): Narzędzie QEMU do operacji na obrazach dysków
192Group: Development/Tools
193Conflicts: qemu < 1.0-2
194
195%description img
196This package provides a command line tool for manipulating disk
197images.
198
199%description img -l pl.UTF-8
200Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
201na obrazach dysków.
202
203%package user
204Summary: QEMU user mode emulation of qemu targets
205Summary(pl.UTF-8): QEMU - emulacja trybu użytkownika środowisk qemu
206Group: Development/Tools
207Requires: %{name}-common = %{version}-%{release}
208
209%description user
210QEMU is a generic and open source processor emulator which achieves a
211good emulation speed by using dynamic translation.
212
213This package provides the user mode emulation of QEMU targets.
214
215%description user -l pl.UTF-8
216QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
217dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
218
219Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
220
221%package system-alpha
222Summary: QEMU system emulator for Alpha
223Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Alpha
224Group: Development/Tools
225Requires: %{name}-common = %{version}-%{release}
226%systempkg_req
227
228%description system-alpha
229QEMU is a generic and open source processor emulator which achieves a
230good emulation speed by using dynamic translation.
231
232This package provides the system emulator with Alpha CPU.
233
234%description system-alpha -l pl.UTF-8
235QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
236dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
237
238Ten pakiet zawiera emulator systemu z procesorem Alpha.
239
240%package system-arm
241Summary: QEMU system emulator for ARM
242Summary(pl.UTF-8): QEMU - emulator systemu z procesorem ARM
243Group: Development/Tools
244Requires: %{name}-common = %{version}-%{release}
245%systempkg_req
246
247%description system-arm
248QEMU is a generic and open source processor emulator which achieves a
249good emulation speed by using dynamic translation.
250
251This package provides the system emulator for ARM.
252
253%description system-arm -l pl.UTF-8
254QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
255dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
256
257Ten pakiet zawiera emulator systemu z procesorem ARM.
258
259%package system-cris
260Summary: QEMU system emulator for CRIS
261Summary(pl.UTF-8): QEMU - emulator systemu z procesorem CRIS
262Group: Development/Tools
263Requires: %{name}-common = %{version}-%{release}
264%systempkg_req
265
266%description system-cris
267QEMU is a generic and open source processor emulator which achieves a
268good emulation speed by using dynamic translation.
269
270This package provides the system emulator with CRIS CPU.
271
272%description system-cris -l pl.UTF-8
273QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
274dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
275
276Ten pakiet zawiera emulator systemu z procesorem CRIS.
277
278%package system-lm32
279Summary: QEMU system emulator for LM32
280Summary(pl.UTF-8): QEMU - emulator systemu z procesorem LM32
281Group: Development/Tools
282Requires: %{name}-common = %{version}-%{release}
283%systempkg_req
284
285%description system-lm32
286QEMU is a generic and open source processor emulator which achieves a
287good emulation speed by using dynamic translation.
288
289This package provides the system emulator with LM32 CPU.
290
291%description system-lm32 -l pl.UTF-8
292QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
293dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
294
295Ten pakiet zawiera emulator systemu z procesorem LM32.
296
297%package system-m68k
298Summary: QEMU system emulator for m68k
299Summary(pl.UTF-8): QEMU - emulator systemu z procesorem m68k
300Group: Development/Tools
301Requires: %{name}-common = %{version}-%{release}
302%systempkg_req
303
304%description system-m68k
305QEMU is a generic and open source processor emulator which achieves a
306good emulation speed by using dynamic translation.
307
308This package provides the system emulator with m68k CPU.
309
310%description system-m68k -l pl.UTF-8
311QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
312dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
313
314Ten pakiet zawiera emulator systemu z procesorem m68k.
315
316%package system-microblaze
317Summary: QEMU system emulator for MicroBlaze
318Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MicroBlaze
319Group: Development/Tools
320Requires: %{name}-common = %{version}-%{release}
321%systempkg_req
322
323%description system-microblaze
324QEMU is a generic and open source processor emulator which achieves a
325good emulation speed by using dynamic translation.
326
327This package provides the system emulator with MicroBlaze CPU.
328
329%description system-microblaze -l pl.UTF-8
330QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
331dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
332
333Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
334
335%package system-mips
336Summary: QEMU system emulator for MIPS
337Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MIPS
338Group: Development/Tools
339Requires: %{name}-common = %{version}-%{release}
340%systempkg_req
341
342%description system-mips
343QEMU is a generic and open source processor emulator which achieves a
344good emulation speed by using dynamic translation.
345
346This package provides the system emulator with MIPS CPU.
347
348%description system-mips -l pl.UTF-8
349QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
350dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
351
352Ten pakiet zawiera emulator systemu z procesorem MIPS.
353
354%package system-moxie
355Summary: QEMU system emulator for Moxie
356Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Moxie
357Group: Development/Tools
358Requires: %{name}-common = %{version}-%{release}
359%systempkg_req
360
361%description system-moxie
362QEMU is a generic and open source processor emulator which achieves a
363good emulation speed by using dynamic translation.
364
365This package provides the system emulator with Moxie CPU.
366
367%description system-moxie -l pl.UTF-8
368QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
369dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
370
371Ten pakiet zawiera emulator systemu z procesorem Moxie.
372
373%package system-or32
374Summary: QEMU system emulator for OpenRISC
375Summary(pl.UTF-8): QEMU - emulator systemu z procesorem OpenRISC
376Group: Development/Tools
377Requires: %{name}-common = %{version}-%{release}
378%systempkg_req
379
380%description system-or32
381QEMU is a generic and open source processor emulator which achieves a
382good emulation speed by using dynamic translation.
383
384This package provides the system emulator with OpenRISC CPU.
385
386%description system-or32 -l pl.UTF-8
387QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
388dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
389
390Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
391
392%package system-ppc
393Summary: QEMU system emulator for PowerPC
394Summary(pl.UTF-8): QEMU - emulator systemu z procesorem PowerPC
395Group: Development/Tools
396Requires: %{name}-common = %{version}-%{release}
397%systempkg_req
398
399%description system-ppc
400QEMU is a generic and open source processor emulator which achieves a
401good emulation speed by using dynamic translation.
402
403This package provides the system emulator with PowerPC CPU.
404
405%description system-ppc -l pl.UTF-8
406QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
407dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
408
409Ten pakiet zawiera emulator systemu z procesorem PowerPC.
410
411%package system-s390x
412Summary: QEMU system emulator for S390
413Summary(pl.UTF-8): QEMU - emulator systemu z procesorem S390
414Group: Development/Tools
415Requires: %{name}-common = %{version}-%{release}
416%systempkg_req
417
418%description system-s390x
419QEMU is a generic and open source processor emulator which achieves a
420good emulation speed by using dynamic translation.
421
422This package provides the system emulator with S390 CPU.
423
424%description system-s390x -l pl.UTF-8
425QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
426dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
427
428Ten pakiet zawiera emulator systemu z procesorem S390.
429
430%package system-sh4
431Summary: QEMU system emulator for SH4
432Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SH4
433Group: Development/Tools
434Requires: %{name}-common = %{version}-%{release}
435%systempkg_req
436
437%description system-sh4
438QEMU is a generic and open source processor emulator which achieves a
439good emulation speed by using dynamic translation.
440
441This package provides the system emulator with SH4 CPU.
442
443%description system-sh4 -l pl.UTF-8
444QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
445dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
446
447Ten pakiet zawiera emulator systemu z procesorem SH4.
448
449%package system-sparc
450Summary: QEMU system emulator for SPARC
451Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SPARC
452Group: Development/Tools
453Requires: %{name}-common = %{version}-%{release}
454%systempkg_req
455
456%description system-sparc
457QEMU is a generic and open source processor emulator which achieves a
458good emulation speed by using dynamic translation.
459
460This package provides the system emulator with SPARC/SPARC64 CPU.
461
462%description system-sparc -l pl.UTF-8
463QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
464dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
465
466Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
467
468%package system-unicore32
469Summary: QEMU system emulator for UniCore32
470Summary(pl.UTF-8): QEMU - emulator systemu z procesorem UniCore32
471Group: Development/Tools
472Requires: %{name}-common = %{version}-%{release}
473%systempkg_req
474
475%description system-unicore32
476QEMU is a generic and open source processor emulator which achieves a
477good emulation speed by using dynamic translation.
478
479This package provides the system emulator with UniCore32 CPU.
480
481%description system-unicore32 -l pl.UTF-8
482QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
483dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
484
485Ten pakiet zawiera emulator systemu z procesorem UniCore32.
486
487%package system-x86
488Summary: QEMU system emulator for x86
489Summary(pl.UTF-8): QEMU - emulator systemu z procesorem x86
490Group: Development/Tools
491Requires: %{name}-common = %{version}-%{release}
492%systempkg_req
493
494%description system-x86
495QEMU is a generic and open source processor emulator which achieves a
496good emulation speed by using dynamic translation.
497
498%description system-x86 -l pl.UTF-8
499QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
500dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
501
502%package system-xtensa
503Summary: QEMU system emulator for Xtensa
504Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Xtensa
505Group: Development/Tools
506Requires: %{name}-common = %{version}-%{release}
507%systempkg_req
508
509%description system-xtensa
510QEMU is a generic and open source processor emulator which achieves a
511good emulation speed by using dynamic translation.
512
513This package provides the system emulator with Xtensa CPU.
514
515%description system-xtensa -l pl.UTF-8
516QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
517dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
518
519Ten pakiet zawiera emulator systemu z procesorem Xtensa.
520
521%prep
522%setup -q
523%patch0 -p1
524%patch1 -p1
525%patch2 -p0
526%patch3 -p1
527
528%{__mv} libcacard libcacard-use-system-lib
529
530# workaround for conflict with alsa/error.h
531ln -s ../error.h qapi/error.h
532
533%build
534./configure \
535 --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
536 --extra-ldflags="%{rpmldflags}" \
537 --prefix=%{_prefix} \
538 --sysconfdir=%{_sysconfdir} \
539 --cc="%{__cc}" \
540 --host-cc="%{__cc}" \
541 --disable-strip \
542 --enable-attr \
543 --enable-bluez \
544 --enable-brlapi \
545 --enable-cap-ng \
546 --enable-curl \
547 --enable-curses \
548 --enable-docs \
549 --enable-fdt \
550 %{__enable_disable glusterfs} \
551 --enable-libiscsi \
552 --enable-mixemu \
553 %{__enable_disable glx} \
554 %{__enable_disable ceph rbd} \
555 %{__enable_disable rdma} \
556 %{__enable_disable sdl} \
557 --enable-seccomp \
558 %{__enable_disable spice} \
559 --enable-smartcard-nss \
560 --enable-tpm \
561 --enable-usb-redir \
562 --enable-uuid \
563 --enable-vde \
564 --enable-virtfs \
565 --enable-vnc-jpeg \
566 --enable-vnc-png \
567 --enable-vnc-sasl \
568 --enable-vnc-tls \
569 %{__enable_disable xen} \
570 --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
571 --interp-prefix=%{_libdir}/qemu/lib-%%M \
572 --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
573
574# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
575# --libexecdir in configure is nop
576%{__make} \
577 V=1 \
578 CONFIG_QEMU_HELPERDIR="%{_libdir}"
579
580# rebuild patched vesa tables with additional widescreen modes.
581%{__make} -C roms/vgabios stdvga-bios
582
583%install
584rm -rf $RPM_BUILD_ROOT
585
586%{__make} install \
587 DESTDIR=$RPM_BUILD_ROOT \
588 libexecdir=%{_libdir}
589
590install -d $RPM_BUILD_ROOT%{_sysconfdir}
591cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
592#!/bin/sh
593
594EOF
595
596# already packaged
597%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
598%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
599
600# install patched vesa tables with additional widescreen modes.
601cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
602
603%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
604%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
605%find_lang %{name}
606
607%clean
608rm -rf $RPM_BUILD_ROOT
609
610%pre common
611%groupadd -g 276 qemu
612%useradd -u 276 -g qemu -c "QEMU User" qemu
613
614%postun common
615if [ "$1" = "0" ]; then
616 %userremove qemu
617 %groupremove qemu
618fi
619
620%files
621%defattr(644,root,root,755)
622
623%files common -f %{name}.lang
624%defattr(644,root,root,755)
625%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
626%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
627%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
628%dir %{_sysconfdir}/qemu
629%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
630%attr(755,root,root) %{_bindir}/qemu-nbd
631%attr(755,root,root) %{_libdir}/qemu-bridge-helper
632%{_mandir}/man1/qemu.1*
633%{_mandir}/man1/virtfs-proxy-helper.1*
634%{_mandir}/man8/qemu-nbd.8*
635
636%dir %{_datadir}/qemu
637%{_datadir}/%{name}/keymaps
638%{_datadir}/%{name}/qemu-icon.bmp
639# various bios images
640%{_datadir}/%{name}/*.aml
641%{_datadir}/%{name}/*.bin
642%{_datadir}/%{name}/*.rom
643%{_datadir}/%{name}/*.dtb
644%{_datadir}/%{name}/qemu_logo_no_text.svg
645%{_datadir}/%{name}/openbios-ppc
646%{_datadir}/%{name}/openbios-sparc*
647%{_datadir}/%{name}/palcode-clipper
648%{_datadir}/%{name}/s390-ccw.img
649
650%files img
651%defattr(644,root,root,755)
652%attr(755,root,root) %{_bindir}/qemu-img
653%{_mandir}/man1/qemu-img.1*
654
655%files user
656%defattr(644,root,root,755)
657%attr(755,root,root) %{_bindir}/qemu-alpha
658%attr(755,root,root) %{_bindir}/qemu-arm
659%attr(755,root,root) %{_bindir}/qemu-armeb
660%attr(755,root,root) %{_bindir}/qemu-cris
661%attr(755,root,root) %{_bindir}/qemu-ga
662%attr(755,root,root) %{_bindir}/qemu-i386
663%attr(755,root,root) %{_bindir}/qemu-io
664%attr(755,root,root) %{_bindir}/qemu-m68k
665%attr(755,root,root) %{_bindir}/qemu-microblaze
666%attr(755,root,root) %{_bindir}/qemu-microblazeel
667%attr(755,root,root) %{_bindir}/qemu-mips
668%attr(755,root,root) %{_bindir}/qemu-mipsel
669%attr(755,root,root) %{_bindir}/qemu-mips64
670%attr(755,root,root) %{_bindir}/qemu-mips64el
671%attr(755,root,root) %{_bindir}/qemu-mipsn32
672%attr(755,root,root) %{_bindir}/qemu-mipsn32el
673%attr(755,root,root) %{_bindir}/qemu-or32
674%attr(755,root,root) %{_bindir}/qemu-ppc
675%attr(755,root,root) %{_bindir}/qemu-ppc64
676%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
677%attr(755,root,root) %{_bindir}/qemu-s390x
678%attr(755,root,root) %{_bindir}/qemu-sh4
679%attr(755,root,root) %{_bindir}/qemu-sh4eb
680%attr(755,root,root) %{_bindir}/qemu-sparc
681%attr(755,root,root) %{_bindir}/qemu-sparc32plus
682%attr(755,root,root) %{_bindir}/qemu-sparc64
683%attr(755,root,root) %{_bindir}/qemu-unicore32
684%attr(755,root,root) %{_bindir}/qemu-x86_64
685
686%files system-alpha
687%defattr(644,root,root,755)
688%attr(755,root,root) %{_bindir}/qemu-system-alpha
689
690%files system-arm
691%defattr(644,root,root,755)
692%attr(755,root,root) %{_bindir}/qemu-system-arm
693
694%files system-cris
695%defattr(644,root,root,755)
696%attr(755,root,root) %{_bindir}/qemu-system-cris
697
698%files system-lm32
699%defattr(644,root,root,755)
700%attr(755,root,root) %{_bindir}/qemu-system-lm32
701
702%files system-m68k
703%defattr(644,root,root,755)
704%attr(755,root,root) %{_bindir}/qemu-system-m68k
705
706%files system-microblaze
707%defattr(644,root,root,755)
708%attr(755,root,root) %{_bindir}/qemu-system-microblaze
709%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
710
711%files system-mips
712%defattr(644,root,root,755)
713%attr(755,root,root) %{_bindir}/qemu-system-mips
714%attr(755,root,root) %{_bindir}/qemu-system-mipsel
715%attr(755,root,root) %{_bindir}/qemu-system-mips64
716%attr(755,root,root) %{_bindir}/qemu-system-mips64el
717
718%files system-moxie
719%defattr(644,root,root,755)
720%attr(755,root,root) %{_bindir}/qemu-system-moxie
721
722%files system-or32
723%defattr(644,root,root,755)
724%attr(755,root,root) %{_bindir}/qemu-system-or32
725
726%files system-ppc
727%defattr(644,root,root,755)
728%attr(755,root,root) %{_bindir}/qemu-system-ppc
729%attr(755,root,root) %{_bindir}/qemu-system-ppc64
730%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
731
732%files system-s390x
733%defattr(644,root,root,755)
734%attr(755,root,root) %{_bindir}/qemu-system-s390x
735
736%files system-sh4
737%defattr(644,root,root,755)
738%attr(755,root,root) %{_bindir}/qemu-system-sh4
739%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
740
741%files system-sparc
742%defattr(644,root,root,755)
743%attr(755,root,root) %{_bindir}/qemu-system-sparc
744%attr(755,root,root) %{_bindir}/qemu-system-sparc64
745
746%files system-unicore32
747%defattr(644,root,root,755)
748%attr(755,root,root) %{_bindir}/qemu-system-unicore32
749
750%files system-x86
751%defattr(644,root,root,755)
752%attr(755,root,root) %{_bindir}/qemu-system-i386
753%attr(755,root,root) %{_bindir}/qemu-system-x86_64
754
755%files system-xtensa
756%defattr(644,root,root,755)
757%attr(755,root,root) %{_bindir}/qemu-system-xtensa
758%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.264183 seconds and 4 git commands to generate.