]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- macros for kernel not userspace
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
21b99717 4# - kqemu module could be distributable if somebody bothers to contact qemu
c33439fc 5# author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
0b3d4f1c
JB
6# (but only in source form as distribution of linked module would be
7# violation of GPL)
0b920c52 8#
6aef4654 9# Conditional build:
2dad6a94 10%bcond_without kqemu # disable QEMU accelerator support
161ffd93 11%bcond_with cflags_passing # with passing rpmcflags to Makefiles
a6d3659e 12%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
4569321b 13%bcond_without gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c 14%bcond_without dist_kernel # without distribution kernel
21b99717 15%bcond_with kernel # build kqemu kernel modules (see License)
8bb1261c
KK
16%bcond_without smp # don't build SMP module
17%bcond_without userspace # don't build userspace utilities
39b50bf0 18#
ca55b10f 19%define _kqemu_version 1.3.0pre9
21b99717 20%define _rel 1
cd19124e 21Summary: QEMU CPU Emulator
5a2da1d0 22Summary(pl): QEMU - emulator procesora
cd19124e 23Name: qemu
ca55b10f 24Version: 0.8.2
8bb1261c 25Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
26License: GPL
27Group: Applications/Emulators
867764ba 28#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 29Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
ca55b10f 30# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
c33439fc 31Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
ca55b10f 32# Source1-md5: 27888c3220844ad360a6a23345fa1bcb
8bd2aee2 33Patch0: %{name}-nostatic.patch
c33439fc 34Patch1: %{name}-cc.patch
867764ba 35Patch2: %{name}-longjmp.patch
d8d8cede 36Patch3: %{name}-dot.patch
8d073aaa
ER
37Patch4: %{name}-gcc4_x86.patch
38Patch5: %{name}-gcc4_ppc.patch
39Patch6: %{name}-nosdlgui.patch
40Patch7: %{name}-ifup.patch
81a493f2
MM
41# Proof of concept, for reference, do not remove
42Patch8: %{name}-kde_virtual_workspaces_hack.patch
e05988b9
AM
43# http://gwenole.beauchesne.info/en/projects/qemu
44Patch9: %{name}-0.8.0-gcc4-hacks.patch
45Patch10: %{name}-0.7.0-gcc4.patch
46Patch11: %{name}-0.7.2-gcc4-opts.patch
47Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
cd19124e 48URL: http://fabrice.bellard.free.fr/qemu/
d1ae30a6 49%if %{with kernel} && %{with dist_kernel}
50BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
9ea49998 51BuildRequires: rpmbuild(macros) >= 1.330
d1ae30a6 52%endif
53%if %{with userspace}
867764ba 54BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 55BuildRequires: alsa-lib-devel
21c5c008 56%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
2fb8ea02 57BuildRequires: perl-tools-pod
2fb8ea02 58BuildRequires: tetex
8bb1261c 59BuildRequires: sed >= 4.0
d1ae30a6 60%endif
8bb1261c 61Requires: SDL >= 1.2.1
2ef13cb9 62# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39b50bf0 63ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
cd19124e 64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
867764ba 66# some SPARC boot image in ELF format
ca55b10f 67%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
867764ba 68
cd19124e 69%description
70QEMU is a FAST! processor emulator. By using dynamic translation it
71achieves a reasonnable speed while being easy to port on new host
72CPUs. QEMU has two operating modes:
73
74- User mode emulation. In this mode, QEMU can launch Linux processes
75 compiled for one CPU on another CPU. Linux system calls are converted
76 because of endianness and 32/64 bit mismatches. Wine (Windows
77 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
78
79- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
80 including a processor and various peripherials. It can also be used to
81 provide virtual hosting of several virtual PC on a single server.
cd19124e 82
5a2da1d0
JB
83%description -l pl
84