]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- fixed build with PREEMPT_RT
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
6%bcond_with kqemu # with QEMU accelerator module
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
a6d3659e 8%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
27439af0 9%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c
KK
10%bcond_without dist_kernel # without distribution kernel
11%bcond_without kernel # don't build kernel modules
12%bcond_without smp # don't build SMP module
13%bcond_without userspace # don't build userspace utilities
b4eae133 14
15%define _kqemu_version 0.7.2
6aef4654 16#
cd19124e 17Summary: QEMU CPU Emulator
5a2da1d0 18Summary(pl): QEMU - emulator procesora
cd19124e 19Name: qemu
b4eae133 20Version: 0.8.0
2ab5858a 21%define _rel 1.1
8bb1261c 22Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
23License: GPL
24Group: Applications/Emulators
867764ba 25#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 26Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
b4eae133 27# Source0-md5: eb175b26583280706fe7e4d8910d320d
6aef4654 28%if %{with kqemu}
b4eae133 29Source1: http://fabrice.bellard.free.fr/qemu/kqemu-%{_kqemu_version}.tar.gz
57d8430f 30# NoSource1-md5: 02cfdecda90458d6393781496ec6b48b
6aef4654 31NoSource: 1
32%endif
8bd2aee2 33Patch0: %{name}-nostatic.patch
f1ae848c 34Patch1: %{name}-DESTDIR.patch
867764ba 35Patch2: %{name}-longjmp.patch
d8d8cede 36Patch3: %{name}-dot.patch
d5906b49 37Patch4: %{name}-initrd_load_addr.patch
0b920c52
38Patch5: %{name}-gcc4_x86.patch
39Patch6: %{name}-gcc4_ppc.patch
3b2d6429 40Patch7: %{name}-parallel.patch
a6d3659e 41Patch8: %{name}-nosdlgui.patch
ac6e5743 42Patch9: %{name}-ifup.patch
3fe0282d 43Patch10: %{name}-gcc33.patch
2ab5858a 44Patch11: %{name}-slirp_throttle.patch
cd19124e 45URL: http://fabrice.bellard.free.fr/qemu/
867764ba 46BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 47BuildRequires: alsa-lib-devel
21c5c008 48%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
8bb1261c
KK
49%if %{with kqemu} && %{with dist_kernel}
50BuildRequires: kernel-module-build >= 2.6.7
4b0669f5 51%endif
8bb1261c
KK
52BuildRequires: rpmbuild(macros) >= 1.217
53BuildRequires: sed >= 4.0
54Requires: SDL >= 1.2.1
35648466 55ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
2ef13cb9 56# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
cd19124e 57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
867764ba
JB
59# some SPARC boot image in ELF format
60%define _noautostrip .*%{_datadir}/qemu/proll.elf
61
8bb1261c
KK
62%if !%{with kqemu}
63%undefine with_kernel
64%endif
65
cd19124e 66%description
67QEMU is a FAST! processor emulator. By using dynamic translation it
68achieves a reasonnable speed while being easy to port on new host
69CPUs. QEMU has two operating modes:
70
71- User mode emulation. In this mode, QEMU can launch Linux processes
72 compiled for one CPU on another CPU. Linux system calls are converted
73 because of endianness and 32/64 bit mismatches. Wine (Windows
74 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
75
76- Full system emulation. In this mode, QEMU emulates a full system,
c012f329 77 including a processor and various peripherials.
78 It can also be used to provide virtual hosting of several
79 virtual PC on a single server.
cd19124e 80
5a2da1d0
JB
81%description -l pl
82