]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- bconds can be confusing sometimes
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
c33439fc
ER
4# - kqemu could be distributable if somebody bothers to contact qemu
5# author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
0b920c52 6#
6aef4654 7# Conditional build:
2dad6a94 8%bcond_without kqemu # disable QEMU accelerator support
161ffd93 9%bcond_with cflags_passing # with passing rpmcflags to Makefiles
a6d3659e 10%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
27439af0 11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c 12%bcond_without dist_kernel # without distribution kernel
2dad6a94 13%bcond_with kernel # build kqemu kernel modules
8bb1261c
KK
14%bcond_without smp # don't build SMP module
15%bcond_without userspace # don't build userspace utilities
39b50bf0
ER
16#
17%define _kqemu_version 1.3.0pre7
2dad6a94 18%define _rel 0.4
cd19124e 19Summary: QEMU CPU Emulator
5a2da1d0 20Summary(pl): QEMU - emulator procesora
cd19124e 21Name: qemu
c33439fc 22Version: 0.8.1
8bb1261c 23Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
24License: GPL
25Group: Applications/Emulators
867764ba 26#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 27Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
c33439fc
ER
28# Source0-md5: 67d924324a5ab79d017bd97a1e767285
29Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
39b50bf0 30# NoSource1-md5: 3b77edbada790f924456aa4675edd0be
6aef4654 31NoSource: 1
8bd2aee2 32Patch0: %{name}-nostatic.patch
c33439fc 33Patch1: %{name}-cc.patch
867764ba 34Patch2: %{name}-longjmp.patch
d8d8cede 35Patch3: %{name}-dot.patch
c33439fc 36
0b920c52
37Patch5: %{name}-gcc4_x86.patch
38Patch6: %{name}-gcc4_ppc.patch
3b2d6429 39Patch7: %{name}-parallel.patch
a6d3659e 40Patch8: %{name}-nosdlgui.patch
ac6e5743 41Patch9: %{name}-ifup.patch
3fe0282d 42Patch10: %{name}-gcc33.patch
c33439fc 43
cd19124e 44URL: http://fabrice.bellard.free.fr/qemu/
867764ba 45BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 46BuildRequires: alsa-lib-devel
21c5c008 47%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
8bb1261c 48%if %{with kqemu} && %{with dist_kernel}
8799423b 49BuildRequires: kernel-module-build >= 3:2.6.7
4b0669f5 50%endif
8bb1261c
KK
51BuildRequires: rpmbuild(macros) >= 1.217
52BuildRequires: sed >= 4.0
53Requires: SDL >= 1.2.1
2ef13cb9 54# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39b50bf0 55ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
cd19124e 56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
867764ba
JB
58# some SPARC boot image in ELF format
59%define _noautostrip .*%{_datadir}/qemu/proll.elf
60
cd19124e 61%description
62QEMU is a FAST! processor emulator. By using dynamic translation it
63achieves a reasonnable speed while being easy to port on new host
64CPUs. QEMU has two operating modes:
65
66- User mode emulation. In this mode, QEMU can launch Linux processes
67 compiled for one CPU on another CPU. Linux system calls are converted
68 because of endianness and 32/64 bit mismatches. Wine (Windows
69 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
70
71- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
72 including a processor and various peripherials. It can also be used to
73 provide virtual hosting of several virtual PC on a single server.
cd19124e 74
5a2da1d0
JB
75%description -l pl
76