]> git.pld-linux.org Git - packages/python3-requests.git/blame - python-requests.spec
- try with tests, added reqs,disable-xdist patches, but one test fails
[packages/python3-requests.git] / python-requests.spec
CommitLineData
ef9212ce 1#
8d099eee 2# Conditional build:
23351644 3%bcond_with tests # pytest tests (one test fails with pytest-httpbin 1.0.0)
ef9212ce
JB
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
dd9a8c31 6
44a39070 7%define urllib3_ver 1.21.1
dd9a8c31
ER
8%define module requests
9%define egg_name requests
ef9212ce
JB
10Summary: HTTP library for Python 2
11Summary(pl.UTF-8): Biblioteka HTTP dla Pythona 2
8ba13116 12Name: python-%{module}
a5ef80ca 13Version: 2.26.0
24e1d820 14Release: 2
017795a9 15License: Apache v2.0
8ba13116 16Group: Development/Languages/Python
44a39070
JB
17#Source0Download: https://pypi.org/simple/requests/
18Source0: https://files.pythonhosted.org/packages/source/r/requests/%{module}-%{version}.tar.gz
a5ef80ca 19# Source0-md5: 8c745949ad3e9ae83d9927fed213db8a
0989c03f 20Patch0: system-cert.patch
23351644
JB
21Patch1: %{name}-reqs.patch
22Patch2: %{name}-disable-xdist.patch
23URL: https://docs.python-requests.org/
dd9a8c31
ER
24BuildRequires: rpm-pythonprov
25BuildRequires: rpmbuild(macros) >= 1.713
a8d01621 26%if %{with python2}
d04d981e 27BuildRequires: python-modules >= 1:2.7
dd9a8c31 28BuildRequires: python-setuptools
017795a9 29%if %{with tests}
d04d981e 30BuildRequires: python-PySocks >= 1.5.8
dd9a8c31 31BuildRequires: python-certifi >= 2017.4.17
0989c03f 32BuildRequires: python-chardet >= 3.0.2
fa360ea6 33BuildRequires: python-chardet < 5
a5ef80ca 34# idna 3 not supported for python2
0989c03f 35BuildRequires: python-idna >= 2.5
0ecc0c85
JB
36BuildRequires: python-idna < 3
37BuildRequires: python-pytest >= 3
017795a9
JB
38BuildRequires: python-pytest-cov
39BuildRequires: python-pytest-httpbin >= 0.0.7
fa360ea6 40BuildRequires: python-pytest-mock >= 2.0.0
d04d981e 41BuildRequires: python-pytest-xdist
44a39070 42BuildRequires: python-urllib3 >= %{urllib3_ver}
fa360ea6 43BuildRequires: python-urllib3 < 1.27
017795a9 44%endif
27c2bafe 45%endif
a8d01621 46%if %{with python3}
a5ef80ca 47BuildRequires: python3-modules >= 1:3.6
616851f8 48BuildRequires: python3-setuptools
017795a9 49%if %{with tests}
d04d981e 50BuildRequires: python3-PySocks >= 1.5.8
dd9a8c31 51BuildRequires: python3-certifi >= 2017.4.17
0989c03f 52BuildRequires: python3-chardet >= 3.0.2
fa360ea6 53BuildRequires: python3-chardet < 5
0989c03f 54BuildRequires: python3-idna >= 2.5
0ecc0c85 55BuildRequires: python3-pytest >= 3
017795a9
JB
56BuildRequires: python3-pytest-cov
57BuildRequires: python3-pytest-httpbin >= 0.0.7
fa360ea6 58BuildRequires: python3-pytest-mock >= 2.0.0
d04d981e 59BuildRequires: python3-pytest-xdist
44a39070 60BuildRequires: python3-urllib3 >= %{urllib3_ver}
fa360ea6 61BuildRequires: python3-urllib3 < 1.27
017795a9 62%endif
27c2bafe 63%endif
dd9a8c31 64Suggests: ca-certificates
e7d50ac0 65# for python2 only to get SNI working. python3 doesn't need this
d04d981e 66Requires: python-cryptography >= 1.3.4
017795a9 67Requires: python-pyOpenSSL >= 0.14
ecc66759 68Requires: python-urllib3 >= 1.22-2
8ba13116
MM
69BuildArch: noarch
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72%description
a8d01621 73Requests is a HTTP library, written in Python, for human beings.
8ba13116
MM
74
75Most existing Python modules for sending HTTP requests are extremely
76verbose and cumbersome. Python's builtin urllib2 module provides most
8d099eee 77of the HTTP capabilities you should need, but the API is thoroughly
8ba13116 78broken. It requires an enormous amount of work (even method overrides)
8d099eee
JB
79to perform the simplest of tasks. Things shouldn't be this way. Not in
80Python.
81
ef9212ce
JB
82This package contains Python 2.x module.
83
8d099eee 84%description -l pl.UTF-8
a8d01621 85Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
8ba13116 86
8d099eee
JB
87Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
88zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
89zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
90wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
91najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
8ba13116 92
ef9212ce
JB
93Ten pakiet zawiera moduł dla Pythona 2.x.
94
a0c91a8e 95%package -n python3-requests
ef9212ce
JB
96Summary: HTTP library for Python 3
97Summary(pl.UTF-8): Biblioteka HTTP dla Pythona 3
a0c91a8e 98Group: Development/Languages/Python
a5ef80ca 99Requires: python3-modules >= 1:3.6
24e1d820 100Requires: python3-charset_normalizer >= 2
d04d981e
JB
101# for https
102Requires: python3-cryptography >= 1.3.4
24e1d820 103Requires: python3-idna >= 2.5
d04d981e 104Requires: python3-pyOpenSSL >= 0.14
ecc66759 105Requires: python3-urllib3 >= 1.22-2
dd9a8c31 106Suggests: ca-certificates
a0c91a8e
KK
107
108%description -n python3-requests
a8d01621 109Requests is a HTTP library, written in Python, for human beings.
a0c91a8e
KK
110
111Most existing Python modules for sending HTTP requests are extremely
112verbose and cumbersome. Python's builtin urllib2 module provides most
113of the HTTP capabilities you should need, but the api is thoroughly
114broken. It requires an enormous amount of work (even method overrides)
8d099eee
JB
115to perform the simplest of tasks. Things shouldn't be this way. Not in
116Python.
117
ef9212ce
JB
118This package contains Python 3.x module.
119
8d099eee 120%description -n python3-requests -l pl.UTF-8
a8d01621 121Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
a0c91a8e 122
a8d01621
ŁK
123Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
124zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
125zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
126wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
127najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
a0c91a8e 128
ef9212ce
JB
129Ten pakiet zawiera moduł dla Pythona 3.x.
130
8ba13116 131%prep
a8d01621 132%setup -q -n %{module}-%{version}
0989c03f 133%patch0 -p1
23351644
JB
134%patch1 -p1
135%patch2 -p1
e16ab944 136
8ba13116 137%build
a8d01621 138%if %{with python2}
23351644
JB
139%py_build
140
141PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
142PYTEST_PLUGINS="pytest_httpbin.plugin,pytest_mock" \
143%{__python} -m pytest tests
a8d01621 144%endif
a0c91a8e 145
a8d01621 146%if %{with python3}
23351644
JB
147%py3_build
148
149PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
150PYTEST_PLUGINS="pytest_httpbin.plugin,pytest_mock" \
151%{__python3} -m pytest tests
8d099eee 152%endif
8ba13116
MM
153
154%install
155rm -rf $RPM_BUILD_ROOT
a8d01621
ŁK
156
157%if %{with python2}
b4dcbe07 158%py_install
fa360ea6 159
a8d01621
ŁK
160%py_postclean
161%endif
8ba13116 162
a8d01621 163%if %{with python3}
b4dcbe07 164%py3_install
a8d01621 165%endif
8ba13116
MM
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
a8d01621 170%if %{with python2}
8ba13116
MM
171%files
172%defattr(644,root,root,755)
283f39fa 173%doc HISTORY.md README.md
8ba13116 174%{py_sitescriptdir}/%{module}
dd9a8c31 175%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
a8d01621 176%endif
a0c91a8e 177
a8d01621 178%if %{with python3}
a0c91a8e
KK
179%files -n python3-requests
180%defattr(644,root,root,755)
283f39fa 181%doc HISTORY.md README.md
a0c91a8e 182%{py3_sitescriptdir}/%{module}
dd9a8c31 183%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
a8d01621 184%endif
This page took 0.068718 seconds and 4 git commands to generate.