]> git.pld-linux.org Git - packages/python3-requests.git/blame - python-requests.spec
drop autogenerated deps
[packages/python3-requests.git] / python-requests.spec
CommitLineData
ef9212ce 1#
8d099eee 2# Conditional build:
017795a9 3%bcond_with tests # test target (tests not included in dist tarball as of 2.13.0)
ef9212ce
JB
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
dd9a8c31 6
0989c03f 7%define urllib3ver 1.21.1
dd9a8c31
ER
8%define module requests
9%define egg_name requests
10%define pypi_name requests
ef9212ce
JB
11Summary: HTTP library for Python 2
12Summary(pl.UTF-8): Biblioteka HTTP dla Pythona 2
8ba13116 13Name: python-%{module}
dd9a8c31 14Version: 2.18.3
017795a9
JB
15Release: 1
16License: Apache v2.0
8ba13116 17Group: Development/Languages/Python
dd9a8c31
ER
18Source0: https://files.pythonhosted.org/packages/source/r/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
19# Source0-md5: c8f60cf816a35c0c3fef0a40d0e407a6
0989c03f 20Patch0: system-cert.patch
017795a9 21URL: http://python-requests.org/
dd9a8c31
ER
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.713
a8d01621
ŁK
24%if %{with python2}
25BuildRequires: python-modules >= 1:2.6
dd9a8c31 26BuildRequires: python-setuptools
017795a9 27%if %{with tests}
dd9a8c31 28BuildRequires: python-certifi >= 2017.4.17
0989c03f
JK
29BuildRequires: python-chardet >= 3.0.2
30BuildRequires: python-idna >= 2.5
017795a9
JB
31BuildRequires: python-pytest >= 2.8.0
32BuildRequires: python-pytest-cov
33BuildRequires: python-pytest-httpbin >= 0.0.7
34BuildRequires: python-pytest-mock
dd9a8c31 35BuildRequires: python-urllib3 >= %{urllib3ver}
017795a9 36%endif
27c2bafe 37%endif
a8d01621 38%if %{with python3}
ef9212ce 39BuildRequires: python3-modules >= 1:3.2
017795a9 40%if %{with tests}
dd9a8c31 41BuildRequires: python3-certifi >= 2017.4.17
0989c03f
JK
42BuildRequires: python3-chardet >= 3.0.2
43BuildRequires: python3-idna >= 2.5
017795a9
JB
44BuildRequires: python3-pytest >= 2.8.0
45BuildRequires: python3-pytest-cov
46BuildRequires: python3-pytest-httpbin >= 0.0.7
47BuildRequires: python3-pytest-mock
dd9a8c31 48BuildRequires: python3-urllib3 >= %{urllib3ver}
017795a9 49%endif
27c2bafe 50%endif
dd9a8c31 51Suggests: ca-certificates
e7d50ac0
AM
52# for python2 only to get SNI working. python3 doesn't need this
53Requires: python-ndg-httpsclient
017795a9 54Requires: python-pyOpenSSL >= 0.14
dd9a8c31 55Requires: python-pyasn1
8ba13116
MM
56BuildArch: noarch
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59%description
a8d01621 60Requests is a HTTP library, written in Python, for human beings.
8ba13116
MM
61
62Most existing Python modules for sending HTTP requests are extremely
63verbose and cumbersome. Python's builtin urllib2 module provides most
8d099eee 64of the HTTP capabilities you should need, but the API is thoroughly
8ba13116 65broken. It requires an enormous amount of work (even method overrides)
8d099eee
JB
66to perform the simplest of tasks. Things shouldn't be this way. Not in
67Python.
68
ef9212ce
JB
69This package contains Python 2.x module.
70
8d099eee 71%description -l pl.UTF-8
a8d01621 72Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
8ba13116 73
8d099eee
JB
74Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
75zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
76zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
77wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
78najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
8ba13116 79
ef9212ce
JB
80Ten pakiet zawiera moduł dla Pythona 2.x.
81
a0c91a8e 82%package -n python3-requests
ef9212ce
JB
83Summary: HTTP library for Python 3
84Summary(pl.UTF-8): Biblioteka HTTP dla Pythona 3
a0c91a8e 85Group: Development/Languages/Python
dd9a8c31 86Suggests: ca-certificates
a0c91a8e
KK
87
88%description -n python3-requests
a8d01621 89Requests is a HTTP library, written in Python, for human beings.
a0c91a8e
KK
90
91Most existing Python modules for sending HTTP requests are extremely
92verbose and cumbersome. Python's builtin urllib2 module provides most
93of the HTTP capabilities you should need, but the api is thoroughly
94broken. It requires an enormous amount of work (even method overrides)
8d099eee
JB
95to perform the simplest of tasks. Things shouldn't be this way. Not in
96Python.
97
ef9212ce
JB
98This package contains Python 3.x module.
99
8d099eee 100%description -n python3-requests -l pl.UTF-8
a8d01621 101Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
a0c91a8e 102
a8d01621
ŁK
103Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
104zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
105zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
106wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
107najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
a0c91a8e 108
ef9212ce
JB
109Ten pakiet zawiera moduł dla Pythona 3.x.
110
8ba13116 111%prep
a8d01621 112%setup -q -n %{module}-%{version}
0989c03f 113%patch0 -p1
e16ab944 114
8ba13116 115%build
a8d01621 116%if %{with python2}
b4dcbe07 117%py_build %{?with_tests:test}
a8d01621 118%endif
a0c91a8e 119
a8d01621 120%if %{with python3}
b4dcbe07 121%py3_build %{?with_tests:test}
8d099eee 122%endif
8ba13116
MM
123
124%install
125rm -rf $RPM_BUILD_ROOT
a8d01621
ŁK
126
127%if %{with python2}
b4dcbe07 128%py_install
4a7ef446
ŁK
129%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
130%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
a8d01621
ŁK
131%py_postclean
132%endif
8ba13116 133
a8d01621 134%if %{with python3}
b4dcbe07 135%py3_install
a8d01621 136%endif
8ba13116
MM
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
a8d01621 141%if %{with python2}
8ba13116
MM
142%files
143%defattr(644,root,root,755)
a8d01621 144%doc HISTORY.rst README.rst
8ba13116 145%{py_sitescriptdir}/%{module}
dd9a8c31 146%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
a8d01621 147%endif
a0c91a8e 148
a8d01621 149%if %{with python3}
a0c91a8e
KK
150%files -n python3-requests
151%defattr(644,root,root,755)
a8d01621 152%doc HISTORY.rst README.rst
a0c91a8e 153%{py3_sitescriptdir}/%{module}
dd9a8c31 154%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
a8d01621 155%endif
This page took 0.062333 seconds and 4 git commands to generate.