]> git.pld-linux.org Git - packages/python3-requests.git/blame - python-requests.spec
Initial, works, but there's problem with versioning; rel 0.1
[packages/python3-requests.git] / python-requests.spec
CommitLineData
8ba13116
MM
1%define module requests
2Summary: HTTP library for Python
3Name: python-%{module}
4Version: 0.13.3
5%define _verinternal 0.13.2
6%define _relstr 11-g52b55cc
7Release: 0.1
8License: ISC
9Group: Development/Languages/Python
10Source0: https://github.com/kennethreitz/requests/tarball/develop/kennethreitz-%{module}-v%{version}-%{_relstr}.tar.gz
11# Source0-md5: 083bd0d48b75d2ab79f2636f5bb204fc
12URL: https://github.com/kennethreitz/requests
13BuildRequires: rpm-pythonprov
14BuildRequires: rpmbuild(macros) >= 1.219
15Requires: python-modules
16BuildArch: noarch
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20Requests is an ISC Licensed HTTP library, written in Python, for human
21beings.
22
23Most existing Python modules for sending HTTP requests are extremely
24verbose and cumbersome. Python's builtin urllib2 module provides most
25of the HTTP capabilities you should need, but the api is thoroughly
26broken. It requires an enormous amount of work (even method overrides)
27to perform the simplest of tasks.
28
29Things shouldn't be this way. Not in Python.
30
31%prep
32%setup -qc
33mv *-%{module}-*/* .
34
35%build
36# Filename says 0.13.3, __version__ says 0.13.2, so the test fails
37#ver=$(%{__python} -c "import requests; print requests.__version__")
38#test "$ver" = %{version}
39
40%{__python} setup.py build
41
42%install
43rm -rf $RPM_BUILD_ROOT
44%{__python} setup.py install \
45 --skip-build \
46 --optimize=2 \
47 --root=$RPM_BUILD_ROOT
48
49%py_postclean
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%files
55%defattr(644,root,root,755)
56%doc AUTHORS.rst README.rst LICENSE docs
57%{py_sitescriptdir}/%{module}
58%if "%{py_ver}" > "2.4"
59%{py_sitescriptdir}/%{module}-%{_verinternal}-*.egg-info
60%endif
This page took 0.050062 seconds and 4 git commands to generate.