]> git.pld-linux.org Git - packages/python3-cryptography.git/blob - python-cryptography.spec
- noarch apidocs
[packages/python3-cryptography.git] / python-cryptography.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_without  doc     # Sphinx documentation
6 %bcond_with     tests   # test target [not all dependencies are currently available in PLD]
7
8 Summary:        Crypthography library for Python 2
9 Summary(pl.UTF-8):      Biblioteka Cryptography dla Pythona 2
10 Name:           python-cryptography
11 Version:        2.7
12 Release:        1
13 License:        Apache v2.0 or BSD
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/cryptography/
16 Source0:        https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
17 # Source0-md5:  7dfe1035cae43569e571318f000462a4
18 URL:            https://cryptography.io/
19 BuildRequires:  openssl-devel >= 1.0.1
20 BuildRequires:  rpm-pythonprov >= 5.4.15-48
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 %if %{with python2}
23 BuildRequires:  python-cffi >= 1.8
24 BuildRequires:  python-devel >= 1:2.7
25 BuildRequires:  python-enum34
26 BuildRequires:  python-pytz
27 BuildRequires:  python-setuptools >= 18.5
28 BuildRequires:  python-six >= 1.4.1
29 %if %{with tests}
30 BuildRequires:  python-asn1crypto >= 0.21.0
31 BuildRequires:  python-cryptography_vectors
32 %if "%{py_ver}" >= "2.7"
33 BuildRequires:  python-hypothesis >= 1.11.4
34 %endif
35 BuildRequires:  python-idna >= 2.1
36 BuildRequires:  python-ipaddress
37 BuildRequires:  python-iso8601
38 BuildRequires:  python-pretend
39 BuildRequires:  python-pytest >= 3.6.0
40 BuildRequires:  python-pytz
41 %endif
42 %endif
43 %if %{with python3}
44 BuildRequires:  python3-cffi >= 1.8
45 BuildRequires:  python3-devel >= 1:3.4
46 BuildRequires:  python3-setuptools >= 18.5
47 BuildRequires:  python3-six >= 1.4.1
48 %if %{with tests}
49 BuildRequires:  python3-asn1crypto >= 0.21.0
50 BuildRequires:  python3-cryptography_vectors
51 BuildRequires:  python3-hypothesis >= 1.11.4
52 BuildRequires:  python3-idna >= 2.1
53 BuildRequires:  python3-iso8601
54 BuildRequires:  python3-pretend
55 BuildRequires:  python3-pytest >= 3.6.0
56 BuildRequires:  python3-pytz
57 %endif
58 %endif
59 %if %{with doc}
60 BuildRequires:  python3-sphinx_rtd_theme
61 BuildRequires:  sphinx-pdg-3 >= 1.6.5
62 %endif
63 Requires:       openssl >= 1.0.1
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 cryptography is a package designed to expose cryptographic recipes and
68 primitives to Python developers. Our goal is for it to be your
69 "cryptographic standard library". It supports Python 2.6-2.7, Python
70 3.2+, and PyPy.
71
72 cryptography includes both high level recipes, and low level
73 interfaces to common cryptographic algorithms such as symmetric
74 ciphers, message digests and key derivation functions.
75
76 This package contains Python 2 modules.
77
78 %description -l pl.UTF-8
79 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
80 obiektów kryptograficznych programistom Pythona. Celem jest
81 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
82 Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
83
84 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
85 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
86 takich jak szyfry symetryczne, skróty wiadomości czy funkcje
87 wyprowadzające klucze.
88
89 Ten pakiet zawiera moduły Pythona 2.
90
91 %package -n python3-cryptography
92 Summary:        Crypthography library for Python 3
93 Summary(pl.UTF-8):      Biblioteka Cryptography dla Pythona 3
94 Group:          Libraries/Python
95 Requires:       openssl >= 1.0.1
96
97 %description -n python3-cryptography
98 cryptography is a package designed to expose cryptographic recipes and
99 primitives to Python developers. Our goal is for it to be your
100 "cryptographic standard library". It supports Python 2.6-2.7, Python
101 3.2+, and PyPy.
102
103 cryptography includes both high level recipes, and low level
104 interfaces to common cryptographic algorithms such as symmetric
105 ciphers, message digests and key derivation functions.
106
107 This package contains Python 3 modules.
108
109 %description -n python3-cryptography -l pl.UTF-8
110 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
111 obiektów kryptograficznych programistom Pythona. Celem jest
112 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
113 Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
114
115 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
116 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
117 takich jak szyfry symetryczne, skróty wiadomości czy funkcje
118 wyprowadzające klucze.
119
120 Ten pakiet zawiera moduły Pythona 3.
121
122 %package apidocs
123 Summary:        API documentation for cryptography module
124 Summary(pl.UTF-8):      Dokumentacja API modułu cryptography
125 Group:          Documentation
126 %if "%{_rpmversion}" >= "5"
127 BuildArch:      noarch
128 %endif
129
130 %description apidocs
131 API documentation for cryptography module.
132
133 %description apidocs -l pl.UTF-8
134 Dokumentacja API modułu cryptography.
135
136 %prep
137 %setup -q -n cryptography-%{version}
138
139 %build
140 export CFLAGS="%{rpmcflags}"
141
142 %if %{with python2}
143 %py_build %{?with_tests:test}
144 %endif
145
146 %if %{with python2}
147 %py3_build %{?with_tests:test}
148 %endif
149
150 %if %{with doc}
151 %{__make} -C docs html \
152         SPHINXBUILD=sphinx-build-3
153 %endif
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157
158 %if %{with python2}
159 %py_install
160
161 %py_postclean
162 %endif
163
164 %if %{with python3}
165 %py3_install
166 %endif
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %if %{with python2}
172 %files
173 %defattr(644,root,root,755)
174 %doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
175 %dir %{py_sitedir}/cryptography
176 %{py_sitedir}/cryptography/*.py[co]
177 %dir %{py_sitedir}/cryptography/hazmat
178 %{py_sitedir}/cryptography/hazmat/*.py[co]
179 %dir %{py_sitedir}/cryptography/hazmat/backends
180 %{py_sitedir}/cryptography/hazmat/backends/*.py[co]
181 %dir %{py_sitedir}/cryptography/hazmat/backends/openssl
182 %{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
183 %dir %{py_sitedir}/cryptography/hazmat/bindings
184 %{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
185 %attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
186 %dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
187 %{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
188 %dir %{py_sitedir}/cryptography/hazmat/primitives
189 %{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
190 %dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
191 %{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
192 %dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
193 %{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
194 %dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
195 %{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
196 %dir %{py_sitedir}/cryptography/hazmat/primitives/serialization
197 %{py_sitedir}/cryptography/hazmat/primitives/serialization/*.py[co]
198 %dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
199 %{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
200 %dir %{py_sitedir}/cryptography/x509
201 %{py_sitedir}/cryptography/x509/*.py[co]
202 %{py_sitedir}/cryptography-%{version}-py*.egg-info
203 %endif
204
205 %if %{with python3}
206 %files -n python3-cryptography
207 %defattr(644,root,root,755)
208 %doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
209 %dir %{py3_sitedir}/cryptography
210 %{py3_sitedir}/cryptography/*.py
211 %{py3_sitedir}/cryptography/__pycache__
212 %dir %{py3_sitedir}/cryptography/hazmat
213 %{py3_sitedir}/cryptography/hazmat/*.py
214 %{py3_sitedir}/cryptography/hazmat/__pycache__
215 %dir %{py3_sitedir}/cryptography/hazmat/backends
216 %{py3_sitedir}/cryptography/hazmat/backends/*.py
217 %{py3_sitedir}/cryptography/hazmat/backends/__pycache__
218 %dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
219 %{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
220 %{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
221 %dir %{py3_sitedir}/cryptography/hazmat/bindings
222 %{py3_sitedir}/cryptography/hazmat/bindings/*.py
223 %{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
224 %attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
225 %dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
226 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
227 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
228 %dir %{py3_sitedir}/cryptography/hazmat/primitives
229 %{py3_sitedir}/cryptography/hazmat/primitives/*.py
230 %{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
231 %dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
232 %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
233 %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
234 %dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
235 %{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
236 %{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
237 %dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
238 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
239 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
240 %dir %{py3_sitedir}/cryptography/hazmat/primitives/serialization
241 %{py3_sitedir}/cryptography/hazmat/primitives/serialization/*.py
242 %{py3_sitedir}/cryptography/hazmat/primitives/serialization/__pycache__
243 %dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
244 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
245 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
246 %dir %{py3_sitedir}/cryptography/x509
247 %{py3_sitedir}/cryptography/x509/*.py
248 %{py3_sitedir}/cryptography/x509/__pycache__
249 %{py3_sitedir}/cryptography-%{version}-py*.egg-info
250 %endif
251
252 %if %{with doc}
253 %files apidocs
254 %defattr(644,root,root,755)
255 %doc docs/_build/html/{_downloads,_modules,_static,development,hazmat,x509,*.html,*.js}
256 %endif
This page took 0.36644 seconds and 4 git commands to generate.