]> git.pld-linux.org Git - packages/python3-cryptography.git/blame - python-cryptography.spec
- noarch apidocs
[packages/python3-cryptography.git] / python-cryptography.spec
CommitLineData
06232684
JB
1#
2# Conditional build:
049a803f
JB
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
f63b1331 5%bcond_without doc # Sphinx documentation
049a803f 6%bcond_with tests # test target [not all dependencies are currently available in PLD]
06232684
JB
7
8Summary: Crypthography library for Python 2
9Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
10Name: python-cryptography
f63b1331 11Version: 2.7
606dca6b 12Release: 1
d6e7edf5 13License: Apache v2.0 or BSD
06232684 14Group: Libraries/Python
29d4b67b 15#Source0Download: https://pypi.org/simple/cryptography/
7df50b22 16Source0: https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
f63b1331 17# Source0-md5: 7dfe1035cae43569e571318f000462a4
06232684 18URL: https://cryptography.io/
7df50b22 19BuildRequires: openssl-devel >= 1.0.1
d331861d 20BuildRequires: rpm-pythonprov >= 5.4.15-48
049a803f 21BuildRequires: rpmbuild(macros) >= 1.714
06232684 22%if %{with python2}
f63b1331 23BuildRequires: python-cffi >= 1.8
29d4b67b 24BuildRequires: python-devel >= 1:2.7
b2fc4ef3 25BuildRequires: python-enum34
29d4b67b
JB
26BuildRequires: python-pytz
27BuildRequires: python-setuptools >= 18.5
06232684 28BuildRequires: python-six >= 1.4.1
049a803f 29%if %{with tests}
29d4b67b 30BuildRequires: python-asn1crypto >= 0.21.0
049a803f
JB
31BuildRequires: python-cryptography_vectors
32%if "%{py_ver}" >= "2.7"
33BuildRequires: python-hypothesis >= 1.11.4
34%endif
29d4b67b 35BuildRequires: python-idna >= 2.1
049a803f
JB
36BuildRequires: python-ipaddress
37BuildRequires: python-iso8601
38BuildRequires: python-pretend
29d4b67b 39BuildRequires: python-pytest >= 3.6.0
f63b1331 40BuildRequires: python-pytz
049a803f 41%endif
06232684
JB
42%endif
43%if %{with python3}
f63b1331 44BuildRequires: python3-cffi >= 1.8
d331861d 45BuildRequires: python3-devel >= 1:3.4
29d4b67b 46BuildRequires: python3-setuptools >= 18.5
06232684 47BuildRequires: python3-six >= 1.4.1
049a803f 48%if %{with tests}
29d4b67b 49BuildRequires: python3-asn1crypto >= 0.21.0
049a803f
JB
50BuildRequires: python3-cryptography_vectors
51BuildRequires: python3-hypothesis >= 1.11.4
29d4b67b 52BuildRequires: python3-idna >= 2.1
049a803f
JB
53BuildRequires: python3-iso8601
54BuildRequires: python3-pretend
29d4b67b 55BuildRequires: python3-pytest >= 3.6.0
f63b1331
JB
56BuildRequires: python3-pytz
57%endif
049a803f 58%endif
f63b1331
JB
59%if %{with doc}
60BuildRequires: python3-sphinx_rtd_theme
61BuildRequires: sphinx-pdg-3 >= 1.6.5
06232684 62%endif
7df50b22 63Requires: openssl >= 1.0.1
06232684
JB
64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66%description
67cryptography is a package designed to expose cryptographic recipes and
68primitives to Python developers. Our goal is for it to be your
69"cryptographic standard library". It supports Python 2.6-2.7, Python
703.2+, and PyPy.
71
72cryptography includes both high level recipes, and low level
73interfaces to common cryptographic algorithms such as symmetric
74ciphers, message digests and key derivation functions.
75
76This package contains Python 2 modules.
77
78%description -l pl.UTF-8
79cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
80obiektów kryptograficznych programistom Pythona. Celem jest
81dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
82Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
83
84cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
85niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 86takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
87wyprowadzające klucze.
88
89Ten pakiet zawiera moduły Pythona 2.
90
91%package -n python3-cryptography
92Summary: Crypthography library for Python 3
93Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
94Group: Libraries/Python
7df50b22 95Requires: openssl >= 1.0.1
06232684
JB
96
97%description -n python3-cryptography
98cryptography is a package designed to expose cryptographic recipes and
99primitives to Python developers. Our goal is for it to be your
100"cryptographic standard library". It supports Python 2.6-2.7, Python
1013.2+, and PyPy.
102
103cryptography includes both high level recipes, and low level
104interfaces to common cryptographic algorithms such as symmetric
105ciphers, message digests and key derivation functions.
106
107This package contains Python 3 modules.
108
109%description -n python3-cryptography -l pl.UTF-8
110cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
111obiektów kryptograficznych programistom Pythona. Celem jest
112dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
113Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
114
115cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
116niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 117takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
118wyprowadzające klucze.
119
120Ten pakiet zawiera moduły Pythona 3.
121
f63b1331
JB
122%package apidocs
123Summary: API documentation for cryptography module
124Summary(pl.UTF-8): Dokumentacja API modułu cryptography
125Group: Documentation
094f23d7
JB
126%if "%{_rpmversion}" >= "5"
127BuildArch: noarch
128%endif
f63b1331
JB
129
130%description apidocs
131API documentation for cryptography module.
132
133%description apidocs -l pl.UTF-8
134Dokumentacja API modułu cryptography.
135
06232684
JB
136%prep
137%setup -q -n cryptography-%{version}
138
139%build
140export CFLAGS="%{rpmcflags}"
141
142%if %{with python2}
049a803f 143%py_build %{?with_tests:test}
06232684
JB
144%endif
145
146%if %{with python2}
049a803f 147%py3_build %{?with_tests:test}
06232684
JB
148%endif
149
f63b1331
JB
150%if %{with doc}
151%{__make} -C docs html \
152 SPHINXBUILD=sphinx-build-3
153%endif
154
06232684
JB
155%install
156rm -rf $RPM_BUILD_ROOT
157
158%if %{with python2}
6d1f8f74 159%py_install
06232684
JB
160
161%py_postclean
162%endif
163
164%if %{with python3}
6d1f8f74 165%py3_install
06232684
JB
166%endif
167
168%clean
169rm -rf $RPM_BUILD_ROOT
170
171%if %{with python2}
172%files
173%defattr(644,root,root,755)
049a803f 174%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
06232684 175%dir %{py_sitedir}/cryptography
06232684
JB
176%{py_sitedir}/cryptography/*.py[co]
177%dir %{py_sitedir}/cryptography/hazmat
178%{py_sitedir}/cryptography/hazmat/*.py[co]
179%dir %{py_sitedir}/cryptography/hazmat/backends
180%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
06232684
JB
181%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
182%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
183%dir %{py_sitedir}/cryptography/hazmat/bindings
184%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
d198b5a4 185%attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
186%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
187%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
188%dir %{py_sitedir}/cryptography/hazmat/primitives
189%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
190%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
191%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
192%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
193%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
194%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
195%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
f63b1331
JB
196%dir %{py_sitedir}/cryptography/hazmat/primitives/serialization
197%{py_sitedir}/cryptography/hazmat/primitives/serialization/*.py[co]
f7d88309
AM
198%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
199%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
d198b5a4
AM
200%dir %{py_sitedir}/cryptography/x509
201%{py_sitedir}/cryptography/x509/*.py[co]
06232684
JB
202%{py_sitedir}/cryptography-%{version}-py*.egg-info
203%endif
204
205%if %{with python3}
206%files -n python3-cryptography
207%defattr(644,root,root,755)
049a803f 208%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
06232684 209%dir %{py3_sitedir}/cryptography
06232684
JB
210%{py3_sitedir}/cryptography/*.py
211%{py3_sitedir}/cryptography/__pycache__
212%dir %{py3_sitedir}/cryptography/hazmat
213%{py3_sitedir}/cryptography/hazmat/*.py
214%{py3_sitedir}/cryptography/hazmat/__pycache__
215%dir %{py3_sitedir}/cryptography/hazmat/backends
216%{py3_sitedir}/cryptography/hazmat/backends/*.py
217%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
06232684
JB
218%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
219%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
220%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
221%dir %{py3_sitedir}/cryptography/hazmat/bindings
222%{py3_sitedir}/cryptography/hazmat/bindings/*.py
223%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
d198b5a4 224%attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
225%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
226%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
227%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
228%dir %{py3_sitedir}/cryptography/hazmat/primitives
229%{py3_sitedir}/cryptography/hazmat/primitives/*.py
230%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
231%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
232%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
233%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
234%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
235%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
236%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
237%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
238%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
239%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
f63b1331
JB
240%dir %{py3_sitedir}/cryptography/hazmat/primitives/serialization
241%{py3_sitedir}/cryptography/hazmat/primitives/serialization/*.py
242%{py3_sitedir}/cryptography/hazmat/primitives/serialization/__pycache__
f7d88309
AM
243%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
244%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
245%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
d198b5a4
AM
246%dir %{py3_sitedir}/cryptography/x509
247%{py3_sitedir}/cryptography/x509/*.py
248%{py3_sitedir}/cryptography/x509/__pycache__
06232684
JB
249%{py3_sitedir}/cryptography-%{version}-py*.egg-info
250%endif
f63b1331
JB
251
252%if %{with doc}
253%files apidocs
254%defattr(644,root,root,755)
255%doc docs/_build/html/{_downloads,_modules,_static,development,hazmat,x509,*.html,*.js}
256%endif
This page took 0.100488 seconds and 4 git commands to generate.