]> git.pld-linux.org Git - packages/python-keyczar.git/commitdiff
- updated to 0.716 auto/th/python-keyczar-0.716-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 20 Apr 2017 19:19:03 +0000 (21:19 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 20 Apr 2017 19:19:03 +0000 (21:19 +0200)
- added tests patch (disable broken test)

python-keyczar-tests.patch [new file with mode: 0644]
python-keyczar.spec

diff --git a/python-keyczar-tests.patch b/python-keyczar-tests.patch
new file mode 100644 (file)
index 0000000..79b8a14
--- /dev/null
@@ -0,0 +1,11 @@
+Disable failing test; included certificate doesn't seem to be valid X509.
+--- python/tests/keyczar_tests/util_test.py.orig       2016-05-05 05:54:29.000000000 +0200
++++ python/tests/keyczar_tests/util_test.py    2017-04-20 19:33:49.661631829 +0200
+@@ -177,7 +177,6 @@
+   alltests = unittest.TestSuite(
+     [unittest.TestLoader().loadTestsFromTestCase(Base64WSStreamingReadTest),
+      unittest.TestLoader().loadTestsFromTestCase(Base64WSStreamingWriteTest),
+-     unittest.TestLoader().loadTestsFromTestCase(ParseX509Test),
+     ])
+   return alltests
index 296f40cd01da3e632b0955973f2be4b8c67c1b64..c34b78b564a163df9ef9d2b4af09b96ac88b977b 100644 (file)
@@ -4,21 +4,29 @@
 
 %define        module  keyczar
 Summary:       Toolkit for safe and simple cryptography
+Summary(pl.UTF-8):     Zbiór narzędzi do bezpiecznej i prostej kryptografii
 Name:          python-%{module}
-Version:       0.71c
-Release:       3
+Version:       0.716
+Release:       1
 License:       Apache v2.0
-Group:         Development/Languages
-Source0:       http://keyczar.googlecode.com/files/%{name}-%{version}.tar.gz
-# Source0-md5: 57154b1e8ad3f59e2c8296d5d5a516eb
+Group:         Development/Languages/Python
+# github tarballs contain all bindings, regardless of tag kind...
+##Source0Download: https://github.com/google/keyczar/releases
+#Source0:      https://github.com/google/keyczar/archive/Python_release_%{version}.tar.gz
+# ...so use pypi tarball
+#Source0Download: https://pypi.python.org/simple/python-keyczar
+Source0:       https://files.pythonhosted.org/packages/source/p/python-keyczar/%{name}-%{version}.tar.gz
+# Source0-md5: 734334a6c5921e39003b68429eee77ae
+Patch0:                %{name}-tests.patch
 URL:           http://www.keyczar.org/
+BuildRequires: python-devel >= 1:2.5
+BuildRequires: python-setuptools
+%if %{with tests}
 BuildRequires: python-Crypto
-BuildRequires: python-devel
 BuildRequires: python-pyasn1
+%endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.710
-Requires:      python-Crypto
-Requires:      python-pyasn1
+BuildRequires: rpmbuild(macros) >= 1.714
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -28,20 +36,32 @@ easier and safer for developers to use cryptography in their
 applications. Keyczar supports authentication and encryption with both
 symmetric and asymmetric keys.
 
+%description -l pl.UTF-8
+Keyczar to mający otwarte źródła zbiór narzędzi kryptograficznych
+zaprojektowany tak, aby programiści mogli łatwiej i bezpieczniej
+wykorzystywać kryptografię w swoich aplikacjach. Keyczar obsługuje
+uwierzytelnianie oraz szyfrowanie z kluczami symetrycznymi oraz
+asymetrycznymi.
+
 %prep
 %setup -q
-rm -r python_keyczar.egg-info
+%patch0 -p1
+
+%{__rm} -r python_keyczar.egg-info
 
 %build
 %py_build
 
 %if %{with tests}
+srcdir=$(pwd)/src
+# scripts expect data in ../../testdata, so run them from this subdir
 cd tests/keyczar_tests
-PYTHONPATH=$PYTHONPATH:../../src/ ./alltests.py
+PYTHONPATH=${srcdir} %{__python} alltests.py
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %py_install
 
 %py_postclean
@@ -51,6 +71,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README LICENSE doc/pycrypt.pdf
+%doc ChangeLog README doc/pycrypt.pdf
+%attr(755,root,root) %{_bindir}/keyczart
 %{py_sitescriptdir}/keyczar
 %{py_sitescriptdir}/python_keyczar-*.egg-info
This page took 0.085481 seconds and 4 git commands to generate.