]> git.pld-linux.org Git - packages/python-keyczar.git/blob - python-keyczar.spec
296f40cd01da3e632b0955973f2be4b8c67c1b64
[packages/python-keyczar.git] / python-keyczar.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  keyczar
6 Summary:        Toolkit for safe and simple cryptography
7 Name:           python-%{module}
8 Version:        0.71c
9 Release:        3
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        http://keyczar.googlecode.com/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  57154b1e8ad3f59e2c8296d5d5a516eb
14 URL:            http://www.keyczar.org/
15 BuildRequires:  python-Crypto
16 BuildRequires:  python-devel
17 BuildRequires:  python-pyasn1
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 Requires:       python-Crypto
21 Requires:       python-pyasn1
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Keyczar is an open source cryptographic toolkit designed to make it
27 easier and safer for developers to use cryptography in their
28 applications. Keyczar supports authentication and encryption with both
29 symmetric and asymmetric keys.
30
31 %prep
32 %setup -q
33 rm -r python_keyczar.egg-info
34
35 %build
36 %py_build
37
38 %if %{with tests}
39 cd tests/keyczar_tests
40 PYTHONPATH=$PYTHONPATH:../../src/ ./alltests.py
41 %endif
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %py_install
46
47 %py_postclean
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README LICENSE doc/pycrypt.pdf
55 %{py_sitescriptdir}/keyczar
56 %{py_sitescriptdir}/python_keyczar-*.egg-info
This page took 0.042468 seconds and 2 git commands to generate.