]> git.pld-linux.org Git - packages/python-SOAP.git/commitdiff
- new URLs, updated to 0.12.22; still not python3 ready auto/th/python-SOAP-0.12.22-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 22 Mar 2020 17:46:00 +0000 (18:46 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 22 Mar 2020 17:46:00 +0000 (18:46 +0100)
- removed outdated future patch

python-SOAP-future.patch [deleted file]
python-SOAP-urltry.patch
python-SOAP.spec

diff --git a/python-SOAP-future.patch b/python-SOAP-future.patch
deleted file mode 100644 (file)
index 8386c38..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-diff -ur SOAPpy-0.12.0-orig/SOAPpy/Client.py SOAPpy-0.12.0/SOAPpy/Client.py
---- SOAPpy-0.12.0-orig/SOAPpy/Client.py        2005-02-21 21:27:09.000000000 +0100
-+++ SOAPpy-0.12.0/SOAPpy/Client.py     2006-11-07 10:36:40.388147000 +0100
-@@ -39,12 +39,11 @@
- #
- ################################################################################
- """
-+from __future__ import nested_scopes
- ident = '$Id: Client.py,v 1.27 2005/02/21 20:27:09 warnes Exp $'
- from version import __version__
--from __future__ import nested_scopes
--
- #import xml.sax
- import urllib
- from types import *
-diff -ur SOAPpy-0.12.0-orig/SOAPpy/Server.py SOAPpy-0.12.0/SOAPpy/Server.py
---- SOAPpy-0.12.0-orig/SOAPpy/Server.py        2005-02-15 17:32:22.000000000 +0100
-+++ SOAPpy-0.12.0/SOAPpy/Server.py     2006-11-07 10:36:55.441087750 +0100
-@@ -40,11 +40,11 @@
- ################################################################################
- """
-+from __future__ import nested_scopes
-+
- ident = '$Id: Server.py,v 1.21 2005/02/15 16:32:22 warnes Exp $'
- from version import __version__
--from __future__ import nested_scopes
--
- #import xml.sax
- import re
- import socket
-diff -ur SOAPpy-0.12.0-orig/SOAPpy/Types.py SOAPpy-0.12.0/SOAPpy/Types.py
---- SOAPpy-0.12.0-orig/SOAPpy/Types.py 2005-02-22 05:29:43.000000000 +0100
-+++ SOAPpy-0.12.0/SOAPpy/Types.py      2006-11-07 10:36:40.392147250 +0100
-@@ -33,11 +33,11 @@
- ################################################################################
- """
-+from __future__ import nested_scopes
-+
- ident = '$Id: Types.py,v 1.19 2005/02/22 04:29:43 warnes Exp $'
- from version import __version__
--from __future__ import nested_scopes
--
- import UserList
- import base64
- import cgi
index 68cc26367c5d51b7232ad42b024aacf835d7ddbe..f85d885fc5db5a87bae79bffe9dbd021ad6ff96a 100644 (file)
@@ -1,5 +1,5 @@
---- SOAPpy-0.11.6/SOAPpy/WSDL.py~      2004-01-31 04:20:06.000000000 +0000
-+++ SOAPpy-0.11.6/SOAPpy/WSDL.py       2004-11-09 11:17:48.927693480 +0000
+--- SOAPpy-0.12.22/src/SOAPpy/WSDL.py~ 2004-01-31 04:20:06.000000000 +0000
++++ SOAPpy-0.12.22/src/SOAPpy/WSDL.py  2004-11-09 11:17:48.927693480 +0000
 @@ -63,6 +63,11 @@
              except (IOError, OSError): pass
  
index 0f442a3b7e1d13519aaf8428d53be1feabbc3b4a..cd3c93485ca8f2245e0d145bafb7bbad69187cee 100644 (file)
@@ -1,22 +1,22 @@
+# TODO: how to run tests in %build?
 Summary:       A SOAP library for Python
 Summary(pl.UTF-8):     Biblioteka SOAP dla Pythona
 Name:          python-SOAP
-Version:       0.12.0
-Release:       7
-License:       Python
+Version:       0.12.22
+Release:       1
+License:       BSD
 Group:         Libraries/Python
-Source0:       http://downloads.sourceforge.net/pywebsvcs/SOAPpy-%{version}.tar.gz
-# Source0-md5: d0d29f9b6fb27bfadc69b64a36321e20
+#Source0Download: https://github.com/kiorky/SOAPpy/releases
+Source0:       https://github.com/kiorky/SOAPpy/archive/%{version}/SOAPpy-%{version}.tar.gz
+# Source0-md5: c93de2e7827bcbb6841a8a0ca1de5c59
 Patch0:                %{name}-urltry.patch
-Patch1:                %{name}-future.patch
-URL:           http://sourceforge.net/projects/pywebsvcs/
-BuildRequires: python-PyXML
+URL:           https://github.com/kiorky/SOAPpy
 BuildRequires: python-devel >= 1:2.3
-BuildRequires: python-fpconst
+BuildRequires: python-setuptools
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.710
-Requires:      python
-Requires:      python-fpconst
+BuildRequires: rpmbuild(macros) >= 1.714
+BuildRequires: sed >= 4.0
+Requires:      python-modules
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -31,29 +31,32 @@ SOAP, WSDL, UDDI itp.
 %prep
 %setup -q -n SOAPpy-%{version}
 %patch0 -p1
-%patch1 -p1
+rm -f src/SOAPpy/*.orig
 
 %build
 %py_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
 
 %py_install
 
-find $RPM_BUILD_ROOT%{py_sitescriptdir} -type f -name "*.py" -exec rm {} \;
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -pr bid contrib tests tools validate $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+%{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/*.py
+%{__sed} -i -e '1s,#!/usr/bin/python\s*$,#!%{__python},' $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/tests/testleak.py
+
+%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README docs/*.txt validate tests tools contrib bid
+%doc CHANGES.txt LICENSE README.txt TODO old.Changelog docs/*.txt
 %dir %{py_sitescriptdir}/SOAPpy
-%{py_sitescriptdir}/SOAPpy/*.py?
-%dir %{py_sitescriptdir}/SOAPpy/wstools
-%{py_sitescriptdir}/SOAPpy/wstools/*.py[co]
+%{py_sitescriptdir}/SOAPpy/*.py[co]
 %if "%{py_ver}" > "2.4"
 %{py_sitescriptdir}/SOAPpy-%{version}-py2.7.egg-info
 %endif
+%{_examplesdir}/%{name}-%{version}
This page took 0.129373 seconds and 4 git commands to generate.