]> git.pld-linux.org Git - packages/pure-ftpd.git/commitdiff
- up to 1.0.41; fix trigger; additionalgid option changed from -2 to -3 (to avoid... auto/th/pure-ftpd-1.0.41-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 2 Jul 2015 11:00:57 +0000 (13:00 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 2 Jul 2015 11:00:57 +0000 (13:00 +0200)
pure-ftpd-additionalgid.patch
pure-ftpd-mysql_config.patch
pure-ftpd.spec

index a2e52626fb15bb37d8e74944a1700493747ce807..0eff2c9980de52ba944f9809717543bc8ef71d75 100644 (file)
@@ -36,7 +36,7 @@ diff -ur pure-ftpd-1.0.21/src/ftpd.c pure-ftpd-1.0.21.new/src/ftpd.c
              no_truncate = 1;
              break;
          }
-+        case '2': {
++        case '3': {
 +            const char *nptr;
 +            char *endptr;
 +
@@ -46,7 +46,7 @@ diff -ur pure-ftpd-1.0.21/src/ftpd.c pure-ftpd-1.0.21.new/src/ftpd.c
 +            if (!nptr || !*nptr || !endptr || *endptr) {
 +                die(421, LOG_ERR, MSG_CONF_ERR ": " MSG_ILLEGAL_TRUSTED_GID " (XXX: additional): %s" , optarg);
 +            }
-+          want_additionalgid = 1;
++            want_additionalgid = 1;
 +            break;
 +        }
          case '4': {
@@ -60,18 +60,18 @@ diff -ur pure-ftpd-1.0.21/src/ftpd_p.h pure-ftpd-1.0.21.new/src/ftpd_p.h
  
  static const char *GETOPT_OPTIONS =
 -    "0146"
-+    "012:46"
++    "013:46"
  #ifdef WITH_RFC2640
      "8:9:"
  #endif
-@@ -112,6 +112,7 @@
- static struct option long_options[] = {
-     { "notruncate", 0, NULL, '0' },    
-     { "logpid", 0, NULL, '1' },
-+    { "additionalgid", 1, NULL, '2' },
+@@ -115,6 +115,7 @@ static struct option long_options[] = {
+ # ifdef WITH_TLS
+     { "certfile", 1, NULL, '2' },
+ # endif
++    { "additionalgid", 1, NULL, '3' },
      { "ipv4only", 0, NULL, '4' },
-     { "ipv6only", 0, NULL, '6' },    
- #ifdef WITH_RFC2640
+     { "ipv6only", 0, NULL, '6' },
+ # ifdef WITH_RFC2640
 diff -ur pure-ftpd-1.0.21/src/globals.h pure-ftpd-1.0.21.new/src/globals.h
 --- pure-ftpd-1.0.21/src/globals.h     2006-02-15 09:55:00.000000000 +0100
 +++ pure-ftpd-1.0.21.new/src/globals.h 2009-02-03 15:13:13.234021509 +0100
@@ -90,7 +90,7 @@ diff -ur pure-ftpd-1.0.21/src/globals.h pure-ftpd-1.0.21.new/src/globals.h
  my %numeric_switch_for = (
          MaxIdleTime             => "-I",
          MaxDiskUsage            => "-k",
-+        AdditionalGID           => "-2",
++        AdditionalGID           => "-3",
          TrustedGID              => "-a",
          MaxClientsNumber        => "-c",
          MaxClientsPerIP         => "-C",
index 95920fd91ad8d1d38555a95323801fd83078d5e0..caa361d9eb064190c8419da3ed905f09d6bc10bc 100644 (file)
@@ -4,7 +4,7 @@
  
  # Optional : define the location of mysql.sock if the server runs on this host.
  
--MYSQLSocket     /tmp/mysql.sock
+-MYSQLSocket     /var/run/mysqld/mysqld.sock
 +MYSQLSocket     /var/lib/mysql/mysql.sock
  
  
index 08202935ab3d491f2db51fc35cdf1d722a91859c..0b683ee88c6f743e386c9797c7f1118364990a59 100644 (file)
@@ -9,17 +9,17 @@
 %bcond_without tls             # disable SSL/TLS support
 %bcond_without cap             # disable capabilities
 
-%define        rel     2
+%define        rel     1
 Summary:       Small, fast and secure FTP server
 Summary(pl.UTF-8):     Mały, szybki i bezpieczny serwer FTP
 Name:          pure-ftpd
-Version:       1.0.40
+Version:       1.0.41
 Release:       %{rel}%{?with_extra:extra}
 Epoch:         0
 License:       BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
 Group:         Daemons
 Source0:       http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 33a503343a0f960332156387cc2dde55
+# Source0-md5: 76c2364591418f153ed815034621d058
 Source1:       %{name}.pamd
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
@@ -42,6 +42,7 @@ URL:          http://www.pureftpd.org/
 %{?with_extra:BuildRequires:   automake}
 %{?with_cap:BuildRequires:     libcap-devel}
 %{?with_extra:BuildRequires:   libcfg+-devel >= 0.6.2}
+BuildRequires: libsodium-devel
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 %{?with_tls:BuildRequires:     openssl-devel}
@@ -206,7 +207,7 @@ if [ "$1" = "0" ]; then
        %service -q ldap restart
 fi
 
-%triggerpostun -- %{name}-server < 1.0.40-1
+%triggerpostun -- pure-ftpd < 1.0.40-1
 %{?with_mysql:sed -i -e 's#MYSQLCrypt[\t ]\+all#MYSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
 %{?with_pgsql:sed -i -e 's#PgSQLCrypt[\t ]\+all#PgSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
 exit 0
This page took 0.204141 seconds and 4 git commands to generate.