]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- up to 1.0.41; fix trigger; additionalgid option changed from -2 to -3 (to avoid...
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11
12 %define rel     1
13 Summary:        Small, fast and secure FTP server
14 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
15 Name:           pure-ftpd
16 Version:        1.0.41
17 Release:        %{rel}%{?with_extra:extra}
18 Epoch:          0
19 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
20 Group:          Daemons
21 Source0:        http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
22 # Source0-md5:  76c2364591418f153ed815034621d058
23 Source1:        %{name}.pamd
24 Source2:        %{name}.init
25 Source3:        %{name}.sysconfig
26 Source4:        ftpusers.tar.bz2
27 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
28 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
29 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
30 Patch0:         %{name}-config.patch
31 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
32 Patch2:         %{name}-pure-pw_passwd.patch
33 Patch3:         %{name}-mysql_config.patch
34
35 Patch5:         %{name}-passwd_location.patch
36 Patch6:         %{name}-additionalgid.patch
37 Patch7:         audit_cap.patch
38 Patch8:         pure-ftpd-apparmor.patch
39 Patch9:         pure-ftpd-mysql-utf8.patch
40 URL:            http://www.pureftpd.org/
41 %{?with_extra:BuildRequires:    autoconf}
42 %{?with_extra:BuildRequires:    automake}
43 %{?with_cap:BuildRequires:      libcap-devel}
44 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
45 BuildRequires:  libsodium-devel
46 %{?with_mysql:BuildRequires:    mysql-devel}
47 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
48 %{?with_tls:BuildRequires:      openssl-devel}
49 BuildRequires:  libapparmor-devel
50 BuildRequires:  pam-devel
51 %{?with_pgsql:BuildRequires:    postgresql-devel}
52 BuildRequires:  rpmbuild(macros) >= 1.304
53 Requires(post,preun):   /sbin/chkconfig
54 Requires:       pam >= 0.79.0
55 %{!?with_extra:Requires:        perl-base}
56 Requires:       rc-scripts
57 Provides:       ftpserver
58 Conflicts:      man-pages < 1.51
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %define         _sysconfdir     /etc/ftpd
62 %define         _ftpdir         /home/services/ftp
63 %define         schemadir       /usr/share/openldap/schema
64
65 %description
66 Pure-FTPd is a fast, production-quality, standard-comformant FTP
67 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
68 has no known security flaw, it is really trivial to set up and it is
69 especially designed for modern Linux kernels (setfsuid, sendfile,
70 capabilities) . Features include PAM support, IPv6, chroot()ed home
71 directories, virtual domains, built-in LS, anti-warez system, bounded
72 ports for passive downloads...
73
74 %description -l pl.UTF-8
75 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
76 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
77 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
78 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
79 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
80 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
81 LS, system anty-warezowy, ograniczanie portów dla pasywnych
82 połączeń...
83
84 %package -n openldap-schema-pureftpd
85 Summary:        Pure-FTPd LDAP schema
86 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
87 Group:          Networking/Daemons
88 Requires(post,postun):  sed >= 4.0
89 Requires:       openldap-servers
90 Requires:       sed >= 4.0
91 %if "%{_rpmversion}" >= "5"
92 BuildArch:      noarch
93 %endif
94
95 %description -n openldap-schema-pureftpd
96 This package contains an Pure-FTPd openldap schema.
97
98 %description -n openldap-schema-pureftpd -l pl.UTF-8
99 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
100
101 %prep
102 %setup -q -a 5
103 %patch0 -p0
104 %patch3 -p1
105
106 %patch5 -p1
107 %patch6 -p1
108 %patch7 -p1
109 %patch8 -p1
110 %patch9 -p1
111
112 %{?with_extra:%patch1 -p1}
113 %{?with_extra:%patch2 -p1}
114
115 %build
116 %{__aclocal} -Im4
117 %{__autoconf}
118 %{__autoheader}
119 %configure \
120         CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
121         --with-boring \
122         --with-altlog \
123         --with-cookie \
124         --with-diraliases \
125         --with-extauth \
126         --with-ftpwho \
127         --with-language=english \
128         %{!?with_cap:--without-capabilities} \
129         %{?with_ldap:--with-ldap} \
130         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
131         --with-pam \
132         --with-peruserlimits \
133         --with-rfc2640 \
134         %{?with_pgsql:--with-pgsql} \
135         --with-privsep \
136         %{?with_puredb:--with-puredb} \
137         --with-quotas \
138         --with-ratios \
139         --with-throttling \
140         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
141         --with-uploadscript \
142         --with-virtualchroot \
143         --with-virtualhosts \
144         --with-apparmor
145
146 %if %{with extra}
147 cd pure-config
148 %{__aclocal}
149 %{__autoconf}
150 %{__autoheader}
151 %{__automake}
152 %configure
153 %{__make}
154 %endif
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
159         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
165 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
166 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
167
168 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
169 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
170 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
171 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
172 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
173 install pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
174
175 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
176
177 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
178
179 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
180 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
181
182 %if %{with extra}
183 %{__make} -C pure-config install \
184         DESTDIR=$RPM_BUILD_ROOT
185 %endif
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %post
191 /sbin/chkconfig --add %{name}
192 %service %{name} restart "PureFTPD daemon"
193
194 %preun
195 if [ "$1" = "0" ]; then
196         %service %{name} stop
197         /sbin/chkconfig --del %{name}
198 fi
199
200 %post -n openldap-schema-pureftpd
201 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
202 %service -q ldap restart
203
204 %postun -n openldap-schema-pureftpd
205 if [ "$1" = "0" ]; then
206         %openldap_schema_unregister %{schemadir}/pureftpd.schema
207         %service -q ldap restart
208 fi
209
210 %triggerpostun -- pure-ftpd < 1.0.40-1
211 %{?with_mysql:sed -i -e 's#MYSQLCrypt[\t ]\+all#MYSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
212 %{?with_pgsql:sed -i -e 's#PgSQLCrypt[\t ]\+all#PgSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
213 exit 0
214
215 %files
216 %defattr(644,root,root,755)
217 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
218 %attr(755,root,root) %{_bindir}/*
219 %attr(755,root,root) %{_sbindir}/*
220 %attr(754,root,root) /etc/rc.d/init.d/%{name}
221 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
222 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
223 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
224 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
225 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
226 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
227 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
228 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
229 %attr(710,root,ftp) %dir %{_sysconfdir}
230 %dir %{_sysconfdir}/vhosts
231 %dir %{_sysconfdir}/pure-ftpd
232 %dir %{_ftpdir}
233 %{_mandir}/man?/*
234 %lang(ja) %{_mandir}/ja/man5/ftpusers*
235 %lang(pl) %{_mandir}/pl/man5/ftpusers*
236 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
237 %lang(ru) %{_mandir}/ru/man5/ftpusers*
238
239 %files -n openldap-schema-pureftpd
240 %defattr(644,root,root,755)
241 %{schemadir}/pureftpd.schema
This page took 0.06312 seconds and 3 git commands to generate.