]> git.pld-linux.org Git - packages/povray.git/blame - povray.spec
- fix building on x32
[packages/povray.git] / povray.spec
CommitLineData
8f6042bf 1#
bc24fd67 2# Conditional build:
9efdfbd6 3%bcond_without x # - without X11 subpackage
be0816cf 4%bcond_with pvm # - with PVM support
9efdfbd6 5%bcond_with svga # - with svgalib support (doesn't work on many platforms)
8f6042bf 6#
f65cefa1 7%define rel 2
4d0bdcea 8%define beta beta.5
520c1407 9Summary: Persistence of Vision Ray Tracer
5c6661ca 10Summary(pl.UTF-8): Persistence of Vision Ray Tracer
520c1407 11Name: povray
4d0bdcea 12Version: 3.7.1
f65cefa1 13Release: 0.%{beta}.%{rel}
e107cc8d 14Epoch: 1
4d0bdcea 15License: AGPLv3+
520c1407 16Group: Applications/Graphics
4d0bdcea
JR
17Source0: https://github.com/POV-Ray/povray/archive/v%{version}-%{beta}/%{name}-%{version}-%{beta}.tar.gz
18# Source0-md5: eeff460742acdaa84ebbc7e7e5135981
f65cefa1 19Patch0: x32.patch
520c1407 20URL: http://www.povray.org/
ec73f680
JB
21BuildRequires: autoconf
22BuildRequires: automake
f65cefa1 23BuildRequires: boost-devel
b7a98b2e 24BuildRequires: libjpeg-devel
f5608087 25BuildRequires: libpng-devel >= 1.4.0
b7a98b2e 26BuildRequires: libstdc++-devel
27BuildRequires: libtiff-devel
4094ca7d
JK
28%{?with_pvm:BuildRequires: pvm-devel >= 3.4.3-24}
29%{?with_svga:BuildRequires: svgalib-devel}
73c51aff 30%{?with_x:BuildRequires: xorg-lib-libX11-devel}
ec73f680 31BuildRequires: zlib-devel
9416b15a 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
4d562464 33
d436f42a 34%if %{with pvm}
697b1b4f 35%define _pvmarch %(/usr/bin/pvmgetarch)
09c1e7ed 36%define _pvmroot /usr/%{_lib}/pvm3
d436f42a 37%endif
a37cc0c6 38
4d562464 39%description
4d562464 40The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
2702972f 41photo-realistic images using a rendering technique called ray-tracing.
42It reads in a text file containing information describing the objects
43and lighting in a scene and generates an image of that scene from the
44view point of a camera also described in the text file. Ray-tracing is
45not a fast process by any means, but it produces very high quality
46images with realistic reflections, shading, perspective and other
47effects.
4d562464 48
2ea14a87
JR
49%description -l pl.UTF-8
50Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
51fotorealistyczne obrazy za pomocą techniki renderingu zwanej
52ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
53obiekty oraz światło przedstawianego świata, a następnie generuje
54rysunek z punktu widzenia kamery, która także jest definiowana w w/w
55pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
56ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
57efektami, tj. odbicia światła, cienie, perspektywa i inne.
4d562464 58
fceafdc6 59%package X11
41b49d87 60Summary: X Window povray executable
5c6661ca 61Summary(pl.UTF-8): povray pod X Window
fceafdc6 62Group: Applications/Graphics
38f80171 63Requires: %{name} = %{epoch}:%{version}-%{release}
41b49d87 64
65%description X11
66The Persistence of Vision(tm) Ray-Tracer X Window executable.
caec2118 67
2ea14a87 68%description X11 -l pl.UTF-8
8ecf04d1 69Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
70Window.
a37cc0c6 71
a37cc0c6 72%package pvm
3af417fe 73Summary: PVM/Unix povray executable
74Summary(pl.UTF-8): Plik wykonywalny povray dla PVM/Unix
a37cc0c6 75Group: Applications/Graphics
38f80171 76Requires: %{name} = %{epoch}:%{version}-%{release}
a37cc0c6
AF
77
78%description pvm
3af417fe 79The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
a37cc0c6 80
2ea14a87 81%description pvm -l pl.UTF-8
8ecf04d1 82Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
3af417fe 83PVM/Unix.
caec2118 84
a37cc0c6
AF
85%package pvm-X11
86Summary: PVM/xwin povray executable
5c6661ca 87Summary(pl.UTF-8): Plik wykonywalny povray dla PVM/xwin
a37cc0c6 88Group: Applications/Graphics
38f80171 89Requires: %{name} = %{epoch}:%{version}-%{release}
a37cc0c6
AF
90
91%description pvm-X11
92The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
caec2118 93
2ea14a87 94%description pvm-X11 -l pl.UTF-8
8ecf04d1 95Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
96PVM/xwin.
fceafdc6 97
4d562464 98%prep
4d0bdcea 99%setup -q -n %{name}-%{version}-%{beta}
f65cefa1
JR
100%ifarch x32
101%patch0 -p1
102%endif
4d562464 103
104%build
8b2043c3
JR
105cd unix
106./prebuild.sh
107cd ..
108
ea227ab9 109COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
09c1e7ed 110%if %{with x} && %{with pvm}
697b1b4f 111%configure \
09c1e7ed 112 --libdir=%{_datadir} \
697b1b4f
AF
113 --enable-pvm \
114 --with-pvm-arch=%{_pvmarch} \
e4be19f9 115 --with-pvm-libs=%{_libdir}
697b1b4f 116%{__make}
21729b33 117install unix/povray x-pvmpov
697b1b4f
AF
118%endif
119
09c1e7ed 120%if %{with pvm}
697b1b4f
AF
121%{__make} clean
122
123%configure \
09c1e7ed 124 --libdir=%{_datadir} \
697b1b4f
AF
125 --enable-pvm \
126 --with-pvm-arch=%{_pvmarch} \
09c1e7ed 127 --with-pvm-libs=%{_libdir} \
697b1b4f
AF
128 --without-x
129%{__make}
21729b33 130install unix/povray pvmpov
697b1b4f
AF
131%endif
132
09c1e7ed 133%if %{with x}
b7a98b2e 134%configure \
68a9cdbb 135 --libdir=%{_datadir}
b7a98b2e 136%{__make}
21729b33 137install unix/povray x-povray
b7a98b2e 138%{__make} clean
2c916a3a 139%endif
b7a98b2e 140
141%configure \
09c1e7ed 142 --libdir=%{_datadir} \
b7a98b2e 143 --without-x
144%{__make}
4d562464 145
146%install
61158218 147rm -rf $RPM_BUILD_ROOT
e4be19f9 148install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
ea227ab9
AM
149%if %{with pvm}
150install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
151%endif
61158218 152
e4be19f9
JR
153%{__make} install \
154 INSTALL="install -c -D" \
155 mkdir_p="mkdir -p" \
b7a98b2e 156 DESTDIR=$RPM_BUILD_ROOT
4d562464 157
09c1e7ed 158%if %{with x}
a5a450ff 159install x-povray $RPM_BUILD_ROOT%{_bindir}
2c916a3a 160%endif
161
09c1e7ed 162%if %{with x} && %{with pvm}
a5a450ff 163install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
09c1e7ed 164ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
697b1b4f
AF
165%endif
166
09c1e7ed 167%if %{with pvm}
a5a450ff 168install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
09c1e7ed 169ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
697b1b4f
AF
170%endif
171
21729b33 172##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
173##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
fceafdc6 174
4d562464 175%clean
176rm -rf $RPM_BUILD_ROOT
177
178%files
49c88a8f 179%defattr(644,root,root,755)
be0816cf 180%doc AUTHORS ChangeLog NEWS README* changes.txt
fceafdc6 181%attr(755,root,root) %{_bindir}/povray
09c1e7ed 182%{_datadir}/povray*
21729b33 183%{_docdir}/povray*
b7a98b2e 184%{_mandir}/man?/*
e11b17d4 185%dir %{_sysconfdir}/povray
be0816cf
AG
186%dir %{_sysconfdir}/povray/3.7
187%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
21729b33 188## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
fceafdc6 189
09c1e7ed 190%if %{with x}
96df36ec 191%files X11
2702972f 192%defattr(644,root,root,755)
a5a450ff 193%attr(755,root,root) %{_bindir}/x-povray
a37cc0c6
AF
194%endif
195
8f6042bf 196%if %{with pvm}
697b1b4f
AF
197%files pvm
198%defattr(644,root,root,755)
199%attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
a5a450ff 200%attr(755,root,root) %{_bindir}/pvmpov
697b1b4f
AF
201%endif
202
09c1e7ed 203%if %{with pvm} && %{with x}
697b1b4f
AF
204%files pvm-X11
205%defattr(644,root,root,755)
206%attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
a5a450ff 207%attr(755,root,root) %{_bindir}/x-pvmpov
697b1b4f 208%endif
This page took 0.199939 seconds and 4 git commands to generate.