]> git.pld-linux.org Git - packages/php.git/commitdiff
use alternatives for phar links
authorElan Ruusamäe <glen@delfi.ee>
Sun, 31 Jan 2016 13:15:14 +0000 (15:15 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 31 Jan 2016 18:04:41 +0000 (20:04 +0200)
php.spec

index 6dac16672d43043076a512393dda2d399e20a720..6ef8f825a87a3f7e3c9d3c781db4689525619816 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1409,6 +1409,7 @@ Group:            Libraries
 URL:           http://www.php.net/manual/en/book.phar.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
+Requires:      alternatives
 Suggests:      %{name}-cli
 # zlib is required by phar program, but as phar cli is optional should the dep be too
 Suggests:      %{name}-zlib
@@ -2419,9 +2420,10 @@ cp -pf Makefile.cli Makefile
 # version the .phar files
 mv $RPM_BUILD_ROOT%{_bindir}/phar{,%{ver_suffix}}.phar
 mv $RPM_BUILD_ROOT%{_mandir}/man1/phar{,%{ver_suffix}}.1
-# make link relative
-ln -sfn phar%{ver_suffix}.phar $RPM_BUILD_ROOT%{_bindir}/phar
-ln -sfn phar%{ver_suffix}.1 $RPM_BUILD_ROOT%{_mandir}/man1/phar.1
+# touch for ghost
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/phar
+touch $RPM_BUILD_ROOT%{_bindir}/phar
+touch $RPM_BUILD_ROOT%{_mandir}/man1/phar.1
 
 # version suffix
 v=$(echo %{version} | cut -d. -f1-2)
@@ -2639,16 +2641,24 @@ sed -i -e 's#modules/libphp5.so#modules/mod_php.so#g' /etc/apache/conf.d/*_mod_p
 sed -i -e 's#modules/libphp[57].so#modules/mod_php.so#g' /etc/httpd/conf.d/*_mod_php.conf
 
 # common macros called at extension post/postun scriptlet
-%define        extension_scripts() \
-%post %1 \
+%define ext_post \
 if [ "$1" = "1" ]; then \
        %php_webserver_restart \
 fi \
-\
-%postun %1 \
+%{nil}
+
+%define ext_postun \
 if [ "$1" = "0" ]; then \
        %php_webserver_restart \
-fi
+fi \
+%{nil}
+
+%define extension_scripts() \
+%post %1 \
+%ext_post \
+\
+%postun %1 \
+%ext_postun
 %{nil}
 
 # extension scripts defines
@@ -2693,7 +2703,6 @@ fi
 %extension_scripts pdo-pgsql
 %extension_scripts pdo-sqlite
 %extension_scripts pgsql
-%extension_scripts phar
 %extension_scripts pcntl
 %extension_scripts posix
 %extension_scripts pspell
@@ -2721,6 +2730,18 @@ fi
 %extension_scripts zip
 %extension_scripts zlib
 
+%post phar
+%ext_post
+update-alternatives \
+       --install %{_bindir}/phar phar %{_bindir}/phar%{ver_suffix}.phar %{ver_suffix} \
+       --slave %{_mandir}/man1/phar.1 phar.1 %{_mandir}/man1/phar%{ver_suffix}.1* || :
+
+%postun phar
+%ext_postun
+if [ $1 -eq 0 ]; then
+       update-alternatives --remove phar %{_bindir}/phar || :
+fi
+
 %if %{with apache1}
 %files -n apache1-mod_%{name}
 %defattr(644,root,root,755)
@@ -3113,11 +3134,11 @@ fi
 %doc ext/phar/{CREDITS,TODO}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/phar.ini
 %attr(755,root,root) %{php_extensiondir}/phar.so
-%attr(755,root,root) %{_bindir}/phar
 %attr(755,root,root) %{_bindir}/phar%{ver_suffix}.phar
-%{_mandir}/man1/phar.1
 %{_mandir}/man1/phar.phar.1
 %{_mandir}/man1/phar%{ver_suffix}.1*
+%ghost %{_bindir}/phar
+%ghost %{_mandir}/man1/phar.1
 %endif
 
 %files posix
This page took 0.055175 seconds and 4 git commands to generate.