]> git.pld-linux.org Git - packages/php.git/commitdiff
fix phar manual packaging
authorElan Ruusamäe <glen@delfi.ee>
Sun, 31 Jan 2016 13:05:46 +0000 (15:05 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 31 Jan 2016 13:07:20 +0000 (15:07 +0200)
phar.1 and phar.phar.1 are links
pharXY.1 is the real man page

php.spec

index 34673e352fb25cc65a28e4ec806ff5c76d1f028f..6dac16672d43043076a512393dda2d399e20a720 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2418,9 +2418,10 @@ cp -pf Makefile.cli Makefile
 
 # version the .phar files
 mv $RPM_BUILD_ROOT%{_bindir}/phar{,%{ver_suffix}}.phar
-mv $RPM_BUILD_ROOT%{_mandir}/man1/phar{,%{ver_suffix}}.phar.1
+mv $RPM_BUILD_ROOT%{_mandir}/man1/phar{,%{ver_suffix}}.1
 # make link relative
 ln -sfn phar%{ver_suffix}.phar $RPM_BUILD_ROOT%{_bindir}/phar
+ln -sfn phar%{ver_suffix}.1 $RPM_BUILD_ROOT%{_mandir}/man1/phar.1
 
 # version suffix
 v=$(echo %{version} | cut -d. -f1-2)
@@ -3114,8 +3115,9 @@ fi
 %attr(755,root,root) %{php_extensiondir}/phar.so
 %attr(755,root,root) %{_bindir}/phar
 %attr(755,root,root) %{_bindir}/phar%{ver_suffix}.phar
-%{_mandir}/man1/phar.1*
-%{_mandir}/man1/phar%{ver_suffix}.phar.1
+%{_mandir}/man1/phar.1
+%{_mandir}/man1/phar.phar.1
+%{_mandir}/man1/phar%{ver_suffix}.1*
 %endif
 
 %files posix
This page took 0.046921 seconds and 4 git commands to generate.