]> git.pld-linux.org Git - packages/php.git/commitdiff
- fix building with icu 69
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 27 Aug 2021 20:55:39 +0000 (22:55 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 27 Aug 2021 20:55:39 +0000 (22:55 +0200)
icu69.patch [new file with mode: 0644]
php.spec

diff --git a/icu69.patch b/icu69.patch
new file mode 100644 (file)
index 0000000..a837605
--- /dev/null
@@ -0,0 +1,84 @@
+--- php-7.2.34/ext/intl/collator/collator_sort.c~      2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/collator/collator_sort.c       2021-08-27 22:44:44.636032116 +0200
+@@ -30,6 +30,11 @@
+ typedef zend_long ptrdiff_t;
+ #endif
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ /**
+  * Declare 'index' which will point to sort key in sort key
+  * buffer.
+--- php-7.2.34/ext/intl/normalizer/normalizer_normalize.c~     2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/normalizer/normalizer_normalize.c      2021-08-27 22:50:28.139941746 +0200
+@@ -25,6 +25,11 @@
+ #include "normalizer_normalize.h"
+ #include "intl_convert.h"
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ /* {{{ proto string Normalizer::normalize( string $input [, string $form = FORM_C] )
+  * Normalize a string. }}} */
+ /* {{{ proto string normalizer_normalize( string $input [, string $form = FORM_C] )
+--- php-7.2.34/ext/intl/dateformat/dateformat_attr.c~  2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/dateformat/dateformat_attr.c   2021-08-27 22:52:05.242621694 +0200
+@@ -26,6 +26,11 @@
+ #include <unicode/ustring.h>
+ #include <unicode/udat.h>
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ /* {{{ proto unicode IntlDateFormatter::getDateType( )
+  * Get formatter datetype. }}} */
+ /* {{{ proto string datefmt_get_datetype( IntlDateFormatter $mf )
+--- php-7.2.34/ext/intl/timezone/timezone_class.cpp~   2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/timezone/timezone_class.cpp    2021-08-27 22:52:48.582342940 +0200
+@@ -37,6 +37,11 @@
+ #include <ext/date/php_date.h>
+ }
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ /* {{{ Global variables */
+ U_CDECL_BEGIN
+ zend_class_entry *TimeZone_ce_ptr = NULL;
+--- php-7.2.34/ext/intl/timezone/timezone_methods.cpp~ 2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/timezone/timezone_methods.cpp  2021-08-27 22:53:23.048792982 +0200
+@@ -37,6 +37,11 @@
+ }
+ #include "common/common_enum.h"
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ U_CFUNC PHP_METHOD(IntlTimeZone, __construct)
+ {
+       zend_throw_exception( NULL,
+--- php-7.2.34/ext/intl/breakiterator/codepointiterator_internal.cpp~  2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/intl/breakiterator/codepointiterator_internal.cpp   2021-08-27 22:54:10.761833238 +0200
+@@ -20,6 +20,11 @@
+ #include "php.h"
++#if !defined(FALSE)
++#define FALSE 0
++#define TRUE 1
++#endif
++
+ //copied from cmemory.h, which is not public
+ typedef union {
+     zend_long    t1;
index 19f3ab78d2c3a535a8df8b34b88e800a15c8c8c1..90f08e70793ac413da8ea8f158534f50cbc7d6aa 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -220,6 +220,7 @@ Patch68:    php-mysql-ssl-context.patch
 Patch70:       mysqlnd-ssl.patch
 Patch71:       libdb-info.patch
 Patch72:       phar-hash-shared.patch
+Patch73:       icu69.patch
 URL:           http://php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -2038,6 +2039,7 @@ cp -p php.ini-production php.ini
 %patch70 -p1
 %patch71 -p1
 %patch72 -p1 -b .phar-shared
+%patch73 -p1
 
 sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
       run-tests.php
This page took 0.065822 seconds and 4 git commands to generate.