]> git.pld-linux.org Git - packages/php.git/commitdiff
- rediffed remaining patches
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 27 Aug 2021 20:41:57 +0000 (22:41 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 27 Aug 2021 20:41:57 +0000 (22:41 +0200)
bug-52078-fileinode.patch
fix-test-run.patch
libdb-info.patch
mysql-lib-ver-mismatch.patch
pcre-shared.patch

index 419be68ad1481ec5b560928a3e5e8e171a3bead6..f16529238a72d31e04f194c056c9382e9bd6fb16 100644 (file)
@@ -1,6 +1,18 @@
---- php-5.3.3/ext/standard/tests/file/fileinode_basic.phpt~    2007-11-05 19:43:21.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/fileinode_basic.phpt     2010-07-26 19:31:43.613553760 +0300
-@@ -28,9 +28,9 @@
+diff -urNp -x '*.orig' php-7.2.34.org/ext/spl/tests/SplFileInfo_getInode_basic.phpt php-7.2.34/ext/spl/tests/SplFileInfo_getInode_basic.phpt
+--- php-7.2.34.org/ext/spl/tests/SplFileInfo_getInode_basic.phpt       2021-08-27 22:34:19.251518695 +0200
++++ php-7.2.34/ext/spl/tests/SplFileInfo_getInode_basic.phpt   2021-08-27 22:34:20.224831419 +0200
+@@ -11,6 +11,7 @@ Jacopo Romei <jacopo@sviluppoagile.it>
+ --SKIPIF--
+ <?php
+ if (substr(PHP_OS, 0, 3) == 'WIN') die("skip this test not for Windows platforms");
++if (PHP_INT_SIZE == 4) die("skip this test is for >32bit platform only (inodes overflow there)");
+ ?>
+ --FILE--
+ <?php
+diff -urNp -x '*.orig' php-7.2.34.org/ext/standard/tests/file/fileinode_basic.phpt php-7.2.34/ext/standard/tests/file/fileinode_basic.phpt
+--- php-7.2.34.org/ext/standard/tests/file/fileinode_basic.phpt        2020-09-30 07:15:51.000000000 +0200
++++ php-7.2.34/ext/standard/tests/file/fileinode_basic.phpt    2021-08-27 22:34:20.221498156 +0200
+@@ -28,9 +28,9 @@ unlink (dirname(__FILE__)."/inode.tmp");
  ?>
  --EXPECTF--
  *** Testing fileinode() with file, directory ***
 +%i
  
  *** Done ***
---- php-5.3.3/ext/standard/tests/file/fileinode_variation.phpt~        2007-11-05 19:43:21.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/fileinode_variation.phpt 2010-07-26 19:34:01.610414378 +0300
-@@ -89,24 +89,24 @@
+diff -urNp -x '*.orig' php-7.2.34.org/ext/standard/tests/file/fileinode_variation.phpt php-7.2.34/ext/standard/tests/file/fileinode_variation.phpt
+--- php-7.2.34.org/ext/standard/tests/file/fileinode_variation.phpt    2020-09-30 07:15:51.000000000 +0200
++++ php-7.2.34/ext/standard/tests/file/fileinode_variation.phpt        2021-08-27 22:34:20.221498156 +0200
+@@ -88,24 +88,24 @@ echo "\n*** Done ***";
  --EXPECTF--
  *** Testing fileinode() with files, links and directories ***
  -- Testing with files --
 +%i
 +%i
  *** Done ***
---- php-5.3.3/ext/standard/tests/file/fileinode_variation1.phpt~       2008-11-26 12:10:19.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/fileinode_variation1.phpt        2010-07-26 19:35:31.216291870 +0300
-@@ -42,7 +42,7 @@
+diff -urNp -x '*.orig' php-7.2.34.org/ext/standard/tests/file/fileinode_variation1.phpt php-7.2.34/ext/standard/tests/file/fileinode_variation1.phpt
+--- php-7.2.34.org/ext/standard/tests/file/fileinode_variation1.phpt   2020-09-30 07:15:51.000000000 +0200
++++ php-7.2.34/ext/standard/tests/file/fileinode_variation1.phpt       2021-08-27 22:34:20.221498156 +0200
+@@ -41,7 +41,7 @@ unlink($file_path."/fileinode_variation1
+ ?>
  --EXPECTF--
  *** Testing fileinode() with links ***
 -int(%d)
 +int(%i)
  
  *** Done ***
---- php-5.3.3/ext/standard/tests/file/filestat.phpt~   2006-11-15 19:27:03.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/filestat.phpt    2010-07-26 19:37:10.367060798 +0300
-@@ -30,17 +30,17 @@
+diff -urNp -x '*.orig' php-7.2.34.org/ext/standard/tests/file/filestat.phpt php-7.2.34/ext/standard/tests/file/filestat.phpt
+--- php-7.2.34.org/ext/standard/tests/file/filestat.phpt       2020-09-30 07:15:51.000000000 +0200
++++ php-7.2.34/ext/standard/tests/file/filestat.phpt   2021-08-27 22:34:20.221498156 +0200
+@@ -30,17 +30,17 @@ var_dump(filectime("/no/such/file/or/dir
  echo "Done\n";
  ?>
  --EXPECTF--
  int(%d)
  int(%d)
  int(%d)
---- php-5.3.3/ext/standard/tests/file/lstat_stat_variation18.phpt~     2010-07-26 19:43:12.000000000 +0300
-+++ php-5.3.3/ext/standard/tests/file/lstat_stat_variation18.phpt      2010-07-26 19:43:14.470984630 +0300
-@@ -66,7 +66,7 @@
+diff -urNp -x '*.orig' php-7.2.34.org/ext/standard/tests/file/lstat_stat_variation18.phpt php-7.2.34/ext/standard/tests/file/lstat_stat_variation18.phpt
+--- php-7.2.34.org/ext/standard/tests/file/lstat_stat_variation18.phpt 2020-09-30 07:15:51.000000000 +0200
++++ php-7.2.34/ext/standard/tests/file/lstat_stat_variation18.phpt     2021-08-27 22:34:20.221498156 +0200
+@@ -65,7 +65,7 @@ array(26) {
    [0]=>
    int(%d)
    [1]=>
    [2]=>
    int(%d)
    [3]=>
-@@ -92,7 +92,7 @@
+@@ -91,7 +91,7 @@ array(26) {
    ["dev"]=>
    int(%d)
    ["ino"]=>
    ["mode"]=>
    int(%d)
    ["nlink"]=>
-@@ -122,7 +122,7 @@
+@@ -121,7 +121,7 @@ array(26) {
    [0]=>
    int(%d)
    [1]=>
    [2]=>
    int(%d)
    [3]=>
-@@ -148,7 +148,7 @@
+@@ -147,7 +147,7 @@ array(26) {
    ["dev"]=>
    int(%d)
    ["ino"]=>
    ["mode"]=>
    int(%d)
    ["nlink"]=>
---- php-5.3.3/ext/standard/tests/file/lstat_stat_variation19.phpt~     2007-11-05 19:43:21.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/lstat_stat_variation19.phpt      2010-07-26 19:44:58.320079730 +0300
-@@ -67,7 +67,7 @@
+diff -urNp -x '*.orig' php-7.2.34.org/ext/standard/tests/file/lstat_stat_variation19.phpt php-7.2.34/ext/standard/tests/file/lstat_stat_variation19.phpt
+--- php-7.2.34.org/ext/standard/tests/file/lstat_stat_variation19.phpt 2020-09-30 07:15:51.000000000 +0200
++++ php-7.2.34/ext/standard/tests/file/lstat_stat_variation19.phpt     2021-08-27 22:34:20.221498156 +0200
+@@ -66,7 +66,7 @@ array(26) {
    [0]=>
    int(%d)
    [1]=>
    [2]=>
    int(%d)
    [3]=>
-@@ -93,7 +93,7 @@
+@@ -92,7 +92,7 @@ array(26) {
    ["dev"]=>
    int(%d)
    ["ino"]=>
    ["mode"]=>
    int(%d)
    ["nlink"]=>
-@@ -121,7 +121,7 @@
+@@ -120,7 +120,7 @@ array(26) {
    [0]=>
    int(%d)
    [1]=>
    [2]=>
    int(%d)
    [3]=>
-@@ -147,7 +147,7 @@
+@@ -146,7 +146,7 @@ array(26) {
    ["dev"]=>
    int(%d)
    ["ino"]=>
    ["mode"]=>
    int(%d)
    ["nlink"]=>
-@@ -177,7 +177,7 @@
+@@ -176,7 +176,7 @@ array(26) {
    [0]=>
    int(%d)
    [1]=>
    [2]=>
    int(%d)
    [3]=>
-@@ -203,7 +203,7 @@
+@@ -202,7 +202,7 @@ array(26) {
    ["dev"]=>
    int(%d)
    ["ino"]=>
    ["mode"]=>
    int(%d)
    ["nlink"]=>
-@@ -231,7 +231,7 @@
+@@ -230,7 +230,7 @@ array(26) {
    [0]=>
    int(%d)
    [1]=>
    [2]=>
    int(%d)
    [3]=>
-@@ -257,7 +257,7 @@
+@@ -256,7 +256,7 @@ array(26) {
    ["dev"]=>
    int(%d)
    ["ino"]=>
    ["mode"]=>
    int(%d)
    ["nlink"]=>
---- php-5.3.3/ext/standard/tests/file/lstat_stat_variation20.phpt~     2007-07-26 16:38:24.000000000 +0300
-+++ php-5.3.3/ext/standard/tests/file/lstat_stat_variation20.phpt      2010-07-26 19:46:33.907004377 +0300
-@@ -69,7 +69,7 @@
+diff -urNp -x '*.orig' php-7.2.34.org/ext/standard/tests/file/lstat_stat_variation20.phpt php-7.2.34/ext/standard/tests/file/lstat_stat_variation20.phpt
+--- php-7.2.34.org/ext/standard/tests/file/lstat_stat_variation20.phpt 2020-09-30 07:15:51.000000000 +0200
++++ php-7.2.34/ext/standard/tests/file/lstat_stat_variation20.phpt     2021-08-27 22:34:20.221498156 +0200
+@@ -68,7 +68,7 @@ array(26) {
    [0]=>
    int(%d)
    [1]=>
    [2]=>
    int(%d)
    [3]=>
-@@ -95,7 +95,7 @@
+@@ -94,7 +94,7 @@ array(26) {
    ["dev"]=>
    int(%d)
    ["ino"]=>
    ["mode"]=>
    int(%d)
    ["nlink"]=>
-@@ -125,7 +125,7 @@
+@@ -124,7 +124,7 @@ array(26) {
    [0]=>
    int(%d)
    [1]=>
    [2]=>
    int(%d)
    [3]=>
-@@ -151,7 +151,7 @@
+@@ -150,7 +150,7 @@ array(26) {
    ["dev"]=>
    int(%d)
    ["ino"]=>
    ["mode"]=>
    int(%d)
    ["nlink"]=>
-@@ -179,7 +179,7 @@
+@@ -178,7 +178,7 @@ array(26) {
    [0]=>
    int(%d)
    [1]=>
    [2]=>
    int(%d)
    [3]=>
-@@ -205,7 +205,7 @@
+@@ -204,7 +204,7 @@ array(26) {
    ["dev"]=>
    int(%d)
    ["ino"]=>
    ["mode"]=>
    int(%d)
    ["nlink"]=>
-@@ -233,7 +233,7 @@
+@@ -232,7 +232,7 @@ array(26) {
    [0]=>
    int(%d)
    [1]=>
    [2]=>
    int(%d)
    [3]=>
-@@ -259,7 +259,7 @@
+@@ -258,7 +258,7 @@ array(26) {
    ["dev"]=>
    int(%d)
    ["ino"]=>
    ["mode"]=>
    int(%d)
    ["nlink"]=>
---- php-5.3.3/ext/standard/tests/file/tempnam_variation1.phpt~ 2008-11-26 12:10:19.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/tempnam_variation1.phpt  2010-07-26 20:24:46.505943227 +0300
-@@ -66,51 +66,51 @@
+diff -urNp -x '*.orig' php-7.2.34.org/ext/standard/tests/file/tempnam_variation1.phpt php-7.2.34/ext/standard/tests/file/tempnam_variation1.phpt
+--- php-7.2.34.org/ext/standard/tests/file/tempnam_variation1.phpt     2020-09-30 07:15:51.000000000 +0200
++++ php-7.2.34/ext/standard/tests/file/tempnam_variation1.phpt 2021-08-27 22:34:20.221498156 +0200
+@@ -66,51 +66,51 @@ echo "*** Done ***\n";
  -- Iteration 1 --
  File name is => %s%etempnam_variation1.tmp%s
  File permissions are => 100600
 +File inode is => %i
  File created in => directory specified
  *** Done ***
---- php-5.3.3/tests/security/open_basedir_fileinode.phpt~      2008-05-09 11:39:44.000000000 +0300
-+++ php-5.3.3/tests/security/open_basedir_fileinode.phpt       2010-07-27 22:51:29.603089549 +0300
-@@ -46,10 +46,10 @@
+diff -urNp -x '*.orig' php-7.2.34.org/tests/security/open_basedir_fileinode.phpt php-7.2.34/tests/security/open_basedir_fileinode.phpt
+--- php-7.2.34.org/tests/security/open_basedir_fileinode.phpt  2020-09-30 07:15:55.000000000 +0200
++++ php-7.2.34/tests/security/open_basedir_fileinode.phpt      2021-08-27 22:34:20.221498156 +0200
+@@ -46,9 +46,9 @@ bool(false)
  
  Warning: fileinode(): open_basedir restriction in effect. File(./../.) is not within the allowed path(s): (.) in %s on line %d
  bool(false)
 +int(%i)
 +int(%i)
  *** Finished testing open_basedir configuration [fileinode] ***
---- php-5.3.3/ext/spl/tests/SplFileInfo_getInode_basic.phpt~   2010-08-04 16:25:21.000000000 +0300
-+++ php-5.3.3/ext/spl/tests/SplFileInfo_getInode_basic.phpt    2010-08-04 16:28:32.722932851 +0300
-@@ -11,6 +11,7 @@
- --SKIPIF--
- <?php
- if (substr(PHP_OS, 0, 3) == 'WIN') die("skip this test not for Windows platforms");
-+if (PHP_INT_SIZE == 4) die("skip this test is for >32bit platform only (inodes overflow there)");
- ?>
- --FILE--
- <?php
index bd3c3d7df0a98473f9eede0135cb1a9744eb7830..71a1cfa32be43e71c1ec6982b8e486dd56f4dc26 100644 (file)
@@ -1,20 +1,7 @@
---- php-5.4.0alpha2/configure.ac~      2011-08-07 12:43:31.000000000 +0300
-+++ php-5.4.0alpha2/configure.ac       2011-08-07 12:44:11.495394662 +0300
-@@ -1271,6 +1271,11 @@
-   ;;
- esac
-+# shift so that pcre, spl, ... are loaded first
-+PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/xml.la \),\2\1,')
-+PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/spl.la \),\2\1,')
-+PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/pcre.la \),\2\1,')
-+
- PHP_SUBST_OLD(PHP_INSTALLED_SAPIS)
- PHP_SUBST(PHP_EXECUTABLE)
---- php-5.5.11/Makefile.global 2014-04-27 15:05:38.963814051 +0300
-+++ php-5.5.11/Makefile.global 2014-04-27 15:09:54.438443707 +0300
-@@ -81,8 +81,15 @@
+diff -urNp -x '*.orig' php-7.2.34.org/Makefile.global php-7.2.34/Makefile.global
+--- php-7.2.34.org/Makefile.global     2021-08-27 22:34:16.728238938 +0200
++++ php-7.2.34/Makefile.global 2021-08-27 22:34:17.704884843 +0200
+@@ -81,8 +81,15 @@ install-headers:
                done; \
        fi
  
@@ -31,7 +18,7 @@
        if test "x$(PHP_MODULES)" != "x"; then \
                for i in $(PHP_MODULES)""; do \
                        . $$i; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
-@@ -111,7 +118,10 @@
+@@ -111,7 +118,10 @@ test: all
                TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
                TEST_PHP_SRCDIR=$(top_srcdir) \
                CC="$(CC)" \
                TEST_RESULT_EXIT_CODE=$$?; \
                rm $(top_builddir)/tmp-php.ini; \
                exit $$TEST_RESULT_EXIT_CODE; \
+diff -urNp -x '*.orig' php-7.2.34.org/configure.ac php-7.2.34/configure.ac
+--- php-7.2.34.org/configure.ac        2021-08-27 22:34:16.738238725 +0200
++++ php-7.2.34/configure.ac    2021-08-27 22:34:17.704884843 +0200
+@@ -1305,6 +1305,11 @@ AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME
+ PHP_OS=`uname | xargs`
+ AC_DEFINE_UNQUOTED(PHP_OS,"$PHP_OS",[uname output])
++# shift so that pcre, spl, ... are loaded first
++PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/xml.la \),\2\1,')
++PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/spl.la \),\2\1,')
++PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/pcre.la \),\2\1,')
++
+ PHP_SUBST_OLD(PHP_INSTALLED_SAPIS)
+ PHP_SUBST(PHP_EXECUTABLE)
index ee257326c60ff9ef22158128690bd364b87eab4b..1c5941e2e2f2a641252c5a919ccb29fad8d8e78e 100644 (file)
@@ -1,8 +1,9 @@
---- php-7.0.0beta1/ext/dba/dba.c.libdb 2015-07-08 02:24:59.119020904 +0200
-+++ php-7.0.0beta1/ext/dba/dba.c       2015-07-08 07:01:43.158767655 +0200
-@@ -52,6 +52,10 @@
- #include "php_qdbm.h"
+diff -urNp -x '*.orig' php-7.2.34.org/ext/dba/dba.c php-7.2.34/ext/dba/dba.c
+--- php-7.2.34.org/ext/dba/dba.c       2020-09-30 07:15:52.000000000 +0200
++++ php-7.2.34/ext/dba/dba.c   2021-08-27 22:34:35.924503218 +0200
+@@ -53,6 +53,10 @@
  #include "php_tcadb.h"
+ #include "php_lmdb.h"
  
 +#ifdef DB4_INCLUDE_FILE
 +#include DB4_INCLUDE_FILE
@@ -11,7 +12,7 @@
  /* {{{ arginfo */
  ZEND_BEGIN_ARG_INFO_EX(arginfo_dba_popen, 0, 0, 2)
        ZEND_ARG_INFO(0, path)
-@@ -545,6 +549,10 @@ PHP_MINFO_FUNCTION(dba)
+@@ -558,6 +562,10 @@ PHP_MINFO_FUNCTION(dba)
  
        php_info_print_table_start();
        php_info_print_table_row(2, "DBA support", "enabled");
index 81d9261e91a4780dbaeca2c18a89f9de8d7041aa..de055bfe31ea4ffb725255a6c0b0a06ed6dae2b4 100644 (file)
@@ -1,11 +1,12 @@
---- php-5.3.27/ext/mysqli/mysqli_nonapi.c~     2013-11-20 00:19:11.000000000 +0200
-+++ php-5.3.27/ext/mysqli/mysqli_nonapi.c      2013-11-20 00:19:44.725872552 +0200
-@@ -73,7 +73,7 @@
+diff -urNp -x '*.orig' php-7.2.34.org/ext/mysqli/mysqli_nonapi.c php-7.2.34/ext/mysqli/mysqli_nonapi.c
+--- php-7.2.34.org/ext/mysqli/mysqli_nonapi.c  2020-09-30 07:15:54.000000000 +0200
++++ php-7.2.34/ext/mysqli/mysqli_nonapi.c      2021-08-27 22:34:30.637946183 +0200
+@@ -74,7 +74,7 @@ void mysqli_common_connect(INTERNAL_FUNC
        zend_bool                       self_alloced = 0;
  
  
 -#if !defined(MYSQL_USE_MYSQLND)
 +#if 0 && !defined(MYSQL_USE_MYSQLND)
        if ((MYSQL_VERSION_ID / 100) != (mysql_get_client_version() / 100)) {
-               php_error_docref(NULL TSRMLS_CC, E_NOTICE,
+               php_error_docref(NULL, E_WARNING,
                                                "Headers and client library minor version mismatch. Headers:%d Library:%ld",
index fea37ea44607098513c63d4eabae5aee14b0b51a..881ce0cf67a1dfbd004095da0ed1ccd98dc92366 100644 (file)
@@ -17,7 +17,7 @@
 +    for j in $PHP_PCRE_REGEX $PHP_PCRE_REGEX/$PHP_LIBDIR /usr/$PHP_LIBDIR; do
        test -f $j/libpcre.a || test -f $j/libpcre.$SHLIB_SUFFIX_NAME && PCRE_LIBDIR=$j
      done
-     
 @@ -52,12 +52,13 @@
      ],[
        -L$PCRE_LIBDIR
 --- php-5.3.2/sapi/cli/tests/018.phpt~ 2008-03-17 16:05:39.000000000 +0200
 +++ php-5.3.2/sapi/cli/tests/018.phpt  2010-03-16 20:41:11.341251246 +0200
 @@ -20,8 +20,6 @@
- --EXPECTF--     
+ --EXPECTF--
  [PHP Modules]
  %a
 -pcre
This page took 0.13211 seconds and 4 git commands to generate.