]> git.pld-linux.org Git - packages/php-pecl-stats.git/commitdiff
support building for multiple php versions
authorElan Ruusamäe <glen@delfi.ee>
Fri, 21 Jun 2013 17:18:41 +0000 (20:18 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 21 Jun 2013 17:18:41 +0000 (20:18 +0300)
php-pecl-stats.spec

index aa66952b3cbe0daa67c4ab1da2458ab53c43992f..660e34c598424270adc364dc362598c6b8928ade 100644 (file)
@@ -1,17 +1,18 @@
-%define                _modname        stats
-%define                _status         stable
-Summary:       %{_modname} - extension with routines for statistical computation
-Summary(pl.UTF-8):     %{_modname} - rozszerzenie z funkcjami do wykonywania obliczeń statystycznych
-Name:          php-pecl-%{_modname}
+%define                php_name        php%{?php_suffix}
+%define                modname stats
+%define                status          stable
+Summary:       %{modname} - extension with routines for statistical computation
+Summary(pl.UTF-8):     %{modname} - rozszerzenie z funkcjami do wykonywania obliczeń statystycznych
+Name:          %{php_name}-pecl-%{modname}
 Version:       1.0.2
 Release:       3
 License:       PHP 3.01
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: 96f105be1e76fbc5dca424057066e4d8
 URL:           http://pecl.php.net/package/stats/
-BuildRequires: php-devel >= 3:5.0.0
-BuildRequires: rpmbuild(macros) >= 1.344
+BuildRequires: %{php_name}-devel >= 3:5.0.0
+BuildRequires: rpmbuild(macros) >= 1.650
 %{?requires_php_extension}
 Requires:      php-common >= 4:5.0.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -21,20 +22,20 @@ Extension that provides few dozens routines for statistical
 computation, such as stats_absolute_deviation(), stats_covariance(),
 harmonic_mean() and others.
 
-In PECL status of this extension is: %{_status}.
+In PECL status of this extension is: %{status}.
 
 %description -l pl.UTF-8
 To rozszerzenie dostarcza wiele różnych funkcji do wykonywania
 obliczeń statystycznych, takich jak stats_absolute_deviation(),
 stats_covariance(), harmonic_mean() i inne.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
-%setup -q -c
+%setup -qc
+mv %{modname}-%{version}/* .
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
@@ -42,11 +43,10 @@ phpize
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
-
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
@@ -62,7 +62,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-%{version}/{CREDITS,TODO}
-%doc %{_modname}-%{version}/tests
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
+%doc CREDITS TODO
+%doc tests
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.034351 seconds and 4 git commands to generate.