]> git.pld-linux.org Git - packages/php-pecl-stats.git/blob - php-pecl-stats.spec
aa66952b3cbe0daa67c4ab1da2458ab53c43992f
[packages/php-pecl-stats.git] / php-pecl-stats.spec
1 %define         _modname        stats
2 %define         _status         stable
3 Summary:        %{_modname} - extension with routines for statistical computation
4 Summary(pl.UTF-8):      %{_modname} - rozszerzenie z funkcjami do wykonywania obliczeń statystycznych
5 Name:           php-pecl-%{_modname}
6 Version:        1.0.2
7 Release:        3
8 License:        PHP 3.01
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  96f105be1e76fbc5dca424057066e4d8
12 URL:            http://pecl.php.net/package/stats/
13 BuildRequires:  php-devel >= 3:5.0.0
14 BuildRequires:  rpmbuild(macros) >= 1.344
15 %{?requires_php_extension}
16 Requires:       php-common >= 4:5.0.4
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Extension that provides few dozens routines for statistical
21 computation, such as stats_absolute_deviation(), stats_covariance(),
22 harmonic_mean() and others.
23
24 In PECL status of this extension is: %{_status}.
25
26 %description -l pl.UTF-8
27 To rozszerzenie dostarcza wiele różnych funkcji do wykonywania
28 obliczeń statystycznych, takich jak stats_absolute_deviation(),
29 stats_covariance(), harmonic_mean() i inne.
30
31 To rozszerzenie ma w PECL status: %{_status}.
32
33 %prep
34 %setup -q -c
35
36 %build
37 cd %{_modname}-%{version}
38 phpize
39 %configure
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
45
46 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
48 ; Enable %{_modname} extension module
49 extension=%{_modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc %{_modname}-%{version}/{CREDITS,TODO}
66 %doc %{_modname}-%{version}/tests
67 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
68 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.020946 seconds and 2 git commands to generate.