]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blob - php-pecl-ssh2.spec
- php 5.5 rebuild
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname ssh2
3 %define         status  beta
4 Summary:        %{modname} - bindings for the libssh2 library
5 Summary(pl.UTF-8):      %{modname} - dowiązania do biblioteki libssh2
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.12
8 Release:        4
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  409b91678a842bb0ff56f2cf018b9160
13 Patch0:         branch.diff
14 URL:            http://pecl.php.net/package/ssh2/
15 BuildRequires:  %{php_name}-devel >= 4:5.0.4
16 BuildRequires:  libssh2-devel >= 1.2.9
17 BuildRequires:  openssl-devel >= 0.9.7d
18 BuildRequires:  rpmbuild(macros) >= 1.650
19 %{?requires_php_extension}
20 Provides:       php(%{modname}) = %{version}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Provides bindings to the functions of libssh2 which implements the
25 SSH2 protocol.
26
27 In PECL status of this extension is: %{status}.
28
29 %description -l pl.UTF-8
30 Dostarcza dowiązań do różnych funkcji biblioteki libssh2
31 implementującej protokół SSH2.
32
33 To rozszerzenie ma w PECL status: %{status}.
34
35 %prep
36 %setup -qc
37 mv %{modname}-%{version}/* .
38 #%patch0 -p0
39
40 %build
41 phpize
42 %configure
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
48 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
49 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
50 ; Enable %{modname} extension module
51 extension=%{modname}.so
52 EOF
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %php_webserver_restart
59
60 %postun
61 if [ "$1" = 0 ]; then
62         %php_webserver_restart
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
68 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.042881 seconds and 3 git commands to generate.