]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blob - php-pecl-ssh2.spec
Up to 1.3.1
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname ssh2
3 Summary:        %{modname} - bindings for the libssh2 library
4 Summary(pl.UTF-8):      %{modname} - dowiązania do biblioteki libssh2
5 Name:           %{php_name}-pecl-%{modname}
6 Version:        1.3.1
7 Release:        1
8 License:        PHP
9 Group:          Development/Languages/PHP
10 Source0:        https://pecl.php.net/get/%{modname}-%{version}.tgz
11 # Source0-md5:  aa29046de73f1036aea66b4a70f6f598
12 URL:            https://pecl.php.net/package/ssh2
13 BuildRequires:  %{php_name}-devel >= 4:7.0.0
14 BuildRequires:  libssh2-devel >= 1.2.9
15 BuildRequires:  openssl-devel >= 0.9.7d
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Provides:       php(%{modname}) = %{version}
19 Obsoletes:      php-pecl-ssh2 < 0.12-4
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Provides bindings to the functions of libssh2 which implements the
24 SSH2 protocol.
25
26 %description -l pl.UTF-8
27 Dostarcza dowiązań do różnych funkcji biblioteki libssh2
28 implementującej protokół SSH2.
29
30 %prep
31 %setup -qc
32 mv %{modname}-%{version}/* .
33
34 %build
35 phpize
36 %configure
37 %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
42 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
43 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/00_%{modname}.ini
44 ; Enable %{modname} extension module
45 extension=%{modname}.so
46 EOF
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 %php_webserver_restart
53
54 %postun
55 if [ "$1" = 0 ]; then
56         %php_webserver_restart
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/*_%{modname}.ini
62 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.121014 seconds and 4 git commands to generate.