]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blob - php-pecl-ssh2.spec
- fixed previous commit msg
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
1 %define         _modname        ssh2
2 %define         _status         beta
3 Summary:        %{_modname} - bindings for the libssh2 library
4 Summary(pl.UTF-8):      %{_modname} - dowiązania do biblioteki libssh2
5 Name:           php-pecl-%{_modname}
6 Version:        0.11.0
7 Release:        1
8 License:        PHP
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  9f5dcd5b92299458389038f7318cbc46
12 Patch0:         php-pecl-ssh2-libssh2.patch
13 URL:            http://pecl.php.net/package/ssh2/
14 BuildRequires:  libssh2-devel >= 0.16
15 BuildRequires:  openssl-devel >= 0.9.7d
16 BuildRequires:  php-devel >= 3:5.0.0
17 BuildRequires:  rpmbuild(macros) >= 1.344
18 %{?requires_php_extension}
19 Requires:       php-common >= 4:5.0.4
20 Obsoletes:      php-pear-%{_modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Provides bindings to the functions of libssh2 which implements the
25 SSH2 protocol.
26
27 In PECL status of this extension is: %{_status}.
28
29 %description -l pl.UTF-8
30 Dostarcza dowiązań do różnych funkcji biblioteki libssh2
31 implementującej protokół SSH2.
32
33 To rozszerzenie ma w PECL status: %{_status}.
34
35 %prep
36 %setup -q -c
37 cd ssh2-%{version}
38 %patch0 -p0
39
40 %build
41 cd %{_modname}-%{version}
42 phpize
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
49
50 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
51 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
52 ; Enable %{_modname} extension module
53 extension=%{_modname}.so
54 EOF
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %php_webserver_restart
61
62 %postun
63 if [ "$1" = 0 ]; then
64         %php_webserver_restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
70 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.080668 seconds and 3 git commands to generate.