]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blobdiff - php-pecl-memcache.spec
php 5.2 deps
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
index b57e6c095fe4bda0353294d11d1a99525b7a625b..1d8f84af087b7d68fa5eb3cc0b1649dd0ad41be0 100644 (file)
 Summary:       %{modname} - a memcached extension
 Summary(pl.UTF-8):     %{modname} - rozszerzenie memcached
 Name:          %{php_name}-pecl-%{modname}
-Version:       3.0.9
-Release:       2
+Version:       4.0.3
+Release:       1
 License:       PHP 3.01
 Group:         Development/Languages/PHP
-#Source0:      http://pecl.php.net/get/%{modname}-%{version}.tgz
-# https://github.com/websupport-sk/pecl-memcache/commits/NON_BLOCKING_IO_php7
-Source0:       https://github.com/websupport-sk/pecl-memcache/archive/%{commit}/%{modname}-%{version}-%{commit}.tar.gz
-# Source0-md5: 945e6a30b3cac160abf9b6d103c5676b
+Source0:       https://github.com/websupport-sk/pecl-memcache/archive/%{version}/%{modname}-%{version}.tar.gz
+# Source0-md5: 21a001ef690a1397a8b62990254cc8c2
 Source1:       %{modname}.ini
 Source2:       %{modname}-apache.conf
 Source3:       %{modname}-lighttpd.conf
 Source4:       config.php
 Patch0:                %{modname}-webapp.patch
-Patch1:                https://github.com/websupport-sk/pecl-memcache/pull/26.patch
-# Patch1-md5:  7d963433154cd82caea94a7476e73697
-Patch2:                https://github.com/websupport-sk/pecl-memcache/pull/30.patch
-# Patch2-md5:  770b57a139428cc601f19e13dbdb2247
-URL:           http://pecl.php.net/package/memcache/
+URL:           https://github.com/websupport-sk/pecl-memcache/
 BuildRequires: %{php_name}-devel >= 3:5.0.0
 BuildRequires: %{php_name}-xml
 BuildRequires: php-packagexml2cl
@@ -37,6 +31,7 @@ BuildRequires:        rpmbuild(macros) >= 1.650
 BuildRequires: %{php_name}-cli
 BuildRequires: %{php_name}-pcre
 BuildRequires: %{php_name}-session
+BuildRequires: %{php_name}-simplexml
 BuildRequires: %{php_name}-spl
 BuildRequires: memcached
 %endif
@@ -96,13 +91,6 @@ memcache.
 %setup -qc
 mv pecl-%{modname}-*/{.??*,*} .
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
-
-# locks up on carme, likely due udp very long timeout
-rm tests/039.phpt
-rm tests/041.phpt
-rm tests/042.phpt
 
 # skip failed tests
 xfail() {
@@ -121,29 +109,6 @@ xfail() {
 }
 
 xfail <<'EOF'
-memcache->addServer() [tests/019.phpt]
-memcache->set()/memcache->get() with multiple keys and load balancing [tests/020.phpt]
-memcache->getExtendedStats() [tests/022.phpt]
-memcache_get_extended_stats() [tests/022a.phpt]
-memcache->delete() with load balancing [tests/023.phpt]
-memcache->increment() with load balancing [tests/025.phpt]
-memcache->delete() with load balancing [tests/026.phpt]
-memcache->addServer() adding server in failed mode [tests/031.phpt]
-memcache->getServerStatus(), memcache->setServerParams() [tests/032.phpt]
-memcache::connect() with unix domain socket [tests/035.phpt]
-memcache->get() over UDP [tests/038.phpt]
-memcache->increment()/decrement() with multiple keys [tests/040.phpt]
-ini_set('memcache.redundancy') [tests/043.phpt]
-ini_set('memcache.session_redundancy') [tests/044.phpt]
-hash strategies and functions [tests/046.phpt]
-ini_set('session.save_handler') with unix domain socket [tests/053.phpt]
-FLAKY: memcache->addServer() with microsecond timeout [tests/056.phpt]
-ini_set('session.save_handler') [tests/036.phpt]
-ini_set("memcache.allow_failover") [tests/029.phpt]
-%if "%{php_major_version}.%{php_minor_version}" >= "7.1"
-strange keys [tests/005.phpt]
-%endif
-memcache multi host save path function [tests/bug73539.phpt]
 EOF
 
 %build
@@ -158,6 +123,7 @@ phpize
 %{__php} -n -q \
        -d extension_dir=modules \
        -d extension=%{php_extensiondir}/pcre.so \
+       -d extension=%{php_extensiondir}/simplexml.so \
        -d extension=%{php_extensiondir}/spl.so \
        -d extension=%{php_extensiondir}/session.so \
        -d extension=%{modname}.so \
@@ -169,7 +135,7 @@ cat <<'EOF' > run-tests.sh
 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
 exec %{__make} test \
        PHP_EXECUTABLE=%{__php} \
-       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl session" \
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre simplexml spl session" \
        RUN_TESTS_SETTINGS="-q $*"
 EOF
 chmod +x run-tests.sh
This page took 0.061773 seconds and 4 git commands to generate.