]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blame - php-pecl-memcache.spec
mark tests properly skipped
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
CommitLineData
8dfd8797
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
3917ea3d 5%define php_name php%{?php_suffix}
a9222c27 6%define modname memcache
afdaa3d2 7%define php_min_version 5.0.0
3917ea3d 8%include /usr/lib/rpm/macros.php
a9222c27
ER
9Summary: %{modname} - a memcached extension
10Summary(pl.UTF-8): %{modname} - rozszerzenie memcached
3917ea3d 11Name: %{php_name}-pecl-%{modname}
10d2ed2a
ER
12Version: 3.0.9
13Release: 1
d7d5fbe6 14License: PHP 3.01
15f9ce79 15Group: Development/Languages/PHP
10d2ed2a
ER
16#Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
17Source0: https://github.com/websupport-sk/pecl-memcache/archive/NON_BLOCKING_IO_php7.tar.gz
18# Source0-md5: 7751d8191302a726449d7c6506b8783d
20995d54 19Source1: %{modname}.ini
afdaa3d2
ER
20Source2: %{modname}-apache.conf
21Source3: %{modname}-lighttpd.conf
22Source4: config.php
23Patch0: %{modname}-webapp.patch
8d125064 24Patch1: tests.patch
016f4b1b 25URL: http://pecl.php.net/package/memcache/
3917ea3d 26BuildRequires: %{php_name}-devel >= 3:5.0.0
241a36be 27BuildRequires: %{php_name}-xml
fae887d4 28BuildRequires: php-packagexml2cl
afdaa3d2 29BuildRequires: rpm-php-pearprov >= 4.4.2-11
62a21c7f 30BuildRequires: rpmbuild(macros) >= 1.650
8dfd8797
ER
31%if %{with tests}
32BuildRequires: %{php_name}-cli
33BuildRequires: %{php_name}-session
ef0230c6 34BuildRequires: %{php_name}-spl
8dfd8797 35%endif
0bee29d4 36%{?requires_php_extension}
3917ea3d
ER
37Requires: %{php_name}-session
38Requires: %{php_name}-zlib
afdaa3d2 39Suggests: memcached
bd3aaaff 40Provides: php(memcache) = %{version}
41a892be 41Obsoletes: php-pecl-memcache < 3.0.8-5
15f9ce79
AG
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
afdaa3d2
ER
44%define _webapps /etc/webapps
45%define _webapp %{modname}
46%define _sysconfdir %{_webapps}/%{_webapp}
47%define _appdir %{_datadir}/%{_webapp}
48
49# bad depsolver
50%define _noautopear pear
51
52# put it together for rpmbuild
53%define _noautoreq %{?_noautophp} %{?_noautopear}
54
15f9ce79
AG
55%description
56Memcached is a caching daemon designed especially for dynamic web
57applications to decrease database load by storing objects in memory.
58
59This extension allows you to work with memcached through handy OO and
60procedural interfaces.
61
6dd6de29 62%description -l pl.UTF-8
15f9ce79 63Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
6dd6de29
JR
64daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
65przez przechowywanie w pamięci obiektów.
15f9ce79 66
6dd6de29 67To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
15f9ce79
AG
68zorientowanego obiektowo (oraz przez procedury) interfejsu.
69
afdaa3d2
ER
70%package web
71Summary: Web interface for memcache
72Group: Libraries
09120ee3 73# does not require extension itself
fae887d4 74Requires: php(core) >= %{php_min_version}
3917ea3d
ER
75Requires: php(date)
76Requires: php(gd)
77Requires: php(pcre)
afdaa3d2
ER
78Requires: webapps
79Requires: webserver(php) >= 5.0
3917ea3d
ER
80%if "%{_rpmversion}" >= "5"
81BuildArch: noarch
82%endif
afdaa3d2
ER
83
84%description web
85Via this web interface script you can manage and view statistics of
86memcache.
87
15f9ce79 88%prep
10d2ed2a
ER
89%setup -qc
90mv pecl-%{modname}-*/{.??*,*} .
afdaa3d2 91%patch0 -p1
8d125064 92%patch1 -p1
15f9ce79
AG
93
94%build
6c6304c8 95packagexml2cl package.xml > ChangeLog
15f9ce79 96phpize
172c079e
AG
97%configure \
98 --with-zlib-dir=/usr
15f9ce79
AG
99%{__make}
100
8dfd8797
ER
101%if %{with tests}
102# simple module load test
103%{__php} -n -q \
104 -d extension_dir=modules \
ef0230c6 105 -d extension=%{php_extensiondir}/spl.so \
8dfd8797
ER
106 -d extension=%{php_extensiondir}/session.so \
107 -d extension=%{modname}.so \
108 -m > modules.log
109grep %{modname} modules.log
e7368be2
ER
110
111cat <<'EOF' > run-tests.sh
112#!/bin/sh
113export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
114exec %{__make} test \
115 PHP_EXECUTABLE=%{__php} \
ef0230c6 116 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl session" \
e7368be2
ER
117 RUN_TESTS_SETTINGS="-q $*"
118EOF
119chmod +x run-tests.sh
120
121./run-tests.sh
8dfd8797
ER
122%endif
123
15f9ce79
AG
124%install
125rm -rf $RPM_BUILD_ROOT
a9222c27 126install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
20995d54
ER
127install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
128# we use "session_" prefix in inifile to get loader *after* session extension
10d2ed2a
ER
129cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/session_%{modname}.ini
130cp -p example.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
131
132install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
10d2ed2a
ER
133cp -p memcache.php $RPM_BUILD_ROOT%{_appdir}
134cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/config.php
135cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
136cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
137cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
15f9ce79
AG
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%post
86295f4f 143%php_webserver_restart
15f9ce79 144
0bee29d4
ER
145%postun
146if [ "$1" = 0 ]; then
86295f4f 147 %php_webserver_restart
15f9ce79
AG
148fi
149
c69936a3
ER
150%triggerpostun -- %{name} < 3.0.4-2
151if [ -f %{php_sysconfdir}/conf.d/%{modname}.ini.rpmsave ]; then
152 echo >&2 "Restoring old config: %{modname}.ini.rpmsave -> session_%{modname}.ini in %{php_sysconfdir}/conf.d"
153 cp -f %{php_sysconfdir}/conf.d/session_%{modname}.ini{,.rpmnew}
154 mv -f %{php_sysconfdir}/conf.d/{%{modname}.ini.rpmsave,session_%{modname}.ini}
155 %php_webserver_restart
156fi
157
afdaa3d2
ER
158%triggerin web -- apache1 < 1.3.37-3, apache1-base
159%webapp_register apache %{_webapp}
160
161%triggerun web -- apache1 < 1.3.37-3, apache1-base
162%webapp_unregister apache %{_webapp}
163
fbc0c377 164%triggerin web -- apache < 2.2.0, apache-base
afdaa3d2
ER
165%webapp_register httpd %{_webapp}
166
fbc0c377 167%triggerun web -- apache < 2.2.0, apache-base
afdaa3d2
ER
168%webapp_unregister httpd %{_webapp}
169
170%triggerin web -- lighttpd
171%webapp_register lighttpd %{_webapp}
172
173%triggerun web -- lighttpd
174%webapp_unregister lighttpd %{_webapp}
175
15f9ce79
AG
176%files
177%defattr(644,root,root,755)
6c6304c8 178%doc CREDITS README ChangeLog
c69936a3 179%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/session_%{modname}.ini
a9222c27
ER
180%attr(755,root,root) %{php_extensiondir}/%{modname}.so
181%{_examplesdir}/%{name}-%{version}
afdaa3d2
ER
182
183%files web
184%defattr(644,root,root,755)
185%dir %attr(750,root,http) %{_sysconfdir}
186%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
187%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
188%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
1ec0934f 189%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
afdaa3d2 190%{_appdir}
This page took 0.102685 seconds and 4 git commands to generate.