]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blame - php-pecl-imagick.spec
- release 3 (by relup.sh)
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
CommitLineData
a70f8547
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
77bd0b10
ER
5%define php_name php%{?php_suffix}
6%define modname imagick
c3cb436b 7%define status stable
90d6d7a5 8%define libversion %(pkg-config --modversion MagickCore 2>/dev/null || echo ERROR)
c3cb436b
ER
9Summary: %{modname} - PHP wrapper to the Image Magick Library
10Summary(pl.UTF-8): %{modname} - PHP-owy wrapper do biblioteki Image Magick
77bd0b10 11Name: %{php_name}-pecl-%{modname}
90d6d7a5 12Version: 3.4.4
e795c55b 13Release: 3
80c4878b 14License: PHP 3.01
7ef11872 15Group: Development/Languages/PHP
4f00096b 16Source0: https://pecl.php.net/get/%{modname}-%{version}.tgz
90d6d7a5 17# Source0-md5: 6d3a7048ab73b0fab931f28c484dbf76
4baa9e02 18Patch0: skip_version_check.patch
4f00096b 19URL: https://pecl.php.net/package/imagick
76282008 20BuildRequires: %{php_name}-cli
4c078d1b 21BuildRequires: %{php_name}-devel >= 4:5.3
76282008
ER
22BuildRequires: %{php_name}-pcre
23BuildRequires: %{php_name}-spl
30d818b5 24BuildRequires: ImageMagick-devel >= 1:6.2.4.0
58592d83
ER
25BuildRequires: pkgconfig
26BuildRequires: re2c
696a2b4e 27BuildRequires: rpmbuild(macros) >= 1.650
a70f8547 28%if %{with tests}
4dc1d668
ER
29BuildRequires: ImageMagick-coder-jpeg
30BuildRequires: ImageMagick-coder-png
31BuildRequires: ImageMagick-coder-tiff
a70f8547 32%endif
dbfce4b3 33%{?requires_php_extension}
ac93969d 34Requires(triggerpostun): sed >= 4.0
b65e8485 35Requires: %{php_name}-spl
6e32b6ae
ER
36Suggests: ImageMagick-coder-jpeg
37Suggests: ImageMagick-coder-png
38Suggests: ImageMagick-coder-tiff
ee3b6a5c 39Provides: php(imagick) = %{version}
4f00096b 40Provides: php(lib-imagick) = %{libversion}
c056a9a3 41Obsoletes: php-pecl-imagick < 3.1.2-2
7ef11872 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
7ef11872 44%description
45ImageMagick is a robust collection of tools and libraries to read,
46write, and manipulate an image in many image formats (over 68 major
47formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
48and GIF. With ImageMagick you can create images dynamically, making it
49suitable for Web applications. You can also resize, rotate, sharpen,
50color reduce, or add special effects to an image and save your
51completed work in the same or differing image format.
52
c3cb436b 53In PECL status of this package is: %{status}.
3fd56945 54
98a194af
JR
55%description -l pl.UTF-8
56ImageMagick to duży zestaw narzędzi i bibliotek do odczytu, zapisu i
57modyfikowania obrazków w wielu formatach (ponad 68 głównych), w tym
58popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomocą
59ImageMagick można dynamicznie tworzyć obrazki, co jest przydatne w
60aplikacjach WWW. Można je także przeskalowywać, obracać, wyostrzać,
61zmniejszać ilość kolorów - w tym samym lub innym formacie.
7ef11872 62
c3cb436b 63To rozszerzenie ma w PECL status: %{status}.
3fd56945 64
7ef11872 65%prep
4baa9e02 66%setup -qc
2f0fc694 67mv %{modname}-%{version}/* .
4baa9e02 68%patch0 -p1
7ef11872 69
b49484d9
ER
70xfail() {
71 t=$1
72 cat >> $t <<-EOF
73
74 --XFAIL--
75 Skip
76 EOF
77}
f5c1a0f1
ER
78Test() {
79 nf=$(eval echo \$$#)
80 t=$nf; t=${t#\[}; t=${t%\]}
b49484d9 81 xfail $t
f5c1a0f1 82}
b49484d9 83# skip failing tests
f5c1a0f1 84Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
5f8da6bd 85Test Imagick, setRegistry and getRegistry [tests/150_Imagick_setregistry.phpt]
f5c1a0f1
ER
86Test ImagickDraw, composite [tests/177_ImagickDraw_composite_basic.phpt]
87Test ImagickDraw, setFontSize [tests/206_ImagickDraw_setFontSize_basic.phpt]
88Test ImagickDraw, setFontFamily [tests/207_ImagickDraw_setFontFamily_basic.phpt]
89Test ImagickDraw, setFontStretch [tests/208_ImagickDraw_setFontStretch_basic.phpt]
90Test ImagickDraw, setFontWeight [tests/209_ImagickDraw_setFontWeight_basic.phpt]
91Test ImagickDraw, setFontStyle [tests/210_ImagickDraw_setFontStyle_basic.phpt]
92Test ImagickDraw, setGravity [tests/212_ImagickDraw_setGravity_basic.phpt]
93Test ImagickDraw, setTextAlignment [tests/222_ImagickDraw_setTextAlignment_basic.phpt]
94Test ImagickDraw, setTextAntialias [tests/223_ImagickDraw_setTextAntialias_basic.phpt]
95Test ImagickDraw, setTextUnderColor [tests/224_ImagickDraw_setTextUnderColor_basic.phpt]
96Test ImagickDraw, setTextDecoration [tests/225_ImagickDraw_setTextDecoration_basic.phpt]
97Test Tutorial, psychedelicFont [tests/241_Tutorial_psychedelicFont_basic.phpt]
98Test Tutorial, svgExample [tests/243_Tutorial_svgExample_basic.phpt]
99Test Tutorial, psychedelicFontGif [tests/244_Tutorial_psychedelicFontGif_basic.phpt]
59b48731
JR
100Test Imagick, Imagick::exportImagePixels [tests/256_Imagick_exportImagePixels_basic.phpt]
101Test ImagickDraw, getTextDirection [tests/264_ImagickDraw_getTextDirection_basic.phpt]
102Test ImagickDraw, getFontResolution [tests/266_ImagickDraw_getFontResolution_basic.phpt]
b49484d9
ER
103%ifarch x32
104# Fail on 7.0
105Test Imagick, quantizeImage [tests/101_Imagick_quantizeImage_basic.phpt]
106Test Imagick, uniqueImageColors [tests/163_Imagick_uniqueImageColors_basic.phpt]
107Test Tutorial, deconstructGif [tests/237_Tutorial_deconstructGif_basic.phpt]
108Test ImagickPixelIterator, setIteratorRow [tests/251_ImagickPixelIterator_setIteratorRow_basic.phpt]
109%endif
fa75259d
ER
110# Fail on 5.3, 5.5, 5.6, 7.0, 7.1, 7.2
111Test Tutorial, fxAnalyzeImage [tests/229_Tutorial_fxAnalyzeImage_case1.phpt]
f5c1a0f1 112
7ef11872 113%build
7ef11872 114phpize
4f203515
JR
115%configure \
116 php_cv_cc_dashr=false
7ef11872 117
bc18093b 118%{__make} \
bc18093b 119 CFLAGS_CLEAN="%{rpmcflags}"
7ef11872 120
a70f8547
ER
121%{__php} -n -q \
122 -d extension_dir=modules \
e8211def 123%if "%php_major_version.%php_minor_version" < "7.4"
501a42f6 124 -d extension=%{php_extensiondir}/pcre.so \
a70f8547 125 -d extension=%{php_extensiondir}/spl.so \
e8211def 126%endif
a70f8547
ER
127 -d extension=%{modname}.so \
128 -m > modules.log
129grep %{modname} modules.log
130
76282008 131%if %{with tests}
a70f8547
ER
132export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
133%{__make} test \
134 PHP_EXECUTABLE=%{__php} \
e8211def 135%if "%php_major_version.%php_minor_version" < "7.4"
501a42f6 136 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl" \
a70f8547 137%endif
e8211def 138%endif
a70f8547 139
7ef11872 140%install
141rm -rf $RPM_BUILD_ROOT
be7cd71f 142install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
c3cb436b
ER
143install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
144cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
145; Enable %{modname} extension module
146extension=%{modname}.so
dbfce4b3 147EOF
be7cd71f 148cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
7ef11872 149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%post
f7ead91e 154%php_webserver_restart
7ef11872 155
dbfce4b3
ER
156%postun
157if [ "$1" = 0 ]; then
f7ead91e 158 %php_webserver_restart
7ef11872 159fi
160
dbfce4b3 161%triggerpostun -- %{name} < 0.9.11-2.1
c3cb436b 162%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*%{modname}\.so/d' %{php_sysconfdir}/php.ini
dbfce4b3 163
7ef11872 164%files
165%defattr(644,root,root,755)
1fe13cac 166%doc CREDITS
c3cb436b
ER
167%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
168%attr(755,root,root) %{php_extensiondir}/%{modname}.so
be7cd71f 169%{_examplesdir}/%{name}-%{version}
This page took 0.071784 seconds and 4 git commands to generate.