]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blame - php-pecl-imagick.spec
- rebuild with ImageMagick 7.0.4.0
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
CommitLineData
a70f8547
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
77bd0b10
ER
5%define php_name php%{?php_suffix}
6%define modname imagick
c3cb436b 7%define status stable
59b48731 8%define pre RC1
2a03fe33 9%define rel 2
c3cb436b
ER
10Summary: %{modname} - PHP wrapper to the Image Magick Library
11Summary(pl.UTF-8): %{modname} - PHP-owy wrapper do biblioteki Image Magick
77bd0b10 12Name: %{php_name}-pecl-%{modname}
59b48731 13Version: 3.4.3
2a03fe33 14Release: 0.%{pre}.%{rel}
80c4878b 15License: PHP 3.01
7ef11872 16Group: Development/Languages/PHP
59b48731
JR
17Source0: http://pecl.php.net/get/%{modname}-%{version}%{pre}.tgz
18# Source0-md5: 32042fc3043f013047927de21ff15a47
4baa9e02 19Patch0: skip_version_check.patch
b46c9cbe 20URL: http://pecl.php.net/package/imagick/
4c078d1b 21BuildRequires: %{php_name}-devel >= 4:5.3
30d818b5 22BuildRequires: ImageMagick-devel >= 1:6.2.4.0
58592d83
ER
23BuildRequires: pkgconfig
24BuildRequires: re2c
696a2b4e 25BuildRequires: rpmbuild(macros) >= 1.650
a70f8547
ER
26%if %{with tests}
27BuildRequires: %{php_name}-cli
501a42f6 28BuildRequires: %{php_name}-pcre
a70f8547 29BuildRequires: %{php_name}-spl
4dc1d668
ER
30BuildRequires: ImageMagick-coder-jpeg
31BuildRequires: ImageMagick-coder-png
32BuildRequires: ImageMagick-coder-tiff
a70f8547 33%endif
dbfce4b3 34%{?requires_php_extension}
ac93969d 35Requires(triggerpostun): sed >= 4.0
b65e8485 36Requires: %{php_name}-spl
6e32b6ae
ER
37Suggests: ImageMagick-coder-jpeg
38Suggests: ImageMagick-coder-png
39Suggests: ImageMagick-coder-tiff
ee3b6a5c 40Provides: php(imagick) = %{version}
c056a9a3 41Obsoletes: php-pecl-imagick < 3.1.2-2
7ef11872 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
7ef11872 44%description
45ImageMagick is a robust collection of tools and libraries to read,
46write, and manipulate an image in many image formats (over 68 major
47formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
48and GIF. With ImageMagick you can create images dynamically, making it
49suitable for Web applications. You can also resize, rotate, sharpen,
50color reduce, or add special effects to an image and save your
51completed work in the same or differing image format.
52
c3cb436b 53In PECL status of this package is: %{status}.
3fd56945 54
98a194af
JR
55%description -l pl.UTF-8
56ImageMagick to duży zestaw narzędzi i bibliotek do odczytu, zapisu i
57modyfikowania obrazków w wielu formatach (ponad 68 głównych), w tym
58popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomocą
59ImageMagick można dynamicznie tworzyć obrazki, co jest przydatne w
60aplikacjach WWW. Można je także przeskalowywać, obracać, wyostrzać,
61zmniejszać ilość kolorów - w tym samym lub innym formacie.
7ef11872 62
c3cb436b 63To rozszerzenie ma w PECL status: %{status}.
3fd56945 64
7ef11872 65%prep
4baa9e02 66%setup -qc
59b48731 67mv %{modname}-%{version}%{pre}/* .
4baa9e02 68%patch0 -p1
7ef11872 69
b49484d9
ER
70xfail() {
71 t=$1
72 cat >> $t <<-EOF
73
74 --XFAIL--
75 Skip
76 EOF
77}
f5c1a0f1
ER
78Test() {
79 nf=$(eval echo \$$#)
80 t=$nf; t=${t#\[}; t=${t%\]}
b49484d9 81 xfail $t
f5c1a0f1 82}
b49484d9 83# skip failing tests
f5c1a0f1
ER
84Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
85Test ImagickDraw, composite [tests/177_ImagickDraw_composite_basic.phpt]
86Test ImagickDraw, setFontSize [tests/206_ImagickDraw_setFontSize_basic.phpt]
87Test ImagickDraw, setFontFamily [tests/207_ImagickDraw_setFontFamily_basic.phpt]
88Test ImagickDraw, setFontStretch [tests/208_ImagickDraw_setFontStretch_basic.phpt]
89Test ImagickDraw, setFontWeight [tests/209_ImagickDraw_setFontWeight_basic.phpt]
90Test ImagickDraw, setFontStyle [tests/210_ImagickDraw_setFontStyle_basic.phpt]
91Test ImagickDraw, setGravity [tests/212_ImagickDraw_setGravity_basic.phpt]
92Test ImagickDraw, setTextAlignment [tests/222_ImagickDraw_setTextAlignment_basic.phpt]
93Test ImagickDraw, setTextAntialias [tests/223_ImagickDraw_setTextAntialias_basic.phpt]
94Test ImagickDraw, setTextUnderColor [tests/224_ImagickDraw_setTextUnderColor_basic.phpt]
95Test ImagickDraw, setTextDecoration [tests/225_ImagickDraw_setTextDecoration_basic.phpt]
96Test Tutorial, psychedelicFont [tests/241_Tutorial_psychedelicFont_basic.phpt]
97Test Tutorial, svgExample [tests/243_Tutorial_svgExample_basic.phpt]
98Test Tutorial, psychedelicFontGif [tests/244_Tutorial_psychedelicFontGif_basic.phpt]
59b48731
JR
99Test Imagick, Imagick::exportImagePixels [tests/256_Imagick_exportImagePixels_basic.phpt]
100Test ImagickDraw, getTextDirection [tests/264_ImagickDraw_getTextDirection_basic.phpt]
101Test ImagickDraw, getFontResolution [tests/266_ImagickDraw_getFontResolution_basic.phpt]
b49484d9
ER
102%ifarch x32
103# Fail on 7.0
104Test Imagick, quantizeImage [tests/101_Imagick_quantizeImage_basic.phpt]
105Test Imagick, uniqueImageColors [tests/163_Imagick_uniqueImageColors_basic.phpt]
106Test Tutorial, deconstructGif [tests/237_Tutorial_deconstructGif_basic.phpt]
107Test ImagickPixelIterator, setIteratorRow [tests/251_ImagickPixelIterator_setIteratorRow_basic.phpt]
108%endif
f5c1a0f1 109
7ef11872 110%build
7ef11872 111phpize
4f203515
JR
112%configure \
113 php_cv_cc_dashr=false
7ef11872 114
bc18093b 115%{__make} \
bc18093b 116 CFLAGS_CLEAN="%{rpmcflags}"
7ef11872 117
a70f8547
ER
118%if %{with tests}
119%{__php} -n -q \
120 -d extension_dir=modules \
501a42f6 121 -d extension=%{php_extensiondir}/pcre.so \
a70f8547
ER
122 -d extension=%{php_extensiondir}/spl.so \
123 -d extension=%{modname}.so \
124 -m > modules.log
125grep %{modname} modules.log
126
127export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
128%{__make} test \
129 PHP_EXECUTABLE=%{__php} \
501a42f6 130 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl" \
a70f8547
ER
131%endif
132
7ef11872 133%install
134rm -rf $RPM_BUILD_ROOT
be7cd71f 135install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
c3cb436b
ER
136install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
137cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
138; Enable %{modname} extension module
139extension=%{modname}.so
dbfce4b3 140EOF
be7cd71f 141cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
7ef11872 142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%post
f7ead91e 147%php_webserver_restart
7ef11872 148
dbfce4b3
ER
149%postun
150if [ "$1" = 0 ]; then
f7ead91e 151 %php_webserver_restart
7ef11872 152fi
153
dbfce4b3 154%triggerpostun -- %{name} < 0.9.11-2.1
c3cb436b 155%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*%{modname}\.so/d' %{php_sysconfdir}/php.ini
dbfce4b3 156
7ef11872 157%files
158%defattr(644,root,root,755)
1fe13cac 159%doc CREDITS
c3cb436b
ER
160%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
161%attr(755,root,root) %{php_extensiondir}/%{modname}.so
be7cd71f 162%{_examplesdir}/%{name}-%{version}
This page took 0.127473 seconds and 4 git commands to generate.