]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blame - php-pecl-imagick.spec
Up to 3.5.1; PHP 8 support
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
CommitLineData
a70f8547
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
77bd0b10
ER
5%define php_name php%{?php_suffix}
6%define modname imagick
c3cb436b 7%define status stable
90d6d7a5 8%define libversion %(pkg-config --modversion MagickCore 2>/dev/null || echo ERROR)
c3cb436b
ER
9Summary: %{modname} - PHP wrapper to the Image Magick Library
10Summary(pl.UTF-8): %{modname} - PHP-owy wrapper do biblioteki Image Magick
77bd0b10 11Name: %{php_name}-pecl-%{modname}
cb8c1b52
ER
12Version: 3.5.1
13Release: 1
80c4878b 14License: PHP 3.01
7ef11872 15Group: Development/Languages/PHP
4f00096b 16Source0: https://pecl.php.net/get/%{modname}-%{version}.tgz
cb8c1b52 17# Source0-md5: c1385a8dabdf3aa3245f09580583dbd2
4baa9e02 18Patch0: skip_version_check.patch
4f00096b 19URL: https://pecl.php.net/package/imagick
76282008 20BuildRequires: %{php_name}-cli
4c078d1b 21BuildRequires: %{php_name}-devel >= 4:5.3
76282008
ER
22BuildRequires: %{php_name}-pcre
23BuildRequires: %{php_name}-spl
30d818b5 24BuildRequires: ImageMagick-devel >= 1:6.2.4.0
58592d83
ER
25BuildRequires: pkgconfig
26BuildRequires: re2c
696a2b4e 27BuildRequires: rpmbuild(macros) >= 1.650
a70f8547 28%if %{with tests}
4dc1d668
ER
29BuildRequires: ImageMagick-coder-jpeg
30BuildRequires: ImageMagick-coder-png
31BuildRequires: ImageMagick-coder-tiff
a70f8547 32%endif
dbfce4b3 33%{?requires_php_extension}
671f1772 34Requires(postun): sed >= 4.0
b65e8485 35Requires: %{php_name}-spl
6e32b6ae
ER
36Suggests: ImageMagick-coder-jpeg
37Suggests: ImageMagick-coder-png
38Suggests: ImageMagick-coder-tiff
ee3b6a5c 39Provides: php(imagick) = %{version}
4f00096b 40Provides: php(lib-imagick) = %{libversion}
c056a9a3 41Obsoletes: php-pecl-imagick < 3.1.2-2
7ef11872 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
7ef11872 44%description
45ImageMagick is a robust collection of tools and libraries to read,
46write, and manipulate an image in many image formats (over 68 major
47formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
48and GIF. With ImageMagick you can create images dynamically, making it
49suitable for Web applications. You can also resize, rotate, sharpen,
50color reduce, or add special effects to an image and save your
51completed work in the same or differing image format.
52
c3cb436b 53In PECL status of this package is: %{status}.
3fd56945 54
98a194af
JR
55%description -l pl.UTF-8
56ImageMagick to duży zestaw narzędzi i bibliotek do odczytu, zapisu i
57modyfikowania obrazków w wielu formatach (ponad 68 głównych), w tym
58popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomocą
59ImageMagick można dynamicznie tworzyć obrazki, co jest przydatne w
60aplikacjach WWW. Można je także przeskalowywać, obracać, wyostrzać,
61zmniejszać ilość kolorów - w tym samym lub innym formacie.
7ef11872 62
c3cb436b 63To rozszerzenie ma w PECL status: %{status}.
3fd56945 64
7ef11872 65%prep
4baa9e02 66%setup -qc
2f0fc694 67mv %{modname}-%{version}/* .
4baa9e02 68%patch0 -p1
7ef11872 69
b49484d9 70xfail() {
96575c7e
ER
71 local t=$1
72 test -f $t
b49484d9
ER
73 cat >> $t <<-EOF
74
75 --XFAIL--
76 Skip
77 EOF
78}
96575c7e
ER
79
80while read line; do
81 t=${line##*\[}; t=${t%\]}
82 test -z "$t" -o "${t:0:1}" = '#' && continue
b49484d9 83 xfail $t
96575c7e
ER
84done << 'EOF'
85
b49484d9 86# skip failing tests
f5c1a0f1 87Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
5f8da6bd 88Test Imagick, setRegistry and getRegistry [tests/150_Imagick_setregistry.phpt]
f5c1a0f1
ER
89Test ImagickDraw, composite [tests/177_ImagickDraw_composite_basic.phpt]
90Test ImagickDraw, setFontSize [tests/206_ImagickDraw_setFontSize_basic.phpt]
91Test ImagickDraw, setFontFamily [tests/207_ImagickDraw_setFontFamily_basic.phpt]
92Test ImagickDraw, setFontStretch [tests/208_ImagickDraw_setFontStretch_basic.phpt]
93Test ImagickDraw, setFontWeight [tests/209_ImagickDraw_setFontWeight_basic.phpt]
94Test ImagickDraw, setFontStyle [tests/210_ImagickDraw_setFontStyle_basic.phpt]
95Test ImagickDraw, setGravity [tests/212_ImagickDraw_setGravity_basic.phpt]
96Test ImagickDraw, setTextAlignment [tests/222_ImagickDraw_setTextAlignment_basic.phpt]
97Test ImagickDraw, setTextAntialias [tests/223_ImagickDraw_setTextAntialias_basic.phpt]
98Test ImagickDraw, setTextUnderColor [tests/224_ImagickDraw_setTextUnderColor_basic.phpt]
99Test ImagickDraw, setTextDecoration [tests/225_ImagickDraw_setTextDecoration_basic.phpt]
100Test Tutorial, psychedelicFont [tests/241_Tutorial_psychedelicFont_basic.phpt]
101Test Tutorial, svgExample [tests/243_Tutorial_svgExample_basic.phpt]
102Test Tutorial, psychedelicFontGif [tests/244_Tutorial_psychedelicFontGif_basic.phpt]
59b48731
JR
103Test Imagick, Imagick::exportImagePixels [tests/256_Imagick_exportImagePixels_basic.phpt]
104Test ImagickDraw, getTextDirection [tests/264_ImagickDraw_getTextDirection_basic.phpt]
105Test ImagickDraw, getFontResolution [tests/266_ImagickDraw_getFontResolution_basic.phpt]
b49484d9
ER
106%ifarch x32
107# Fail on 7.0
108Test Imagick, quantizeImage [tests/101_Imagick_quantizeImage_basic.phpt]
109Test Imagick, uniqueImageColors [tests/163_Imagick_uniqueImageColors_basic.phpt]
110Test Tutorial, deconstructGif [tests/237_Tutorial_deconstructGif_basic.phpt]
111Test ImagickPixelIterator, setIteratorRow [tests/251_ImagickPixelIterator_setIteratorRow_basic.phpt]
112%endif
fa75259d
ER
113# Fail on 5.3, 5.5, 5.6, 7.0, 7.1, 7.2
114Test Tutorial, fxAnalyzeImage [tests/229_Tutorial_fxAnalyzeImage_case1.phpt]
f5c1a0f1 115
96575c7e
ER
116# 5.3, 5.5, 5.6, 7.0/x32, 7.1, 7.2, 7.3, 7.4
117ImagickKernel::fromMatrix exceptions [tests/280_imagickkernel_exception_invalid_origin.phpt]
118Imagick::setImageAlpha [tests/274_imagick_setImageAlpha.phpt]
119Test ImagickDraw:: setTextInterlineSpacing [tests/279_ImagickDraw_setTextInterlineSpacing.phpt]
120Test Imagick::optimizeimagelayers and Imagick::optimizeimagetransparency [tests/278_Imagick_optimaze_gif.phpt]
fec66c9d
ER
121
122# php73/x32
123Test PHP bug #59378 writing to php://memory is incomplete [tests/bug59378.phpt]
124
125# php 7.4, 8.0
126%if "%php_major_version.%php_minor_version" == "7.4"
127Casting color and opacity to pixel [tests/003_cast_color_opacity.phpt]
128Different types of thumbnailing [tests/002_thumbnail.phpt]
129ImagickKernel::fromMatrix test [tests/145_imagickkernel_coverage.phpt]
130Imagick::resizeImage prevent 0 width/height images [tests/github_174.phpt]
131Test autoGammaImage [tests/263_autoGammaImage.phpt]
132Test compositeImageGravity [tests/261_compositeImageGravity.phpt]
133Test cropthumbnail [tests/006_cropthumbnail.phpt]
134Test filling thumbnail with color [tests/007_thumbnail_fill.phpt]
135Test for round issues [tests/064_cropThumbNailImage.phpt]
136Test Imagick::colorDecisionListImage [tests/277_Imagick_colorDecisionListImage.phpt]
137Test Imagick, progressMonitor [tests/127_Imagick_progressMonitor_basic.phpt]
138Test importimagepixels [tests/010_importimagepixels.phpt]
139Testing clone keyword [tests/004_clone.phpt]
140Testing that cloned object does not affect the original [tests/012-clone-separation.phpt]
141Test thumbnail bestfit [tests/005_bestfit.phpt]
5ee919f7
ER
142%ifarch x32 %{ix86}
143Test localContrastImage [tests/260_localContrastImage.phpt]
144%endif
fec66c9d 145%endif
96575c7e
ER
146EOF
147
7ef11872 148%build
7ef11872 149phpize
4f203515
JR
150%configure \
151 php_cv_cc_dashr=false
7ef11872 152
bc18093b 153%{__make} \
bc18093b 154 CFLAGS_CLEAN="%{rpmcflags}"
7ef11872 155
a70f8547
ER
156%{__php} -n -q \
157 -d extension_dir=modules \
e8211def 158%if "%php_major_version.%php_minor_version" < "7.4"
501a42f6 159 -d extension=%{php_extensiondir}/pcre.so \
a70f8547 160 -d extension=%{php_extensiondir}/spl.so \
e8211def 161%endif
a70f8547
ER
162 -d extension=%{modname}.so \
163 -m > modules.log
164grep %{modname} modules.log
165
76282008 166%if %{with tests}
a70f8547
ER
167export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
168%{__make} test \
169 PHP_EXECUTABLE=%{__php} \
e8211def 170%if "%php_major_version.%php_minor_version" < "7.4"
501a42f6 171 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl" \
a70f8547 172%endif
e8211def 173%endif
a70f8547 174
7ef11872 175%install
176rm -rf $RPM_BUILD_ROOT
be7cd71f 177install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
c3cb436b
ER
178install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
179cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
180; Enable %{modname} extension module
181extension=%{modname}.so
dbfce4b3 182EOF
be7cd71f 183cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
7ef11872 184
185%clean
186rm -rf $RPM_BUILD_ROOT
187
188%post
f7ead91e 189%php_webserver_restart
7ef11872 190
dbfce4b3
ER
191%postun
192if [ "$1" = 0 ]; then
f7ead91e 193 %php_webserver_restart
7ef11872 194fi
195
dbfce4b3 196%triggerpostun -- %{name} < 0.9.11-2.1
c3cb436b 197%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*%{modname}\.so/d' %{php_sysconfdir}/php.ini
dbfce4b3 198
7ef11872 199%files
200%defattr(644,root,root,755)
1fe13cac 201%doc CREDITS
c3cb436b
ER
202%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
203%attr(755,root,root) %{php_extensiondir}/%{modname}.so
be7cd71f 204%{_examplesdir}/%{name}-%{version}
This page took 0.080951 seconds and 4 git commands to generate.