]> git.pld-linux.org Git - packages/php-pecl-funcall.git/commitdiff
- new auto/ac/php-pecl-funcall-0_2_2-1 auto/th/php-pecl-funcall-0_2_2-1
authorAdam Gołębiowski <adamg@pld-linux.org>
Fri, 12 Sep 2008 15:09:50 +0000 (15:09 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-pecl-funcall.spec -> 1.1

php-pecl-funcall.spec [new file with mode: 0644]

diff --git a/php-pecl-funcall.spec b/php-pecl-funcall.spec
new file mode 100644 (file)
index 0000000..82fb7f8
--- /dev/null
@@ -0,0 +1,68 @@
+%define                _modname        funcall
+%define                _status         stable
+Summary:       %{_modname} - Add callbacks for any function/method
+Summary(pl.UTF-8):     %{_modname} - odwołania dla dowolnej funkcji / metody
+Name:          php-pecl-%{_modname}
+Version:       0.2.2
+Release:       1
+License:       BSD
+Group:         Development/Languages/PHP
+Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
+# Source0-md5: 5a86a01b065d3d767d8b0f7a2a3ca865
+URL:           http://pecl.php.net/package/funcall/
+BuildRequires: php-devel >= 3:5.0.0
+BuildRequires: rpmbuild(macros) >= 1.344
+%{?requires_php_extension}
+Requires:      php-common >= 4:5.0.4
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Call callbacks before or after specified functions/methods being
+called.
+
+In PECL status of this extension is: %{_status}.
+
+%description -l pl.UTF-8
+Rozszerzenie to pozwala na wykonywanie odwołań przed lub po wywołaniu
+określonej funkcji / metody.
+
+To rozszerzenie ma w PECL status: %{_status}.
+
+%prep
+%setup -q -c
+
+%build
+cd %{_modname}-%{version}
+phpize
+%configure
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
+
+%{__make} install \
+       -C %{_modname}-%{version} \
+       INSTALL_ROOT=$RPM_BUILD_ROOT \
+       EXTENSION_DIR=%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
+; Enable %{_modname} extension module
+extension=%{_modname}.so
+EOF
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%php_webserver_restart
+
+%postun
+if [ "$1" = 0 ]; then
+       %php_webserver_restart
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc %{_modname}-%{version}/{TODO,funcall.php}
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.043634 seconds and 4 git commands to generate.