]> git.pld-linux.org Git - packages/php-pecl-funcall.git/blob - php-pecl-funcall.spec
- new
[packages/php-pecl-funcall.git] / php-pecl-funcall.spec
1 %define         _modname        funcall
2 %define         _status         stable
3 Summary:        %{_modname} - Add callbacks for any function/method
4 Summary(pl.UTF-8):      %{_modname} - odwołania dla dowolnej funkcji / metody
5 Name:           php-pecl-%{_modname}
6 Version:        0.2.2
7 Release:        1
8 License:        BSD
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  5a86a01b065d3d767d8b0f7a2a3ca865
12 URL:            http://pecl.php.net/package/funcall/
13 BuildRequires:  php-devel >= 3:5.0.0
14 BuildRequires:  rpmbuild(macros) >= 1.344
15 %{?requires_php_extension}
16 Requires:       php-common >= 4:5.0.4
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Call callbacks before or after specified functions/methods being
21 called.
22
23 In PECL status of this extension is: %{_status}.
24
25 %description -l pl.UTF-8
26 Rozszerzenie to pozwala na wykonywanie odwołań przed lub po wywołaniu
27 określonej funkcji / metody.
28
29 To rozszerzenie ma w PECL status: %{_status}.
30
31 %prep
32 %setup -q -c
33
34 %build
35 cd %{_modname}-%{version}
36 phpize
37 %configure
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
43
44 %{__make} install \
45         -C %{_modname}-%{version} \
46         INSTALL_ROOT=$RPM_BUILD_ROOT \
47         EXTENSION_DIR=%{php_extensiondir}
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
49 ; Enable %{_modname} extension module
50 extension=%{_modname}.so
51 EOF
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %php_webserver_restart
58
59 %postun
60 if [ "$1" = 0 ]; then
61         %php_webserver_restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc %{_modname}-%{version}/{TODO,funcall.php}
67 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
68 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.054801 seconds and 3 git commands to generate.