]> git.pld-linux.org Git - packages/php-pecl-event.git/commitdiff
support building for multiple php versions
authorElan Ruusamäe <glen@delfi.ee>
Fri, 21 Jun 2013 17:18:37 +0000 (20:18 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 21 Jun 2013 17:18:37 +0000 (20:18 +0300)
php-pecl-event.spec

index ec07b80b81303b3ec9fefad0a9e98538d816c593..dbafb9e4ab8d01b8a06e73aaa013931b4a5f5e4c 100644 (file)
@@ -1,20 +1,21 @@
-%define                _modname        event
-%define                _status         beta
-Summary:       %{_modname} - event scheduling engine
-Summary(pl.UTF-8):     %{_modname} - silnik do planowania zdarzeń
-Name:          php-pecl-%{_modname}
+%define                php_name        php%{?php_suffix}
+%define                modname event
+%define                status          beta
+Summary:       %{modname} - event scheduling engine
+Summary(pl.UTF-8):     %{modname} - silnik do planowania zdarzeń
+Name:          %{php_name}-pecl-%{modname}
 Version:       0.9.1
 Release:       7
 License:       PHP
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: f009fd3519c14a027a8c85414208b61c
 URL:           http://pecl.php.net/package/event/
-BuildRequires: php-devel >= 3:5.0.0
-BuildRequires: rpmbuild(macros) >= 1.344
+BuildRequires: %{php_name}-devel >= 3:5.0.0
+BuildRequires: rpmbuild(macros) >= 1.650
 %{?requires_php_extension}
-Requires:      php-common >= 4:5.0.4
-Obsoletes:     php-pear-%{_modname}
+Requires:      php(core) >= 5.0.4
+Obsoletes:     php-pear-%{modname}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -25,7 +26,7 @@ system.
 This is a port of libevent to the PHP infrastructure; the API is
 similar but not identical.
 
-In PECL status of this extension is: %{_status}.
+In PECL status of this extension is: %{status}.
 
 %description -l pl.UTF-8
 To rozszerzenie pozwala na efektywne planowanie We/Wy, czasu oraz
@@ -35,13 +36,13 @@ systemu mechanizmu powiadamiania.
 Jest to port biblioteki libevent do infrastruktury PHP; API jest
 podobne, jednak nie identyczne.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
-%setup -q -c
+%setup -qc
+mv %{modname}-%{version}/* .
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
@@ -50,10 +51,10 @@ phpize
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
 
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
@@ -69,6 +70,6 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
+%doc CREDITS EXPERIMENTAL
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.043446 seconds and 4 git commands to generate.