]> git.pld-linux.org Git - packages/php-pecl-event.git/blob - php-pecl-event.spec
support building for multiple php versions
[packages/php-pecl-event.git] / php-pecl-event.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname event
3 %define         status          beta
4 Summary:        %{modname} - event scheduling engine
5 Summary(pl.UTF-8):      %{modname} - silnik do planowania zdarzeń
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.9.1
8 Release:        7
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  f009fd3519c14a027a8c85414208b61c
13 URL:            http://pecl.php.net/package/event/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 Obsoletes:      php-pear-%{modname}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is an extension to efficiently schedule IO, time and signal based
23 events using the best available IO notification mechanism for your
24 system.
25
26 This is a port of libevent to the PHP infrastructure; the API is
27 similar but not identical.
28
29 In PECL status of this extension is: %{status}.
30
31 %description -l pl.UTF-8
32 To rozszerzenie pozwala na efektywne planowanie We/Wy, czasu oraz
33 opartych na sygnałach zdarzeń za pomocą najlepszego dostępnego dla
34 systemu mechanizmu powiadamiania.
35
36 Jest to port biblioteki libevent do infrastruktury PHP; API jest
37 podobne, jednak nie identyczne.
38
39 To rozszerzenie ma w PECL status: %{status}.
40
41 %prep
42 %setup -qc
43 mv %{modname}-%{version}/* .
44
45 %build
46 phpize
47 %configure
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
53
54 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
55 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
56 ; Enable %{modname} extension module
57 extension=%{modname}.so
58 EOF
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 %php_webserver_restart
65
66 %postun
67 if [ "$1" = 0 ]; then
68         %php_webserver_restart
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc CREDITS EXPERIMENTAL
74 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
75 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.227519 seconds and 3 git commands to generate.