]> git.pld-linux.org Git - packages/performous.git/blame - performous.spec
Fix sound output when using new ffmpeg
[packages/performous.git] / performous.spec
CommitLineData
de6d16d9
JK
1#
2# TODO:
3# - update Polish description, current is outdated (it is not only a
4# karaoke game any more)
5Summary: Performous - The All-in-One Music Game
6Summary(pl.UTF-8): Performous - wiele gier muzycznych w jednej
17ceb23f 7Name: performous
0c276d1e 8Version: 0.7.0
f69e77a3 9Release: 4
17ceb23f
JK
10License: GPL v2+
11Group: Applications
0c276d1e
JR
12Source0: http://downloads.sourceforge.net/performous/performous-%{version}.tar.bz2
13# Source0-md5: 60f3f72b51a630a4aa996484aedb9526
d1cb3345 14Patch1: %{name}-libpng15.patch
b74c6e04 15Patch2: cmake.patch
f69e77a3 16Patch3: %{name}-ffmpeg.patch
17ceb23f
JK
17URL: http://performous.org/
18BuildRequires: ImageMagick-c++-devel
19BuildRequires: SDL-devel
20BuildRequires: alsa-lib-devel
3c4e0e7d 21BuildRequires: boost-devel
c411e695 22BuildRequires: cmake >= 2.6
17ceb23f 23BuildRequires: ffmpeg-devel
d9a0d954 24BuildRequires: gettext-devel
17ceb23f
JK
25BuildRequires: glew-devel
26BuildRequires: glibmm-devel
27BuildRequires: help2man
28BuildRequires: jack-audio-connection-kit-devel
6775cf17 29BuildRequires: libpng-devel
17ceb23f
JK
30BuildRequires: librsvg-devel
31BuildRequires: libsigc++-devel
32BuildRequires: libxml++-devel
2330489e 33BuildRequires: opencv-devel
17ceb23f 34BuildRequires: pango-devel
3c4e0e7d 35BuildRequires: pkgconfig
2330489e 36BuildRequires: portaudio-devel
c411e695 37Suggests: %{name}-tools = %{version}-%{release}
17ceb23f
JK
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
de6d16d9
JK
41An open-source karaoke, band and dancing game where one or more
42players perform a song and the game scores their perform ances.
43Supports songs in UltraStar, Frets on Fire and StepMania formats.
44Microphones and instruments from SingStar, Guit ar Hero and Rock Band
45as well as some dance pads are autodetected.
17ceb23f 46
c411e695 47%description -l pl.UTF-8
de6d16d9
JK
48O ile Performous można zaklasyfikować jako program do karaoke, to jest
49czymś o wiele więcej. Zamiast tylko wyświetlać tekst, wyświetlane są
50także nuty, a wykonanie jest oceniane w oparciu o to, jak dobrze
c411e695
JB
51pasuje do nut. W przeciwieństwie do innych gier tego gatunku podawana
52jest także dokładna wysokość śpiewanych tonów, więc można zobaczyć, co
53wykonuje się źle i (względnie) łatwo się poprawić.
54
55Większość dostępnych piosenek zawiera także oryginalne wokale, zaś
56wersje karaoke są dość rzadkie.
57
58Dla śpiewających niezbyt dobrze dostępny jest tryb karaoke. W tyb
59trybie wyświetlane są tylko słowa i nie ma nut ani oceniania.
60
66b61eb5
JK
61%package tools
62Summary: Performous tools
c411e695 63Summary(pl.UTF-8): Narzędzia do programu Performous
66b61eb5
JK
64Group: Applications
65
66%description tools
c411e695
JB
67Several utilities for converting data files for Performous.
68
69%description tools -l pl.UTF-8
70Zestaw narzędzi do konwersji danych dla programu Performous.
66b61eb5 71
17ceb23f 72%prep
0c276d1e 73%setup -q
d1cb3345 74%patch1 -p1
b74c6e04 75%patch2 -p1
f69e77a3 76%patch3 -p1
d1cb3345 77mkdir build
17ceb23f
JK
78
79%build
17ceb23f
JK
80cd build
81%cmake .. \
3c4e0e7d 82 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
b74c6e04
JR
83 -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags}" \
84 -DCMAKE_DEBUG_FLAGS_RELEASE="%{debugcflags}" \
3c4e0e7d 85 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
17ceb23f 86%if "%{_lib}" == "lib64"
3c4e0e7d 87 -DLIB_SUFFIX=64
17ceb23f
JK
88%endif
89
90%{__make}
91
17ceb23f
JK
92%install
93rm -rf $RPM_BUILD_ROOT
66b61eb5 94install -d $RPM_BUILD_ROOT%{_mandir}/man1
17ceb23f
JK
95
96%{__make} -C build install \
97 DESTDIR=$RPM_BUILD_ROOT
98
c411e695 99install docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
66b61eb5 100
73b4d4f2
JR
101%{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_CN}
102
0f6ae010 103%find_lang %{name} --all-name
17ceb23f
JK
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
0f6ae010 108%files -f %{name}.lang
17ceb23f 109%defattr(644,root,root,755)
c411e695 110%doc docs/{Authors,TODO,instruments}.txt
66b61eb5 111%attr(755,root,root) %{_bindir}/performous
17ceb23f 112%{_datadir}/games/%{name}
c411e695
JB
113%{_mandir}/man6/performous.6*
114%{_desktopdir}/performous.desktop
115%{_pixmapsdir}/performous.xpm
66b61eb5
JK
116
117%files tools
118%defattr(644,root,root,755)
c411e695 119%attr(755,root,root) %{_bindir}/gh_*_decrypt
66b61eb5
JK
120%attr(755,root,root) %{_bindir}/itg_pck
121%attr(755,root,root) %{_bindir}/ss_*
c411e695
JB
122%{_mandir}/man1/gh_*_decrypt.1*
123%{_mandir}/man1/ss_*.1*
This page took 0.143007 seconds and 4 git commands to generate.