]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- don't require static openssl to build engines
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.8.1
5 Release:        1
6 License:        LGPL
7 Group:          Applications
8 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  2b64a8e629bd28a00e707e35fd3eb9c7
10 Patch0:         %{name}-libdir.patch
11 URL:            http://www.opensc.org/
12 BuildRequires:  autoconf >= 2.52
13 BuildRequires:  automake
14 BuildRequires:  libassuan-devel >= 1:0.6.0
15 BuildRequires:  libtool >= 1:1.4.2-9
16 BuildRequires:  openldap-devel
17 BuildRequires:  openssl-devel
18 BuildRequires:  openct-devel
19 BuildRequires:  pam-devel
20 BuildRequires:  pcsc-lite-devel
21 BuildRequires:  readline-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # datadir is used for config files and (editable) profiles
25 %define         _datadir        %{_sysconfdir}
26 %define         mozplugindir    /usr/lib/mozilla/plugins
27
28 %description
29 libopensc is a library for accessing SmartCard devices using PC/SC
30 Lite middleware package. It is also the core library of the OpenSC
31 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
32 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
33 using private keys on the SmartCard is at the moment possible only
34 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
35 IDentity) card manufactured by Setec.
36
37 %description -l pl
38 libopensc to biblioteka do korzystania z kart procesorowych przy
39 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
40 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
41 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
42 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
43 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
44 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
45 IDentity) produkowanych przez Setec.
46
47 %package devel
48 Summary:        OpenSC development files
49 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
50 Group:          Development/Tools
51 Requires:       %{name} = %{version}
52
53 %description devel
54 OpenSC development files.
55
56 %description devel -l pl
57 Pliki dla programistów u¿ywaj±cych OpenSC.
58
59 %package static
60 Summary:        Static OpenSC libraries
61 Summary(pl):    Bibloteki statyczne OpenSC
62 Group:          Development/Tools
63 Requires:       %{name}-devel = %{version}
64
65 %description static
66 Static OpenSC libraries.
67
68 %description static -l pl
69 Statyczne biblioteki OpenSC.
70
71 %package -n pam_opensc
72 Summary:        OpenSC module for PAM
73 Summary(pl):    Modu³ PAM OpenSC
74 License:        GPL
75 Group:          Base
76 Requires:       %{name} = %{version}
77
78 %description -n pam_opensc
79 OpenSC module for PAM.
80
81 %description -n pam_opensc -l pl
82 Modu³ PAM OpenSC.
83
84 %package -n mozilla-plugin-opensc
85 Summary:        OpenSC Signer plugin for Mozilla
86 Summary(pl):    Wtyczka OpenSC Signer dla Mozilli
87 # libassuan is GPL
88 License:        GPL
89 Group:          X11/Applications
90 Requires:       %{name} = %{version}
91 Requires:       pinentry-gtk
92
93 %description -n mozilla-plugin-opensc
94 OpenSC Signer plugin for Mozilla.
95
96 %description -n mozilla-plugin-opensc -l pl
97 Wtyczka OpenSC Signer dla Mozilli.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102
103 %build
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__automake}
108 %configure \
109         --with-pin-entry=/usr/bin/pinentry-gtk \
110         --with-plugin-dir="%{mozplugindir}"
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{mozplugindir}
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install -d $RPM_BUILD_ROOT/lib
122 mv -f $RPM_BUILD_ROOT%{_libdir}/security $RPM_BUILD_ROOT/lib
123
124 # just install instead of symlinking
125 rm -f $RPM_BUILD_ROOT%{mozplugindir}/opensc-signer.so
126 mv -f $RPM_BUILD_ROOT%{_libdir}/opensc/opensc-signer.so $RPM_BUILD_ROOT%{mozplugindir}
127
128 # default config
129 mv -f $RPM_BUILD_ROOT%{_datadir}/opensc/opensc.conf{.example,}
130 mv -f $RPM_BUILD_ROOT%{_datadir}/opensc/scldap.conf{.example,}
131
132 # useless (dlopened by *.so)
133 rm -f $RPM_BUILD_ROOT%{_libdir}/libscam.{a,la} \
134         $RPM_BUILD_ROOT%{_libdir}/opensc/*.{a,la} \
135         $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.{a,la} \
136         $RPM_BUILD_ROOT/lib/security/pam_opensc.{a,la}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %doc ANNOUNCE ChangeLog NEWS docs/{pkcs-15v1_1.asn,opensc.{html,css}}
147 %attr(755,root,root) %{_bindir}/cardos-info
148 %attr(755,root,root) %{_bindir}/cryptoflex-tool
149 %attr(755,root,root) %{_bindir}/opensc-explorer
150 %attr(755,root,root) %{_bindir}/opensc-tool
151 %attr(755,root,root) %{_bindir}/pkcs11-tool
152 %attr(755,root,root) %{_bindir}/pkcs15-*
153 %attr(755,root,root) %{_libdir}/lib*.so.*.*
154 %attr(755,root,root) %{_libdir}/libscam.so
155 %dir %{_libdir}/pkcs11
156 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
157 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
158 %dir %{_libdir}/opensc
159 %attr(755,root,root) %{_libdir}/opensc/engine_opensc.so
160 %attr(755,root,root) %{_libdir}/opensc/engine_pkcs11.so
161 %dir %{_datadir}/opensc
162 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.conf
163 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.profile
164 %{_mandir}/man1/cryptoflex-tool.1*
165 %{_mandir}/man1/opensc-explorer.1*
166 %{_mandir}/man1/opensc-tool.1*
167 %{_mandir}/man1/pkcs15*
168 %{_mandir}/man[57]/*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/opensc-config
173 %attr(755,root,root) %{_libdir}/libopensc.so
174 %attr(755,root,root) %{_libdir}/libpkcs15init.so
175 %attr(755,root,root) %{_libdir}/libscconf.so
176 %attr(755,root,root) %{_libdir}/libscldap.so
177 %{_libdir}/lib*.la
178 %{_includedir}/opensc
179 %{_pkgconfigdir}/*.pc
180 %{_mandir}/man1/opensc-config.1*
181 %{_mandir}/man3/*
182
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/lib*.a
186
187 %files -n pam_opensc
188 %defattr(644,root,root,755)
189 %attr(755,root,root) /lib/security/pam_opensc.so
190
191 %files -n mozilla-plugin-opensc
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{mozplugindir}/opensc-signer.so
This page took 0.044954 seconds and 3 git commands to generate.