]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- release 2
[packages/opensc.git] / opensc.spec
1 #
2 # Conditional build:
3 %bcond_with     openct          # use OpenCT instead of PC/SC for reader access
4 %bcond_without  openpace        # OpenPACE support
5 #
6 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
7 Summary(pl.UTF-8):      Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
8 Name:           opensc
9 Version:        0.23.0
10 Release:        2
11 License:        LGPL v2.1+
12 Group:          Applications
13 #Source0Download: https://github.com/OpenSC/OpenSC/releases
14 Source0:        https://github.com/OpenSC/OpenSC/releases/download/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  35c599e673ae9205550974e2dcbe0825
16 URL:            https://github.com/OpenSC/OpenSC/wiki
17 BuildRequires:  autoconf >= 2.68
18 BuildRequires:  automake >= 1:1.10
19 BuildRequires:  cmocka-devel
20 BuildRequires:  docbook-style-xsl
21 BuildRequires:  libltdl-devel
22 BuildRequires:  libtool >= 1:1.4.2-9
23 BuildRequires:  libxslt-progs
24 %{?with_openct:BuildRequires:   openct-devel}
25 %{?with_openpace:BuildRequires: openpace-devel >= 0.9}
26 BuildRequires:  openssl-devel >= 1.1.1
27 %{!?with_openct:BuildRequires:  pcsc-lite-devel >= 1.8.22}
28 BuildRequires:  pkgconfig >= 1:0.9.0
29 BuildRequires:  readline-devel
30 BuildRequires:  rpm-build >= 4.6
31 BuildRequires:  rpmbuild(macros) >= 1.673
32 BuildRequires:  zlib-devel
33 Requires:       filesystem >= 4.0-28
34 %{?with_openpace:Requires:      openpace >= 0.9}
35 %{!?with_openct:Requires:       pcsc-lite-libs >= 1.8.22}
36 Obsoletes:      browser-plugin-opensc < 0.12
37 Obsoletes:      mozilla-plugin-opensc < 0.11.0-2
38 Obsoletes:      opensc-initramfs < 0.12.2-2
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 libopensc is a library for accessing SmartCard devices using PC/SC
43 Lite middleware package. It is also the core library of the OpenSC
44 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
45 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
46 using private keys on the SmartCard is at the moment possible only
47 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
48 IDentity) card manufactured by Setec.
49
50 %description -l pl.UTF-8
51 libopensc to biblioteka do korzystania z kart procesorowych przy
52 użyciu pakietu warstwy pośredniej PC/SC Lite. Jest to także podstawowa
53 biblioteka projektu OpenSC. Podstawowa funkcjonalność (np. SELECT
54 FILE, READ BINARY) powinna działać także z dowolną kartą procesorową
55 zgodną z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy użyciu
56 prywatnych kluczy na karcie na razie jest możliwe tylko przy użyciu
57 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
58 IDentity) produkowanych przez Setec.
59
60 %package devel
61 Summary:        OpenSC development files
62 Summary(pl.UTF-8):      Pliki dla programistów używających OpenSC
63 Group:          Development/Tools
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       libltdl-devel
66 %{?with_openct:Requires:        openct-devel}
67 Requires:       openssl-devel >= 1.1.1
68 %{!?with_openct:Requires:       pcsc-lite-devel >= 1.8.22}
69 Requires:       zlib-devel
70
71 %description devel
72 OpenSC development files.
73
74 %description devel -l pl.UTF-8
75 Pliki dla programistów używających OpenSC.
76
77 %package static
78 Summary:        Static OpenSC library
79 Summary(pl.UTF-8):      Bibloteka statyczna OpenSC
80 Group:          Development/Tools
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static OpenSC library.
85
86 %description static -l pl.UTF-8
87 Biblioteka statyczna OpenSC.
88
89 %package -n bash-completion-opensc
90 Summary:        Bash completion for OpenSC commands
91 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów poleceń OpenSC
92 Group:          Applications/Shells
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       bash-completion >= 1:2.0
95 BuildArch:      noarch
96
97 %description -n bash-completion-opensc
98 Bash completion for OpenSC commands.
99
100 %description -n bash-completion-opensc -l pl.UTF-8
101 Bashowe uzupełnianie parametrów poleceń OpenSC.
102
103 %prep
104 %setup -q
105
106 %build
107 %{__libtoolize}
108 %{__aclocal} -I m4
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --sysconfdir=%{_sysconfdir}/opensc \
114         %{?with_openct:--enable-openct --disable-pcsc} \
115         %{!?with_openct:--enable-pcsc --disable-openct} \
116         %{!?with_openpace:--disable-openpace} \
117         --disable-silent-rules \
118         --disable-strict \
119         --enable-doc \
120         --with-completiondir=%{bash_compdir} \
121         --with-pcsc-provider=%{_libdir}/libpcsclite.so.1
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_libdir}/pkcs11}
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT \
131         xdg_autostartdir=/etc/xdg/autostart
132
133 # not needed (dlopened by soname)
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{onepin-opensc-pkcs11,opensc-pkcs11,pkcs11-spy}.la
135 # API not exported
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{opensc,smm-local}.la
137
138 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc NEWS README doc/tools/tools.html
149 %attr(755,root,root) %{_bindir}/cardos-tool
150 %attr(755,root,root) %{_bindir}/cryptoflex-tool
151 %attr(755,root,root) %{_bindir}/dnie-tool
152 %attr(755,root,root) %{_bindir}/egk-tool
153 %attr(755,root,root) %{_bindir}/eidenv
154 %attr(755,root,root) %{_bindir}/gids-tool
155 %attr(755,root,root) %{_bindir}/goid-tool
156 %attr(755,root,root) %{_bindir}/iasecc-tool
157 %attr(755,root,root) %{_bindir}/netkey-tool
158 %attr(755,root,root) %{_bindir}/npa-tool
159 %attr(755,root,root) %{_bindir}/openpgp-tool
160 %attr(755,root,root) %{_bindir}/opensc-asn1
161 %attr(755,root,root) %{_bindir}/opensc-explorer
162 %attr(755,root,root) %{_bindir}/opensc-notify
163 %attr(755,root,root) %{_bindir}/opensc-tool
164 %attr(755,root,root) %{_bindir}/piv-tool
165 %attr(755,root,root) %{_bindir}/pkcs11-register
166 %attr(755,root,root) %{_bindir}/pkcs11-tool
167 %attr(755,root,root) %{_bindir}/pkcs15-crypt
168 %attr(755,root,root) %{_bindir}/pkcs15-init
169 %attr(755,root,root) %{_bindir}/pkcs15-tool
170 %attr(755,root,root) %{_bindir}/sc-hsm-tool
171 %attr(755,root,root) %{_bindir}/westcos-tool
172 %attr(755,root,root) %{_libdir}/libopensc.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libopensc.so.8
174 %attr(755,root,root) %{_libdir}/libsmm-local.so.*.*.*
175 %attr(755,root,root) %ghost %{_libdir}/libsmm-local.so.8
176 # PKCS11 modules
177 %attr(755,root,root) %{_libdir}/onepin-opensc-pkcs11.so
178 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
179 %attr(755,root,root) %{_libdir}/pkcs11-spy.so
180 %attr(755,root,root) %{_libdir}/pkcs11/onepin-opensc-pkcs11.so
181 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
182 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
183 %dir %{_sysconfdir}/opensc
184 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opensc/opensc.conf
185 %dir %{_datadir}/opensc
186 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
187 %{_desktopdir}/org.opensc.notify.desktop
188 /etc/xdg/autostart/pkcs11-register.desktop
189 %if %{with openpace}
190 /etc/eac/cvc/DESCHSMCVCA00001
191 /etc/eac/cvc/DESRCACC100001
192 %endif
193 %{_mandir}/man1/cardos-tool.1*
194 %{_mandir}/man1/cryptoflex-tool.1*
195 %{_mandir}/man1/dnie-tool.1*
196 %{_mandir}/man1/egk-tool.1*
197 %{_mandir}/man1/eidenv.1*
198 %{_mandir}/man1/gids-tool.1*
199 %{_mandir}/man1/goid-tool.1*
200 %{_mandir}/man1/iasecc-tool.1*
201 %{_mandir}/man1/netkey-tool.1*
202 %{_mandir}/man1/npa-tool.1*
203 %{_mandir}/man1/openpgp-tool.1*
204 %{_mandir}/man1/opensc-asn1.1*
205 %{_mandir}/man1/opensc-explorer.1*
206 %{_mandir}/man1/opensc-notify.1*
207 %{_mandir}/man1/opensc-tool.1*
208 %{_mandir}/man1/piv-tool.1*
209 %{_mandir}/man1/pkcs11-register.1*
210 %{_mandir}/man1/pkcs11-tool.1*
211 %{_mandir}/man1/pkcs15-crypt.1*
212 %{_mandir}/man1/pkcs15-init.1*
213 %{_mandir}/man1/pkcs15-tool.1*
214 %{_mandir}/man1/sc-hsm-tool.1*
215 %{_mandir}/man1/westcos-tool.1*
216 %{_mandir}/man5/opensc.conf.5*
217 %{_mandir}/man5/pkcs15-profile.5*
218
219 %files devel
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/libopensc.so
222 %attr(755,root,root) %{_libdir}/libsmm-local.so
223 %{_pkgconfigdir}/opensc-pkcs11.pc
224
225 %files static
226 %defattr(644,root,root,755)
227 %{_libdir}/libopensc.a
228
229 %files -n bash-completion-opensc
230 %defattr(644,root,root,755)
231 %{bash_compdir}/cardos-tool
232 %{bash_compdir}/cryptoflex-tool
233 %{bash_compdir}/dnie-tool
234 %{bash_compdir}/egk-tool
235 %{bash_compdir}/eidenv
236 %{bash_compdir}/gids-tool
237 %{bash_compdir}/goid-tool
238 %{bash_compdir}/iasecc-tool
239 %{bash_compdir}/netkey-tool
240 %{bash_compdir}/npa-tool
241 %{bash_compdir}/openpgp-tool
242 %{bash_compdir}/opensc-asn1
243 %{bash_compdir}/opensc-explorer
244 %{bash_compdir}/opensc-notify
245 %{bash_compdir}/opensc-tool
246 %{bash_compdir}/piv-tool
247 %{bash_compdir}/pkcs11-register
248 %{bash_compdir}/pkcs11-tool
249 %{bash_compdir}/pkcs15-crypt
250 %{bash_compdir}/pkcs15-init
251 %{bash_compdir}/pkcs15-tool
252 %{bash_compdir}/sc-hsm-tool
253 %{bash_compdir}/westcos-tool
This page took 0.073968 seconds and 4 git commands to generate.