]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- updated cflags patch to remove -march=i686 from CFLAGS
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 23 Jan 2011 06:42:37 +0000 (06:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- pass cmake options to disable -O3 overrides and -msse/-msse2 on CPUs which possibly don't support SSE

Changed files:
    opencv-cflags.patch -> 1.2
    opencv.spec -> 1.22

opencv-cflags.patch
opencv.spec

index 804d1045f4a309fd6e18077edc9a4918884a2a94..58b14d480646ef1f2a358d7e1c0ec3c59a87dd47 100644 (file)
@@ -9,3 +9,20 @@
  if(MSVC)
      set(EXTRA_C_FLAGS "${EXTRA_C_FLAGS} /D _CRT_SECURE_NO_DEPRECATE /D _CRT_NONSTDC_NO_DEPRECATE /D _SCL_SECURE_NO_WARNINGS")
      # 64-bit portability warnings, in MSVC8
+@@ -916,16 +918,6 @@
+         set(EXTRA_C_FLAGS "${EXTRA_C_FLAGS} -Werror")
+     endif()
+-    if(X86)
+-        if(NOT MINGW64)
+-            if(NOT X86_64)
+-                if(NOT APPLE)
+-                    set(EXTRA_C_FLAGS "${EXTRA_C_FLAGS} -march=i686")
+-                endif()
+-            endif()
+-        endif()
+-    endif()
+-
+     # Other optimizations
+     if(USE_OMIT_FRAME_POINTER)
+         set(EXTRA_C_FLAGS_RELEASE "${EXTRA_C_FLAGS_RELEASE} -fomit-frame-pointer")
index 871d1d7b64a4b12cad933eb492704cb580f0d59c..a0cd4a73477e430ec8a47dee61333e6c98a98157 100644 (file)
@@ -127,21 +127,27 @@ Wiązania Pythona do OpenCV.
 install -d build
 cd build
 %cmake .. \
-%ifarch i686 pentium4 athlon %{x8664}
+       -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
+       -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
+%ifarch pentium4 %{x8664}
+       -DENABLE_SSE=ON \
        -DENABLE_SSE2=ON \
+%else
+       -DENABLE_SSE=OFF \
+       -DENABLE_SSE2=OFF \
 %endif
        -DBUILD_NEW_PYTHON_SUPPORT=ON \
-%if %{with xine}
-       -DWITH_XINE=ON \
-%endif
-       -DWITH_GSTREAMER=OFF \
+       -DUSE_O3=OFF \
        -DWITH_1394=ON \
        -DWITH_FFMPEG=ON \
+       -DWITH_GSTREAMER=OFF \
        -DWITH_GTK=ON \
-       -DWITH_V4L=ON
+       -DWITH_V4L=ON \
+%if %{with xine}
+       -DWITH_XINE=ON
+%endif
 
-%{__make} \
-       VERBOSE=1
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.039424 seconds and 4 git commands to generate.