]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- pl
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 22 Jan 2011 20:46:56 +0000 (20:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- more BRs
- static gone due to cmake

Changed files:
    opencv.spec -> 1.21

opencv.spec

index 0ef3f9844ddeb91b6f83bf68fe41a79d724040c9..871d1d7b64a4b12cad933eb492704cb580f0d59c 100644 (file)
@@ -1,8 +1,10 @@
 #
-# TODO: re-enable static libs
+# Conditional build:
+%bcond_with    gstreamer       # GStreamer support
+%bcond_with    xine            # XINE support (GPL)
 #
-%bcond_with    xine
 Summary:       A library of programming functions mainly aimed at real time computer vision
+Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
 Version:       2.2.0
 Release:       6
@@ -14,25 +16,43 @@ Source0:    http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}.tar.bz
 Patch0:                %{name}-multilib.patch
 Patch1:                %{name}-cflags.patch
 Patch2:                %{name}-link.patch
-URL:           http://opencv.willowgarage.com
-BuildRequires: cmake
+URL:           http://opencv.willowgarage.com/
+BuildRequires: OpenEXR-devel
+BuildRequires: cmake >= 2.4
+BuildRequires: doxygen
 BuildRequires: ffmpeg-devel
+%if %{with gstreamer}
+BuildRequires: gstreamer-devel >= 0.10
+BuildRequires: gstreamer-plugins-base-devel >= 0.10
+%endif
 BuildRequires: jasper-devel
+BuildRequires: gtk+2-devel
 BuildRequires: libdc1394-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libraw1394-devel
+BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
 BuildRequires: libtool
+BuildRequires: libv4l-devel
 BuildRequires: pkgconfig
 BuildRequires: python-devel
+BuildRequires: python-numpy-devel
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.577
 BuildRequires: sed >= 4.0
 BuildRequires: swig-python
 BuildRequires: zlib-devel
-%pyrequires_eq python-libs
 %{?with_xine:BuildRequires:    xine-lib-devel}
+# TODO:
+# - unicap (libunicap, libucil)
+# - gstreamer
+# - pvapi (PvApi.h)
+# - Qt (bcond replacing GTK+?)
+# - tbb (tbb.pc)
+# - cuda (on bcond)
+# - eigen2/eigen3 (Eigen/Core headers)
+# - ipp (libippi)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                skip_post_check_so      libhighgui.so.%{version}
@@ -41,37 +61,58 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 OpenCV (Open Source Computer Vision) is a library of programming
 functions mainly aimed at real time computer vision.
 
-Example applications of the OpenCV library are Human-Computer
-Interaction (HCI); Object Identification, Segmentation and
-Recognition; Face Recognition; Gesture Recognition; Motion Tracking,
-Ego Motion, Motion Understanding; Structure From Motion (SFM); Stereo
-and Multi-Camera Calibration and Depth Computation; Mobile Robotics.
+Example applications of the OpenCV library are:
+- Human-Computer Interaction (HCI)
+- Object Identification, Segmentation and Recognition
+- Face Recognition
+- Gesture Recognition
+- Motion Tracking
+- Ego Motion, Motion Understanding
+- Structure From Motion (SFM)
+- Stereo and Multi-Camera Calibration and Depth Computation
+- Mobile Robotics.
+
+%description -l pl.UTF-8
+OpenCV (Open Source Computer Vision) to biblioteka funkcji
+przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
+
+Przykładowe zastosowania biblioteki OpenCV to
+- interakcje człowiek-komputer (HCI)
+- identyfikacja, segmentacja i rozpoznawanie obiektów
+- rozpoznawanie twarzy
+- rozpoznawanie gestów
+- śledzenie ruchu
+- rozumienie ruchu
+- SFM (Structure From Motion)
+- kalibracja dwu- i wielokamerowa, obliczanie głębi
+- robotyka ruchu.
 
 %package devel
-Summary:       Header files and develpment documentation for opencv
+Summary:       Header files for OpenCV library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki OpenCV
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Obsoletes:     opencv-static
 
 %description devel
-Header files and opencv documentation.
-
-%package static
-Summary:       Static opencv library
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+Header files for OpenCV library.
 
-%description static
-This package contains the static library used for development.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki OpenCV.
 
 %package -n python-opencv
 Summary:       OpenCV Python bindings
-Group:         Development/Languages/Python
-%pyrequires_eq  python
+Summary(pl.UTF-8):     Wiązania Pythona do OpenCV
+Group:         Libraries/Python
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+%pyrequires_eq  python-libs
 
 %description -n python-opencv
 OpenCV Python bindings.
 
+%description -n python-opencv -l pl.UTF-8
+Wiązania Pythona do OpenCV.
+
 %prep
 %setup -q -n OpenCV-%{version}
 
@@ -85,7 +126,7 @@ OpenCV Python bindings.
 %build
 install -d build
 cd build
-%cmake \
+%cmake .. \
 %ifarch i686 pentium4 athlon %{x8664}
        -DENABLE_SSE2=ON \
 %endif
@@ -97,8 +138,7 @@ cd build
        -DWITH_1394=ON \
        -DWITH_FFMPEG=ON \
        -DWITH_GTK=ON \
-       -DWITH_V4L=ON \
-       ../
+       -DWITH_V4L=ON
 
 %{__make} \
        VERBOSE=1
@@ -125,24 +165,21 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/lib*so.*.*
+%attr(755,root,root) %{_bindir}/opencv_*
+%attr(755,root,root) %{_libdir}/libopencv_*.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.2
 %dir %{_datadir}/opencv
-%{_datadir}/opencv/doc
+%doc %{_datadir}/opencv/doc
 %{_datadir}/opencv/haarcascades
 %{_datadir}/opencv/lbpcascades
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
+%attr(755,root,root) %{_libdir}/libopencv_*.so
 %{_includedir}/opencv
 %{_includedir}/opencv2
 %{_datadir}/opencv/OpenCVConfig.cmake
-%{_pkgconfigdir}/*.pc
-
-#%files static
-#%defattr(644,root,root,755)
-#%{_libdir}/lib*.a
+%{_pkgconfigdir}/opencv.pc
 
 %files -n python-opencv
 %defattr(644,root,root,755)
This page took 0.128248 seconds and 4 git commands to generate.