]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- initial
[packages/opencv.git] / opencv.spec
1 %bcond_with     xine
2 %define snap    pre1
3 Summary:        A library of programming functions mainly aimed at real time computer vision
4 Name:           opencv
5 Version:        1.1
6 Release:        0.%{snap}.1
7 Epoch:          1
8 License:        BSD
9 Group:          Libraries
10 Source0:        http://dl.sourceforge.net/opencvlibrary/%{name}-%{version}%{snap}.tar.gz
11 # Source0-md5:  b147b7cd3c059831c415c5a2bcecdf95
12 URL:            http://opencv.willowgarage.com
13 BuildRequires:  autoconf >= 2.53
14 BuildRequires:  automake
15 BuildRequires:  ffmpeg-devel
16 BuildRequires:  jasper-devel
17 BuildRequires:  libdc1394-devel
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libpng-devel
20 BuildRequires:  libraw1394-devel
21 BuildRequires:  libtiff-devel
22 BuildRequires:  python-devel
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  zlib-devel
25 %pyrequires_eq  python-libs
26 %{?with_xine:BuildRequires:     xine-lib-devel}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 OpenCV (Open Source Computer Vision) is a library of programming
31 functions mainly aimed at real time computer vision.
32
33 Example applications of the OpenCV library are Human-Computer
34 Interaction (HCI); Object Identification, Segmentation and
35 Recognition; Face Recognition; Gesture Recognition; Motion Tracking,
36 Ego Motion, Motion Understanding; Structure From Motion (SFM); Stereo
37 and Multi-Camera Calibration and Depth Computation; Mobile Robotics.
38
39 %package devel
40 Summary:        Header files and develpment documentation for opencv
41 Group:          Development/Libraries
42 Requires:       %{name} = %{epoch}:%{version}-%{release}
43
44 %description devel
45 Header files and opencv documentation.
46
47 %package static
48 Summary:        Static opencv library
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
51
52 %description static
53 This package contains the static library used for development.
54
55 %package -n python-opencv
56 Summary:        OpenCV Python bindings
57 Group:          Development/Languages/Python
58 %pyrequires_eq  python
59 Requires:       %{name} = %{version}-%{release}
60
61 %description -n python-opencv
62 OpenCV Python bindings.
63
64 %prep
65 %setup -q -n %{name}-%{version}.0
66
67 %build
68 %configure \
69 %ifarch i686 pentium4 athlon %{x8664}
70         --enable-sse2 \
71 %else
72         --disable-sse2 \
73 %endif
74         --with-python \
75         --with%{!?with_xine:-out}-xine \
76         --with-ffmpeg \
77         --with-1394libs \
78         --with-v4l \
79         --with-gtk \
80         --without-gstreamer \
81         --without-quicktime
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS COPYING ChangeLog THANKS TODO
99 %doc docs/*.{htm,rtf,png,txt} docs/papers docs/ref
100 %attr(755,root,root) %{_bindir}/*
101 %attr(755,root,root) %{_libdir}/lib*so.*.*
102 %attr(755,root,root) %ghost %{_libdir}/lib*.so.2
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/lib*.so
107 %{_libdir}/lib*.la
108 %{_includedir}/opencv
109 %{_pkgconfigdir}/*.pc
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/lib*.a
114
115 %files -n python-opencv
116 %defattr(644,root,root,755)
117 %dir %{py_sitedir}/opencv
118 %attr(755,root,root) %{py_sitedir}/opencv/*.so
119 %{py_sitedir}/opencv/*.py[co]
This page took 0.774815 seconds and 3 git commands to generate.